PDA

View Full Version : vB3 Style - "Last Posts" Modification (v1.2a)


Krakken
15 Jan 2003, 01:15
vBulletin Hack: vB3 Style - "Last Posts" Modification.
Version: 1.2a

Designed and Coded by: Krakken
Copyright © 2003

This hack will change the "Last Post" section on your Forum Homepage to a style similar to vBulletin 3.0.
It will show the last active thread someone posted and it's current icon in on the forum homepage in the place of the date and time. The date is completely removed in this version and the time is placed underneath the thread title next to the name of the last person to post in that thread.

Example:
http://www.inspire-fx.com/images/lastpostex.png

Working Demo:
http://www.randomrubbish.net/bulletin

Files to Edit: "index.php" "forumdisplay.php" (x2)
Templates to Edit: "forumhome_lastpostby" (x1)

Current Releases:
v1.2a - Added a fix so the thread shows in the category view as well.
v1.1a - The script now only uses two querys (one for thread and one for thread icon) to display for all forums. Also, thread icons can now be seen next to thread title.
v1.0a - Changes "Last Post" template and adds last active thread view to forum home.

If you like this hack please click INSTALL (http://www.vbulletin.org/forum/misc.php?s=&action=install&threadid=47726). Thanks. ;)

Krakken
15 Jan 2003, 01:20
You can view an active demo here:
http://www.randomrubbish.net/bulletin

I have also attached a small screenshot to give you the idea.

snyx
15 Jan 2003, 01:42
yeah ppn (i think, oh tech) created this ages ago
but not the vb3 style.. none the less I prefer to use my own style.

Brad
15 Jan 2003, 01:47
how many querys dose it add to go to the last thread? I also released something that would go to the last thread (not post) that works like the method vB uses to send a user to the lastest post in a forum.

Krakken
15 Jan 2003, 02:02
PPN's was a lot more complicated to install than this one is.

Vivi Ornitier
15 Jan 2003, 02:07
wat's the dif between just using the lasttitlehacks we have right now and changing the layout around a bit to achieve that. Good hack tho, good job!

alkatraz
15 Jan 2003, 02:08
Installed, works great, thx!

Here is a live demo on my forums:
http://forums.northwestnissans.com/

BigJohnson
15 Jan 2003, 02:11
one query per forum right?

So which one uses less queries this one or PPN's?

Krakken
15 Jan 2003, 04:18
Okay that is now fixed; the script uses only two querys altogether.
I have also added the thread icon display.

Boofo
15 Jan 2003, 06:15
Without the date, though, how do you know when the last post was done? PPN's hack is better in that way. :)

TECK
15 Jan 2003, 07:16
This hack will add 2 queries to your forumhome.
PPN's is more complicated, true, but it will add no extra queries.
Also, you could use a LEFT JOIN for the icon, if you want to get the path, so you save a query...

BigJohnson
15 Jan 2003, 09:33
true also this hack right here doesnt work on subdomains. It just doesn't show the thread title.

Erwin
15 Jan 2003, 11:13
TECK is absolutely correct. PPN's hack adds no additional queries. This is why I use his hack. :)

Krakken
15 Jan 2003, 12:20
Originally posted by TECK
This hack will add 2 queries to your forumhome.
PPN's is more complicated, true, but it will add no extra queries.
Also, you could use a LEFT JOIN for the icon, if you want to get the path, so you save a query...

Hmm could you elaborate on how to do this? I have never used "LEFT JOIN" before. Thanks.
Also there was a little bit I left out of the installation file which is fixed now sorry.

Krakken
15 Jan 2003, 12:21
Originally posted by BigJohnson
true also this hack right here doesnt work on subdomains. It just doesn't show the thread title.

That might have been because of a bug in the installation. Sorry, fixed now.

Krakken
15 Jan 2003, 12:24
Originally posted by Boofo
Without the date, though, how do you know when the last post was done? PPN's hack is better in that way. :)

You can add the date very easily by adding:
$forum[lastpostdate]

...where you want it to appear in the template.

USODJA
17 Jan 2003, 22:56
I am having problems wth this picking up the proper thread in sub forums!

Krakken
18 Jan 2003, 13:00
All fixed. :)
Download and follow instructions to upgrade from v1.1a to v1.2a.

Krakken
03 Feb 2003, 18:28
That was just a little side-thing I made. I may make it into a proper hack one day. Contact me on AIM: "Krakkius" and I will try to show you what to do.

Boofo
03 Feb 2003, 18:31
Originally posted by Krakken
That was just a little side-thing I made. I may make it into a proper hack one day. Contact me on AIM: "Krakkius" and I will try to show you what to do.

I'd be interested in seeing that also. ;)

Krakken
03 Feb 2003, 18:36
Heh, alrite, I will see what I can do this weekend! :)

Xyphen
03 Mar 2003, 21:38
Works Perfectly fine on vB2.3.0, thank you so much!

Krakken
04 Mar 2003, 15:53
Your most welcome. :)
Thanks for the comment buddy!

Matt
16 Mar 2003, 15:30
I tried using this hack but it seemed to grab threads from the wrong forums so I had two of the same threads showing up as the last thread in two seperate forums when the thread only exists in one of them :-\

Fi_InCogNiTo
17 Mar 2003, 17:47
I found a small bug in this. If the topic has been moved, and it is the most recent topic in a forum, it doesn't redirect you to the new location. It just shows you a blank section that you may reply to ;)

I have the quick reply hack and that's all I can see when this happens.

Fi_InCogNiTo
17 Mar 2003, 17:52
Other than that, looks very nice <me clicks install>

Fi_InCogNiTo
17 Mar 2003, 23:06
Yesterday at 11:30 AM Matt said this in Post #24 (http://www.vbulletin.org/forum/showthread.php?postid=367480#post367480)
I tried using this hack but it seemed to grab threads from the wrong forums so I had two of the same threads showing up as the last thread in two seperate forums when the thread only exists in one of them :-\


I am also having this problem. I see 3 of the same topics in 3 different forums. Two of them are incorrect.

Krakken
18 Mar 2003, 10:06
Hmm I really have no idea why it's doing that. I'll take a look at the code in a bit. Could you give me a little more information? Maybe a screenshot and vB version? Thanks.

Krakken
18 Mar 2003, 10:10
Ah I just visited your forums and it's because of the way you structure your forum. I will try to make a fix for it and release it as soon as I can.

Fi_InCogNiTo
18 Mar 2003, 14:19
ty, hack looks great. I'll uninstall until there is a fix ;)

Fenriz
30 Mar 2003, 20:14
Why "Show a default icon" is totally desabled in this hack? I enabled it in Control Panel, but no effect.. Please, correct it.
------------------
Show a default icon if a user doesn't choose a message icon or is unable to choose one based on forum settings? {imagesfolder}/icons/icon1.gif will be used

theXME
23 Apr 2003, 03:40
A very great Hack :) I installed it, but i had a problem (vB 2.2.9). I could find the problem and now the hack works fine *hehe*
I can't explain the problem in english, but i will try it.
You must delete the spaces on the left of the code.
For ex:
// Wrong:

if {

// Right:

if {

Sorry for my bad english, but i'm german (15) :D

Airs
23 Apr 2003, 04:17
Is there a way to remove the time and put there "By" instead? thnx in advance!

theXME
23 Apr 2003, 05:23
That's simple.

Replace this

<font color="{timecolor}">$forum[lastposttime]</font>


with this

by

I hope you meaned that.

Airs
23 Apr 2003, 05:52
Today at 05:23 AM theXME said this in Post #34 (http://www.vbulletin.org/forum/showthread.php?postid=385827#post385827)
That's simple.

Replace this

<font color="#FF9C58">$forum[lastposttime]</font>


with this

by

I hope you meaned that.
i cant seem to find <font color="#FF9C58">$forum[lastposttime]</font> anywhere? oO

theXME
23 Apr 2003, 06:19
Ohh, the Forum replaced it :D

<font color="{/timecolor/}">$forum[lastposttime]</font>

But without the '/' at timecolor.

Krakken
23 Apr 2003, 17:32
Thanks for everyones comments. Unfortunately I cannot provide support for this hack anymore because my server ran out and I am not intending on re-installing my forums until I can get a graphics person. This looks like it will probably take a while. Sorry to anyone who I said I would help and haven't. I may be able to pick up this project again and make a v2 for you all with a nice menu etc. in the future sometime. ;)

theXME: Strange. That shouldn't make any difference seeing as PHP ignores whitespaces.

Tungsten
28 Apr 2003, 22:43
What's the thread ID for PPN's hack?

Boofo
28 Apr 2003, 22:50
Check his profile. ;)

Tungsten
29 Apr 2003, 02:36
Today at 05:50 PM Boofo said this in Post #39 (http://www.vbulletin.org/forum/showthread.php?postid=388640#post388640)
Check his profile. ;)

Tried that. He's no longer listed as PPN, ostensibly because he has changed his user name. I guess I should know what he changed it to, but I've been lax at keeping up with such things. ;)

Boofo
29 Apr 2003, 03:24
http://www.vbulletin.org/forum/showthread.php?s=&threadid=28561

hashesh
26 May 2003, 04:26
I have one section of forums that is 3 levels deep. Its doesnt work on the top level. the lower 2 levels are great.

Look at the PBX systems section for example:
http://www.pbxtech.info/forums/index.php

This is a GREAT hack! thanks

hashesh
03 Jun 2003, 18:04
does nobody know how to fix this?

Conundrum9
08 Jun 2003, 23:50
I've found part of the problem...At least on my board.

It seems that the forums that grab threat titles from other forums are sub-forums that are 4 levels deep that are listed under forums that are 3 levels deep. When I removed the 4 level deep forum from the category that it eleviated the problem of grabing thread titles from another forum, but when the 4 level sub-forum was returned the category under a 3 level sub-forum the grabing of a thread from that sub-forum occured again.

I don't know very much about php so I doubt that I'll be able to come up with a solution (though I am trying), but maybe that will help someone else figure something out.

edit: I gave the wrong levels deep

chipheodeptrai
25 Jun 2003, 03:37
I have some problems too...

some special characters is error with this hack, exp : " > &qu...
or when one thread have 2 pages and i click to this thread..i dont have last post...only the first post...

sorry for my english :(

ajk
30 Jun 2003, 01:10
I just rencently installed this. On my index.php page, it only shows the date and user name. On the actual forums, the title, time, and posted by work fine. I even reindexed all my forums. I did that more for maint..

Can someone tell me what to fix to get the title to appear on the index.php page? You can see what I mean at http://www.drumsmith.com

Thanks in advance,

hashesh
30 Jun 2003, 01:40
I had the same problem.
this one works: http://www.vbulletin.org/forum/showthread.php?s=&threadid=28561

Exo
19 Aug 2003, 13:44
problems with sub forums!

Agent XY
04 Oct 2003, 18:16
hi,

my notepad can't found "// set defaults" in forumdisplay.php, why???

(2.3.2 vB version)

Mäuschen
11 Oct 2003, 22:24
Hello,
i have a question...

vBulletin Hack: vB3 Style - "Last Posts" Modification.
Version: 1.1a
Designed and Coded by: Krakken Copyright © 2003

What do I have to enter, so that with "last post" additionally still the date is indicated?

Please answer in simple words, since my English is very bad. For dieden contribution I use AltaVista.

Bye Mäuschen.

Diggin
11 Oct 2003, 23:01
put - $forum[lastpostdate] somewhere in there

Mäuschen
11 Oct 2003, 23:18
Thanks...


I found help in the vBulletin Support Forum:

____________________________________

Search in the Template "forumhome_lastpostby":

<font color="{timecolor}">$forum[lastposttime]</font>

and replace it with: :

$forum[lastpostdate] <font color="{timecolor}">$forum[lastposttime]</font>

____________________________________

Bye Mäuschen.

Agent XY
23 Oct 2003, 21:04
hi,

my notepad can't found "// set defaults" in forumdisplay.php, why???

(2.3.2 vB version)
*push&edit*

Edit: I have the german vb version :)