View Full Version : Problem with newreply.php (Part 2)

09 Feb 2003, 17:47

I can't access the other thread, I tried to upload my newreply.php and it won't let me access that thread anymore. If one of the mods want to delete it, be my guest.

Basically, I tried what Erwin suggested and I am still getting the same error message:

Parse error: parse error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /home/virtual/site98/fst/var/www/html/testvb/newreply.php(48) : eval()'d code on line 1

Anymore ideas?

09 Feb 2003, 17:48
nevertheless you are not allowed to upload your newreply.php.

(i delete the other thread.)

09 Feb 2003, 17:49
Sorry Xenon, I didn't know that :ermm:.

09 Feb 2003, 21:53
You've got white space in that file... are you sure there are NO spaces at the beginning and end of file? And the same message comes up with an unhacked newreply.php?

10 Feb 2003, 00:06

I have downloaded a brand new version off of vbulletin.com and uploaded it directly from the unzipped folder and I am still getting the same error message.

Can I send you my newreply.php folder?

10 Feb 2003, 00:26
Check your templates. Revert them to the base code. (Any that have to do with posting the reply) This is just a hunch, but it couldn't hurt to try.

10 Feb 2003, 00:29
Nothing to do with templates. It's a PHP error, and HTML can't give you that.

I'm quite sure that it's the way you are uploading it. Try a different FTP program. You should not get the same error if you are sure you are uploading an unhacked, virgin newreply.php.

10 Feb 2003, 00:30
All the ones having to do with newreply are in their original state.

I am not sure if I mentioned this before but I am only having a problem with this when I try to click the "quote" button from a post. Everything else is working fine.

10 Feb 2003, 00:31

Not sure if my recent reply changes anything, so I will wait for some instruction. Also I have used CuteFTP for 2 years now and never had a problem, why would it only be happening with newreply.php?

10 Feb 2003, 00:35
So newreply works, but quote doesn't? Have you done anything to your functions.php? Try reverting that and see if the problem disappears.

10 Feb 2003, 00:40
I have extensively hacked admin/functions.php with all the things I have installed; however, I uploaded a fresh copy of admin/functions.php and still getting the same error, possibly another file?

Also, new reply is working flawlessly it is just when I click "quote" do I get an error message.

Thanks for your help Erwin!

10 Feb 2003, 01:18
Is it only with quoting a particular post? Or all posts? Or posts by a particular member? Also, try uploading an unhacked forums/global.php and see if that fixes it.

10 Feb 2003, 02:41

I will try that in a few minutes. This may help: www.joelrotunda.org/hacks.htm

Thanks again.

10 Feb 2003, 03:00

You won't believe this but it actually was a template. As I was compiling my hack list (above) I stumbled across something at vbulletintemplates.com whereas someone was having the same problem. Needless to say, I followed the links that were provided to fix it and voila, it was gone! YAY! :D

Here is the thread: http://www.vbulletintemplates.com/mods/showthread.php?s=&threadid=2870

I appreciate your help Erwin, you defintely led me in some good directions :).

10 Feb 2003, 03:25
There you go... I have to eat my words! :) Very unusual for a template to do this, unless it's the phpinclude template, but I guess it's possible if the template is calling the wrong function of a PHP file. :)

10 Feb 2003, 22:38
Okay, I looked into this in more detail, and was able to replicate the error myself.

It's the quotereply template - I guess you tried to add the Date and Time to the quote box. You can do that - just move the variables to the BEGINNING of the line ie. before the poster name and after [i]. That will stop the error. It's to do with the way it is parsed.