PDA

View Full Version : SQL Errors.


laeth
26 Feb 2005, 21:59
Heya,

When I first ran the installer file I got a SQL error (which I stupidly didnt store somewhere).

Anyway I then decided to use the delete functions. This is where I got the:

Invalid SQL: ALTER TABLE vb3_userfield DROP field;
mysql error: Can't DROP 'field'; check that column/key exists

mysql error number: 1091

So I looked on the forums here and found a post saying too add two lines of code. One before the data query and one after. I did this, and now I get the error.

Database error in vBulletin 3.0.3:

Invalid SQL: CREATE TABLE `vb3_rpg_lottery` (
`lotteryid` int(5) NOT NULL auto_increment,
`lotteryname` varchar(20) NOT NULL default '',
`lotterym` varchar(50) NOT NULL default '',
`prize` int(10) NOT NULL default '0',
`dateset` varchar(35) NOT NULL default '',
`dateend` varchar(35) NOT NULL default '',
`cost` int(6) NOT NULL default '0',
`sold` int(5) NOT NULL default '0',
`active` int(2) NOT NULL default '0',
`editing` int(5) NOT NULL default '',
PRIMARY KEY (`lotteryid`,`lotteryid`)
) TYPE=MyISAM;
mysql error: Duplicate column name 'lotteryid'

mysql error number: 1060

When I run the delete option again, I dont get any errors anymore. But this error keeps popping up whenever I try and install the tables.

I have looked inside phpmyadmin for lotteryid, and I get four matches within the vb3_templates table.

Any help would be cool, not sure what to do. Can I just ignore it?

Thanks.

Revan
26 Feb 2005, 22:54
http://www.vbulletin.org/forum/showpost.php?p=614501&postcount=8
This file might help. Try running install with that one. It SHOULD amend to the installation, provided its not a table half added.
If this doesn't solve your problem, then you have to manually edit the profilefield table, drop the RPG related stuff in there, and manually create the field through the ACP.

laeth
26 Feb 2005, 23:10
Unfortunatly that didnt do the trick. I got the same error.

What do you mean add the field manually through the ACP?

Thanks again.

EDIT:Nvm, I managed to get the tables to work.

Now I just need to figure out the lank posts problem. Also, my post bit info doesnt seem to want to update. The extended rpg stats works, but the post bit doesnt. Any ideas?

EDIT2: Well everything seems to be working now. The reason I was getting blank posts afaik is because the tables were not working. Same with the postbit.

Thanks dude.