PDA

View Full Version : Avatar & Warn.php Bug


vulture
22 Mar 2005, 04:23
Using version 3.3.1

In the MEMBERINFO TEMPLATE it refers to images/avatars/noavatar.gif.

I couldn't find the gif in the download or forum install (3.07).

EDIT: Found out Warn.php doesn't redirect either


Cheers

Vulture

sv1cec
22 Mar 2005, 07:32
Using version 3.3.1

In the MEMBERINFO TEMPLATE it refers to images/avatars/noavatar.gif.

I couldn't find the gif in the download or forum install (3.07).

EDIT: Found out Warn.php doesn't redirect either


Cheers

Vulture
You are right about the avatar, but that shouldn't affect you too much. Just replace this part of the instructions:


<td colspan="3"><div class="smallfont">User's avatar :<p><img src="images/avatars/noavatar.gif"></td>


with this:


<td>&nbsp;</td>


The redirection issue though, I can't verify, it works for me. Some times your browser can act up, try closing your browser window and start over. Else, please tell me when it is not redirecting you? When you issue a warning? From the postbit or from the MemberInfo page?

Rgds

vulture
22 Mar 2005, 17:56
The redirection issue though, I can't verify, it works for me. Some times your browser can act up, try closing your browser window and start over. Else, please tell me when it is not redirecting you? When you issue a warning? From the postbit or from the MemberInfo page?

Rgds

It will redirect in IE, just not in Firefox. I've only tried it from the memberinfo page so far.

sv1cec
22 Mar 2005, 18:16
I am using Firefox as my main browser. I just tested it again, from the public profile and it works fine. Some of the browser settings maybe?

Rgds

vulture
23 Mar 2005, 00:04
Weird. On both my home pc and work pc it won't redirect (using firefox), but the other pages do.

I'll look into it further this week. As you say, prob a browser setting somewhere.

sv1cec
23 Mar 2005, 10:41
I knew it!!

Rgds

vulture
23 Mar 2005, 18:41
Ah, I fixed it. It was because I have one window that opens each session in a new tab. Weird.

Found another bug. If I enable non-post related warnings using the non-hierachy option, my other mods and admins can't issue them except for the main admin with user id 1

sv1cec
23 Mar 2005, 19:29
I would appreciate if you could clarify this.

From what I understand, if hierarchy option is set to 'No', only your admin can issue non-post related warnings? Is that correct? The moderators and the supermods do not see the 'Warn XYZ' link? Is that what you mean?

If so, please check your MEMBERINFO template.

vulture
23 Mar 2005, 20:27
That's correct. What am I checking for in MEMBERINFO template?

sv1cec
23 Mar 2005, 21:10
That's how the part where the Warn link is, should look like:


<!-- main info - avatar, profilepic etc. -->
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="thead">
<table cellpadding="0" cellspacing="0" border="0" width="100%" align="center">
<tr>
<td class="thead">$vbphrase[view_profile]: <span class="normal">$userinfo[username]</span></td>
<td class="thead" align='right'><div class="smallfont" style="float:$stylevar[right]">

<if condition="THIS_SCRIPT=='member' AND $vboptions[warn_allowoffpost]==1 AND $buttons=='Text'">
<if condition="$hierarchical==0">
<if condition="($bbuserinfo[usergroupid]==7 OR $bbuserinfo[usergroupid]==6 OR $bbuserinfo[usergroupid]==5) AND $userinfo[usergroupid]!=6 AND $userinfo[usergroupid]!=5 AND $userinfo[usergroupid]!=7">
<a href='Warn.php?do=WarnUserNoPost&id=$userid'>Warn $userinfo[username] (non-post related)</a> <a href='Warn.php?do=ViewWarnings&id=$userinfo[userid]'>View $userinfo[username]'s Warnings</a>
</if>
<if condition="$userinfo[userid]==$bbuserinfo[userid] AND $userinfo[usergroupid]!=6 AND $userinfo[usergroupid]!=7 AND $userinfo[usergroupid]!=5 AND $userinfo[warning_level]>0">
<a href='Warn.php?do=ViewMyWarnings'>View your Warnings</a>
</if>
</if>
<if condition="$hierarchical==1">
<if condition="($userinfo[usergroupid]!=6 AND $userinfo[usergroupid]!=5 AND $userinfo[usergroupid]!=7 AND ($bbuserinfo[usergroupid]==5 OR $bbuserinfo[usergroupid]==6 OR $bbuserinfo[usergroupid]==7)) OR ($userinfo[usergroupid]==7 AND $bbuserinfo[usergroupid]==5) OR ($bbuserinfo[usergroupid]==6 AND $userinfo[usergroupid]!=6)">
<a href='Warn.php?do=WarnUserNoPost&id=$userid'>Warn $userinfo[username] (non-post related)</a> <a href='Warn.php?do=ViewWarnings&id=$userinfo[userid]'>View $userinfo[username]'s Warnings</a>
</if>
<if condition="$userinfo[userid]==$bbuserinfo[userid] AND $userinfo[usergroupid]!=6 AND $userinfo[warning_level]>0">
<a href='Warn.php?do=ViewMyWarnings'>View your Warnings</a>
</if>
</if>
</if>
<if condition="THIS_SCRIPT=='member' AND $vboptions[warn_allowoffpost]==1 AND $buttons=='Buttons'">
<if condition="$hierarchical==0">
<if condition="($bbuserinfo[usergroupid]==7 OR $bbuserinfo[usergroupid]==6 OR $bbuserinfo[usergroupid]==5) AND $userinfo[usergroupid]!=6 AND $userinfo[usergroupid]!=5 AND $userinfo[usergroupid]!=7">
<a href='Warn.php?do=WarnUserNoPost&id=$userid'><input type="button" class="button" name="warn" value="Warn $post[username] (non-post related)" accesskey="w" onClick="window.location='Warn.php?do=WarnUserNoPost&id=$userid'"></a> <a href='Warn.php?do=ViewWarnings&id=$userinfo[userid]'><input type="button" class="button" name="warn" value="View $post[username]'s Warnings" accesskey="v" onClick="window.location='Warn.php?do=ViewWarnings&id=$userinfo[userid]'"></a>
</if>
<if condition="$userinfo[userid]==$bbuserinfo[userid] AND $userinfo[usergroupid]!=6 AND $userinfo[usergroupid]!=7 AND $userinfo[usergroupid]!=5 AND $userinfo[warning_level]>0">
<a href='Warn.php?do=ViewMyWarnings'><input type="button" class="button" name="warn" value="View Your Warnings" accesskey="v" onClick="window.location='Warn.php?do=ViewMyWarnings'"></a>
</if>
</if>
<if condition="$hierarchical==1">
<if condition="($userinfo[usergroupid]!=6 AND $userinfo[usergroupid]!=5 AND $userinfo[usergroupid]!=7 AND ($bbuserinfo[usergroupid]==5 OR $bbuserinfo[usergroupid]==6 OR $bbuserinfo[usergroupid]==7)) OR ($userinfo[usergroupid]==7 AND $bbuserinfo[usergroupid]==5) OR ($bbuserinfo[usergroupid]==6 AND $userinfo[usergroupid]!=6)">
<a href='Warn.php?do=WarnUserNoPost&id=$userid'><input type="button" class="button" name="warn" value="Warn $post[username] (non-post related)" accesskey="w" onClick="window.location='Warn.php?do=WarnUserNoPost&id=$userid'"></a> <a href='Warn.php?do=ViewWarnings&id=$userinfo[userid]'><input type="button" class="button" name="warn" value="View $post[username]'s Warnings" accesskey="v" onClick="window.location='Warn.php?do=ViewWarnings&id=$userinfo[userid]'"></a>
</if>
<if condition="$userinfo[userid]==$bbuserinfo[userid] AND $userinfo[usergroupid]!=6 AND $userinfo[warning_level]>0">
<a href='Warn.php?do=ViewMyWarnings'><input type="button" class="button" name="warn" value="View Your Warnings" accesskey="v" onClick="window.location='Warn.php?do=ViewMyWarnings'"></a>
</if>
</if>
</if>
<!-- end of warning system -->
</div>
</td>
</tr>
</table>
</td>
</tr>
<tr>
<td class="alt2">


Rgds

vulture
23 Mar 2005, 23:38
Its exactly the same. Do the links show up for you?

sv1cec
24 Mar 2005, 03:30
Yes, they do. Two things to check here:

First, your moderators and super moderators should be in usergroups 7 and 5.

Second, the links show up only inside the forums that the moderators can moderate. If the moderator cannot moderate a forum, the warn link will not show, only the View User Warnings link will be shown. Maybe this is your problem?

vulture
24 Mar 2005, 16:25
No, thats not the problem as its not showing up for admins either. I shall delve deeper!

sv1cec
25 Mar 2005, 07:09
Check the edits you have done in your member.php file. If your MEMBERINFO template is correct the only thing that remains to be checked is the member.php file. Make sure you have all the changes done properly.

Rgds

vulture
09 Apr 2005, 04:32
You are right about the avatar, but that shouldn't affect you too much. Just replace this part of the instructions:


<td colspan="3"><div class="smallfont">User's avatar :<p><img src="images/avatars/noavatar.gif"></td>


with this:


<td>&nbsp;</td>




Hi,

Replacing with
<td>&nbsp;</td>
ruins the page view if the user doesn't have an avatar. The Last Activity details are now centered in in middle instead of the right.

sv1cec
09 Apr 2005, 06:54
Sorry, try this:


<td colspan="3">&nbsp;</td>

vulture
11 Apr 2005, 13:16
I upgraded to 3.4.1 and those earlier problems have disappeared.
Thanks for your help.

BTW, html in the above post is not yet integrated with your 3.4.1 release.

sv1cec
11 Apr 2005, 14:04
Yeah, I forgot to change the instructions, thanks for bringing it to my attention.

Rgds