PDA

View Full Version : How do you get Vbgarage info under avatar?


axi
04 Apr 2005, 19:39
i see on some automotive sites with vbgarage under the users avatar it has something like

View my garage
Car:
Model:
etc..

How do i get that?

anyone know?


Cheers

Osiris2k
04 Apr 2005, 20:37
edit postbit or postbit_legacy depending on what style you are running

just find

for postbit_legacy


<if condition="$post['joindate']"><div>$vbphrase[join_date]: $post[joindate]</div></if>


just add under or above etc.


<if condition="$post['userid']"><div><a href="vbgarage.php?do=view&id=$post[userid]">$post[musername]'s Garage</a></div></if>


thats should be it..

axi
04 Apr 2005, 21:25
error:

vBulletin Message
Please complete all the fields. Press the back button, correct the problem then try again.

happens when trying to click on that users 'garage' under the avatar

and yes they are listed in the garage..

Osiris2k
04 Apr 2005, 21:41
you need to make sure that it is forwarded correctly, try this

<if condition="$post['userid']"><div><a href="vbgarage.php?do=view&id=$post[userid]">$post[musername]'s Garage</a></div></if>

where it says

"vbgarage.php?do=view&id=$post[userid]"

replace with

"http://www.yoursite.com/forums/vbgarage.php?do=view&id=$post[userid]"


make sure that it is correctly forwarded to vbgarage.php ...hope it helps

axi
04 Apr 2005, 21:54
its still coming up with the same error :S
hmm what could it be?

Osiris2k
04 Apr 2005, 22:28
its still coming up with the same error :S
hmm what could it be?


post your code and your website url...

Rick Sample
05 Apr 2005, 00:31
I think he might be using vbgarage 4.1 That code posted above I think will only work with the older versions.

Osiris2k
05 Apr 2005, 02:47
I think he might be using vbgarage 4.1 That code posted above I think will only work with the older versions.


I upgraded to vbgarage 4.0.4 today and it works fine...i even modified it so it shows up on the memberspage

www.corollaonline.com

axi
05 Apr 2005, 05:48
i have version 3
website is www.beastclub.com.au/forums/
members cars at top for vbgarage

i just upgraded to version 4 and i cant get the function work still
can someone help!!

cheers

Osiris2k
05 Apr 2005, 19:11
post the postbit_legacy code too please.

this should work though..i changed it a bit

<if condition="$post['userid']"><div><a href="http://www.beastclub.com.au/forums/vbgarage.php?do=viewparked&id=$post[userid]">$post[musername]'s Garage</a></div></if>

axi
06 Apr 2005, 15:30
thanks it worked

Stangsta
11 Apr 2005, 05:18
How do you set it so it appears in only 1 color? If Mods/users are a different colors, it looks all jacked up like the example below.

example:

Stangsta's Garage

I want it to look like this:

Stangsta's Garage

Osiris2k
12 Apr 2005, 20:38
How do you set it so it appears in only 1 color? If Mods/users are a different colors, it looks all jacked up like the example below.

example:

Stangsta's Garage

I want it to look like this:

Stangsta's Garage


put color tags around "$post[musername]'s Garage"

Stangsta
13 Apr 2005, 00:30
put color tags around "$post[musername]'s Garage"
I tried that, it doesn't override the username color tags that are assaigned in the usergroup.

Heres the code im using:
<if condition="$post['userid']"><div><a href="vbgarage.php?do=view&id=$post[userid]"><font color="Navy">$post[musername]<b>'s Garage</font></b></a></div></if>

Any other suggestions?

Osiris2k
15 Apr 2005, 00:23
try this
<if condition="$post['userid']"><div><a href="vbgarage.php?do=view&id=$post[userid]"><font color=#1322AF>$post[musername]<b>'s Garage</font></b></a></div></if>

epic1
15 Apr 2005, 16:38
This should do it if the above doesn't work:


<if condition="$post['userid']"><div><a href="vbgarage.php?do=view&id=$post[userid]"><span style="color: #1322AF">$post[username]'s Garage</span></a></div></if>

axi
15 Apr 2005, 21:57
it all works
thanks

Stangsta
16 Apr 2005, 15:24
This should do it if the above doesn't work:


<if condition="$post['userid']"><div><a href="vbgarage.php?do=view&id=$post[userid]"><span style="color: #1322AF">$post[username]'s Garage</span></a></div></if>


That did the trick...thank you!!!

Residue
10 May 2005, 05:30
Is there a way to do this so that the link will only display if the user has setup a garage? I set this up on mine, and the link showed up on everyones post, even people without garages. Thanks

scottishcruise
26 May 2005, 23:24
I just wrote this into my style too, many thanks!! great wee touch :classic:

aussiev8
27 May 2005, 02:55
there isn't a way to tell it a user has a garage or not..
unless you preform a query and check for no match in the database.
thats another query to ever page load..

lionslair
02 Jun 2005, 14:04
Where do you get version 4+ from. I thought I found the thread but could find no link to download it.

forzablues
17 Aug 2006, 13:17
Works great

BlueKnight
31 Aug 2006, 09:40
its about 2am and well is there a away you can summarize the which code is working where to put it and the color tags to use? I think this would be great to encourage members to fill the garage.

BlueKnight
06 Oct 2006, 02:49
neither one of these or any of these I can get the info to show up...

fixed it... if you have something already below like we do with arcade it wont show but if you place this just under show avatar line it works.

smoknz28
14 Dec 2006, 05:42
edit postbit or postbit_legacy depending on what style you are running

just find

for postbit_legacy



just add under or above etc.



thats should be it..


This worked great for me using vB 3.6.4.

I have read that some of you have version 4.x of vBGarage....I just installed v3.5 and had no idea there was a later version.

Where is the latest version located?

Thanks

ExciterNL
26 Apr 2007, 14:57
That did the trick...thank you!!!

Works even here... Many thanks