PDA

View Full Version : garage link in topic view 4.1 beta solution


hraweb.com
07 May 2005, 23:57
After installing 4.1 beta i tryed to add this feature by following the topics from this thread (http://www.vbulletin.org/forum/showthread.php?t=79342)

It didnt work, and it gave an error saying

vBulletin Message
Please complete all the fields.
Press the back button, correct the problem then try again.

Then i saw that old garage invokes user garage with vbgarage.php?do=view&id and new does the same with vbgarage.php?do=viewparked&id

notice the View and viewparked - that is the difference

So to get user garage listed under user info in topic view do this

edit postbit or postbit_legacy depending on what style you are running

just find

for postbit_legacy

<if condition="$post['joindate']"><div>$vbphrase[join_date]: $post[joindate]</div></if>

just add under or above etc.

<if condition="$post['userid']"><div><a href="vbgarage.php?do=viewparked&id=$post[userid]"><span style="color: #1322AF">$post[username]'s Garage</span></a></div></if>

hotwheels
19 Aug 2005, 23:14
i followed this hack by the simple step and i am not being takin to my vbgarage. Here is what it show's: http://www.insanemustangs.com/forums/vbgarage.php?do=viewparked&id=1

For what ever reason, it just show's a blank page, and it say's done down in the bottom left hand corner..... I used the above hack and added it to my postbit

any help to make this hack work would be greatly appreciated.....hotwheels

Rick Sample
20 Aug 2005, 00:22
i followed this hack by the simple step and i am not being takin to my vbgarage. Here is what it show's: http://www.insanemustangs.com/forums/vbgarage.php?do=viewparked&id=1

For what ever reason, it just show's a blank page, and it say's done down in the bottom left hand corner..... I used the above hack and added it to my postbit

any help to make this hack work would be greatly appreciated.....hotwheels

Hi, I know precisly what is the problem. The hack he's invoking requires VBgarage 4.1. Your running VBgarage 3.0. By the way, nice mustang site, I run one as well ;)


This one should work and is compatable with the version you are running:

<if condition="$post['userid']"><div><a href="vbgarage.php?do=view&id=$post[userid]"><span style="color: #1322AF">$post[username]'s Garage</span></a></div></if>

hotwheels
20 Aug 2005, 01:14
awesome rick............thanks for the hack and for the compliment's..........once i get this installed, i will swing by and check out your site.........doug

you are da man............that was the exact fix..........woot

hotwheels
13 Nov 2005, 19:26
Just updated my site, deleted the one that rick sample posted and moved to the one that hraweb.com posted, work's like a champ.....

I just upgraded to the 4.1 version.....thanks