PDA

View Full Version : Adding Images


Dan Flynn
29 Sep 2002, 04:03
I wanted to add images to my categories and posts. But first I have to separate the categories and posts.

I did that and have a problem I was wondering if someone would know how to fix this. The categories came out fine but the post didn't. You can see I have a header and footer with rounded corners. But this wasn't a problem on the main page breaking up the categories.

The posts after I separate them have green behind them instead of white. Here are the sreenshots.

Thanks

Tony G
29 Sep 2002, 08:06
Check the bg tag in your postbit and make sure it's bgcolor and not catcolor or anything like that.

Dan Flynn
29 Sep 2002, 13:19
Thanks for your reply, here is my postbit code

I tried to break them up with diferent codes from different people. This code at the very bottum has been my latest attemped


<!--added-->
<table align="center">

<td bgcolor=""#FFFFFF" background="images/mainbg.gif"" width="100" height="10" align="center"></td>

</table>
<!--/added-->


POSTBIT BELOW
=================================================

<table bgcolor=""#FFFFFF" background="images/mainbg.gif"" width="750" cellpadding="0" cellspacing="0" border="0"><tr><td width="10"><img width="10" height="1" src="images/space.gif" alt=""></td><td width="100%"><!-- spacer -->

<table cellpadding="0" cellspacing="0" border="0" bgcolor="#6597D9" width="100%" align="center"><tr><td>
<table cellpadding="4" cellspacing="1" border="0" width="100%">
<tr>
<td bgcolor="$post[backcolor]" width="175" valign="top" nowrap>
<a name="post$post[postid]"></a>
$post[firstnewinsert]
<normalfont><b>$post[username]</b></normalfont> <a href="search.php?s=$session[sessionhash]&action=finduser&userid=$post[userid]"><img src="images/findnew.gif" border="0"></a><br>
<smallfont>$post[usertitle]</smallfont><br>
$post[avatar]<p>
<smallfont>Registered: $post[joindate]<br>
Location: $post[field2]<br>
Posts: $post[posts]<br>
$post[donation]<br>$onlinestatus</smallfont></td>

<td bgcolor="$post[backcolor]" width="100%" height="100%" valign="top">
<table width="100%" border="0" cellpadding="0" align="left" height="100%">
<tr>
<td bgcolor="$post[backcolor]" colspan="2" align="left" valign="top" height="20"><smallfont>$post[icon] <b>$post[title]</b></smallfont></td>
</tr>
<tr>
<td bgcolor="$post[backcolor]" colspan="2" align="left" valign="top"><p><normalfont>$post[message]</normalfont></p></td>
</tr>
<tr>
<td bgcolor="$post[backcolor]" colspan="2" align="left" valign="bottom" height="20"> $post[attachment]</td>
</tr>
<tr>
<td bgcolor="$post[backcolor]" colspan="2" align="left" valign="bottom" >$post[signature]</td>
</tr>
<tr>
<td bgcolor="$post[backcolor]" align="left" valign="top" height="8">$post[editedby]</td>
<td bgcolor="$post[backcolor]" align="right" valign="top" height="8"><smallfont><a href="report.php?s=$session[sessionhash]&postid=$post[postid]">Report this post to a moderator</a> | $post[iplogged]</smallfont></td>
</tr>
</table>
</td>
</tr>
<tr>
<td bgcolor="$post[backcolor]" width="175" height="16" nowrap><smallfont>$post[foldericon]
$post[postdate] <font color="#000000">$post[posttime]</font></smallfont></td>

<td bgcolor="$post[backcolor]" width="100%" valign="middle" height="16">
<table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr valign="bottom">
<td><smallfont>
$post[profile] $post[pmlink] $post[useremail] $post[homepage] $post[search] $post[buddy]
<!-- $ post[icqicon] --> <!-- $ post[aimicon] --> <!-- $ post[yahooicon] -->
</smallfont></td>
<td align="right" nowrap><smallfont>
<a href="editpost.php?s=$session[sessionhash]&action=editpost&postid=$post[postid]"><img src="images/edit.gif" border="0" alt="Edit/Delete Message"></a>
<a href="newreply.php?s=$session[sessionhash]&action=newreply&postid=$post[postid]"><img src="images/quote.gif" border="0" alt="Reply w/Quote"></a>
</smallfont></td>
</tr>
</table>
</td>
</tr>
</table>
</td></tr></table>

<!-- spacer --></td><td width="10"><img width="10" height="1" src="images/space.gif" alt=""></td></tr></table>

<!--added-->
<table align="center">

<td bgcolor=""#FFFFFF" background="images/mainbg.gif"" width="100" height="10" align="center"></td>

</table>
<!--/added-->

Tony G
29 Sep 2002, 13:58
<td bgcolor=""#FFFFFF" background="images/mainbg.gif"" width="100" height="10" align="center"></td>

Thats the only code I could see this green coming from. The spacer can't be it..:-/