vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=329121

Moving from 3.8 to 4.2
by BillB1
12 Jan 2022 11:28

Gentlmen,

I need your advice on how to upgrade to 4.2.5
Testing on local PC using XAMPP:

Old Forum:
PHP Version: 5.6.32
Myadmin: 4.7.4
Vbulletin: 3.8.11
Custom syles
Runs perfect!

New forum:
Migrating database to
PHP 7.1.1
Myadmin: 4.6.5
Vbulletin: 4.2.5

Questions:
1. Do I create a new database and install VB 4.2.5 first then import vb 3.8 backup to it?
2. or Create new data base, restore vb 3.8 back up ?
3. In all cases when installing vb 4.2.5 it over writes the entire database tables.
4. I wish to keep the vb3.8. customized style, is there a tool to modify/upgrade the style to vb4.2?

Note:
If all goes well, I'll be upgrading to VB5

Thanks
Bill

RichieBoy67 12 Jan 2022 14:47

You do not need Xamp server. You can just back up and make a test site in a directory on your server if you wish. Run the upgrade script there and fix the theming, etc.

Or is your plan to build the site fresh in 4.2 and then import? Either method will work.

Basically create your new vbulletin site and use Impex to import from the old files and database.

snakes1100 12 Jan 2022 19:41

1. Create new, there is no reason for an import.
2. Create new & import your backup, from the cmd line prefebly as the new server could time out importing thru phpmyadmin, you may have to tweak phps timeouts via php.ini.
3. You will run the upgrade script after uploading the new vb 4.x.x series php files to the server.
4. You should build a new style based off the old style, there are MANY things a 3.8 style wont have for functionality in the templates.

templaters 18 Apr 2022 23:48

Quote:

Or is your plan to build the site fresh in 4.2 and then import? Either method will work
New and clean is always best, vb4 is way different than vb3

BillB1 26 May 2022 19:48

Apology for the late reply; and appreciate all inputs :)
and yes backed old data up, fresh vb4.2.5 files, did the upgrade today; so far so good!

Note:
I wonder if it's possible to add (LIKE button) I've tried most mods here,
they seem outdated ( I believe the lastest mod is for 4.2.2) triggering errors.

--------------- Added 26 May 2022 at 22:40 ---------------

Well! upgrade was too good to be true!

Anyone knows why I am getting this
after the upgrade?

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It was like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

ALL counters updated via admincp.

Also, after creating a new user name/password, can't log in, redirects to forgot password!

TheLastSuperman 03 Jun 2022 16:28

Try fixing your AdminCP access issue using this article:
https://vbulletin.org/forum/showthread.php?t=259619

Any SEO modifications installed or were there .htaccess file modifications (rewrites) done?

BillB1 03 Jun 2022 16:57

Many thanks.
adding define('DISABLE_HOOKS', true); did the trick.
SEO mod was installed on vb3.8 , uninstalled it prior to upgrade.

I don't see .htaccess file, do I need one to solve the problem these weird characters (%C7%E4%C) in URL .


All times are GMT. The time now is 19:36.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.