vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=166987

Is this a server issue?
by attroll
05 Jan 2008 07:24

I do not know which forum to put this post in so I picked what I thought was right. I think this may be a server issue but I am unsure. Let me explain what is going on.

I am having a server problem with one of my VB domains and it is not happening on any of my other VB sites so I am hoping that someone with some experience can shed some light on this and help me fix it.

I have set up my config.php file to use the datastore_cache.php file as VB has designed it to be used. I have set it to CHMOD 777. Then after I access my Admincp and do anything in the Admincp and save it the file reverts back to CHMOD 644 and then I can no longer wrtiten to it. In fact it changes the permissions so that even I can not change it back to CHMOD 777 again.

Let me shed a little light one all I have done to me server lately.

I updated my PHP to PHP 5 about two weeks ago and then I noticed this problem. I donít know if I can blame this on the PHP5 upgrade or not because I also have four other VB sites running on this server and they do not have this problem.

Can someone shed some light on this that may know what I can do to fix this?

Marco van Herwaarden 05 Jan 2008 07:42

Did you also set the permission for the ./includes/datastore directory?

attroll 05 Jan 2008 08:05

The directory that is it in is 775. It should not have to be 777. Only the file datastore_cache.php should be 777. But it keeps doing what I mentioned in the first post.

Marco van Herwaarden 05 Jan 2008 08:46

Try setting the directory to 777 or ensure that it is owned by the user/group that your webserver is running under.

attroll 05 Jan 2008 09:22

Ok we got it fixed so it stays at 777 but now it does not save changes to the file. I have to do some more digging now.

Marco van Herwaarden 05 Jan 2008 09:32

And the current file permissions are?

If the directory in which the file is created is set to 777, then the file should also get the correct permissions, unless the account under which the file is created has a strange UMASK set. Under what user/group is the file created and what is the current owner/group of the directory.

attroll 05 Jan 2008 09:38

The directory that is falls under is 775. It should not have to be 777 should it?

--------------- Added 05 Jan 2008 at 09:44 ---------------

I tried changing the directory to 777 and that did not help either.

If I start out with a new datastore_cache.php file and make it CHMOD 777 and then open up my Admincp it reads the contents from the database into the file and saves the file. Then when I try to delete a forum is says that it was successful but after is says that then it brings up the forum listing again but it it still shows the forum that I just deleted. It seems as though it did not get deleted. I then try to click on the forum that I tried to delete and it says "Invalid forum specified".

To me it seems like it is not writing back to the datastore_cache.php file with the changes but nothign is getting changed. The time changes on the file but nothing I do gets changed.

Marco van Herwaarden 05 Jan 2008 09:54

Let's look at some possible causes.

First of all what is the username/accountname under which the site is running?

Next what are the current permissions and user/group for:
- ./includes directory
- ./includes/datastore directory
- ./includes/datastore/datastore_cache.php file

You say that the time is updated on the file but you don't see the changes. Can you verify if the changed data is written to the file or not.

Also are you using any caching mechanism that might be serving an old version of the file?

attroll 05 Jan 2008 22:13

Answer to question #1
For security reasons I will use the name "blaze" instead of the username/accountname that I actually use. Here is the permissions.

Answer to question #2
[email protected] [/home/blaze/public_html/forum]# ll -d ./includes
drwxr-xr-x 9 blaze blaze 12288 Jan 5 12:42 ./includes/

[email protected] [/home/blaze/public_html/forum]# ll -d ./includes/datastore
drwxr-xr-x 2 blaze blaze 4096 Jan 5 12:14 ./includes/datastore/

[email protected] [/home/blaze/public_html/forum]# ll ./includes/datastore/datastore_cache.php
-rwxrwxrwx 1 blaze blaze 225479 Jan 5 15:14 ./includes/datastore/datastore_cache.php*

Answer to question #3
Yes I can view the datastore_cache.php and verify that none of the changes such as adding a forum is getting written to the file.

Answer to question #4
I am unsure of what you mean by this question. I am using the datastore_cache.php file that came with VB 3.6.8 and that is the verision I am upgraded to. Should I try and older file? I looked at all the 3.0 and up versions and they all look the same.

Marco van Herwaarden 06 Jan 2008 09:09

[email protected] [/home/blaze/public_html/forum]# ll -d ./includes/datastore
drwxr-xr-x 2 blaze blaze 4096 Jan 5 12:14 ./includes/datastore/


Datastore directory should be set to 777

About #4
I am not talking about vBulletin versions. I was suggesting that maybe a caching mechanism used on your server still had an old copy of the file in memory and serving that. But first set the directory permissions correct and take it from there.

attroll 06 Jan 2008 13:11

I went in and made the datastore directory 777 and then after I tried it the datastore_cache.php and all the files in the datastore directory changed to 644 and I can not changed them back to 777 now. I think it changed all the permisions. So I deleted the directory and reuploaded it again and made the directory and the file 777 again and tried it again and the file reverted back to 644 again. So now I am back to where I started.

Marco van Herwaarden 06 Jan 2008 17:45

The directory should be 777 and the file should be 666 (or 664)

attroll 06 Jan 2008 23:19

Are you sure of this because VB only says that the file is suppose to be 777?
http://www.vbulletin.com/docs/html/datastore

Alien 08 Apr 2008 05:27

I have this exact same issue occurring, did you ever resolve this?

attroll 08 Apr 2008 06:59

Quote:

Originally Posted by Alien (Post 1485649)
I have this exact same issue occurring, did you ever resolve this?

No I never got this resolved. I just disabled it again. I got sick of people talking out their butts or not understanding the problem or not knowing what they were talking about. I ask VB.com and they said it was a server issue and would not explain. I talk to my server management team and they told me that it was a software issue with VB. I love VB but I hate it when ever you have something they don't want to help you with they always default to blaming it on the server.

I asked the VB team what was the problem and they said it was a server issue. I explained that I owned my server and asked them what would cause this on a server so I could fix it. They replied "Honestly I have no idea what would cause the server to change the file permissions like that". How can they blame it on a server if they don't know what would cause it? They were spouting off just to get me off there back because they did not have the answer.

I have upgraded my VB to the latest version but have not tried using the "datastore_cache" file since I upgraded. I just gave up. It pisses me off that VB would put this in the config file but not help you when you have problems with it.

Don't get me wrong, I love VB but when they don't want to help you resolve something they do not have an answer to then what can you do.

PS. If you ever figure this out please let post your results here to help me and possibly others.


All times are GMT. The time now is 01:09.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.