vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=236888

Dylanblitz 04 Mar 2010 09:36

by default it installs as admin only. This is so you can configure it before releasing it to the users.
ACP->Settings->Options->Garage General Settings
Change Garage Menu Button from Admin Only to Enabled

venom2124 07 Mar 2010 17:36

Is there a way to make the featured vehicles on the home page and maybe a way to vote on the featured vehicles to get the vehicle of the month.

Dylanblitz 07 Mar 2010 18:53

There are a few different options for setting the front page vehicles on the Garage General Settings vboptions section, featured vehicle is one of them.
I'm working on a way to nominate and vote on vehicle of the month for 2.2.x

deadbolt80 22 Mar 2010 04:31

So, basically just follow the "quick and dirty" install, and everything should work fine, right?

I'm trying this tonight.

Dylanblitz 22 Mar 2010 04:47

yes, if it's in the forums directory it should work. Only repeat issues I've seen is having to set the images/garage/attach folder to 777 if you get permission errors uploading images and sometimes having to set the Garage Files URL field in the Garage General Settings

deadbolt80 22 Mar 2010 10:33

this is what i got

Quote:

Warning: mkdir() [function.mkdir]: Permission denied in [path]/includes/garage_func_var.php on line 1730

Warning: mkdir() [function.mkdir]: Unable to access images/garage/attach/4/8 in [path]/includes/garage_func_var.php on line 1730

Warning: mkdir() [function.mkdir]: Unable to access images/garage/attach/4/8/5 in [path]/includes/garage_func_var.php on line 1730

Warning: mkdir() [function.mkdir]: Unable to access images/garage/attach/4/8/5/0 in [path]/includes/garage_func_var.php on line 1730

Warning: mkdir() [function.mkdir]: Unable to access images/garage/attach/4/8/5/0/7 in [path]/includes/garage_func_var.php on line 1730

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to access images/garage/attach/4/8/5/0/7/garage_vehicle-1-12692537291_full.jpg in
what does this mean??

I did change the attach folder to 777

What garage files URL? what do I post there?

Dylanblitz 22 Mar 2010 15:29

who is the owner of images/garage/attach? Changing it to 777 usually works.
The Garage Files URL wouldn't cause this problem, it has to do with the folder ownership.

EDIT:
Also, is safe-mode on?

deadbolt80 22 Mar 2010 16:19

Quote:

Originally Posted by Dylanblitz (Post 2008147)
who is the owner of images/garage/attach? Changing it to 777 usually works.
The Garage Files URL wouldn't cause this problem, it has to do with the folder ownership.

EDIT:
Also, is safe-mode on?

I'm not sure If i understand your Q. what do you mean who's the owner?

I uploaded the files in the "Upload" folder to the server under mysite.org/public_html/forums, right? did all the steps as stated and changed the permissions to 777 to the "Attach" folder. Am I missing something?

And no safe mode is not on. The forum is active and perfectly fine.

Dylanblitz 22 Mar 2010 16:33

Quote:

Originally Posted by deadbolt80 (Post 2008184)
I'm not sure If i understand your Q. what do you mean who's the owner?

I uploaded the files in the "Upload" folder to the server under mysite.org/public_html/forums, right? did all the steps as stated and changed the permissions to 777 to the "Attach" folder. Am I missing something?

And no safe mode is not on. The forum is active and perfectly fine.

Safe mode is a php function, you can tell if it's on by going to ACP->Maintenance->View PHP info
Look for the safe_mode setting.

If you look through your ftp program it should tell you who the owner/group of the attach folder is.

deadbolt80 22 Mar 2010 16:46

Quote:

Originally Posted by Dylanblitz (Post 2008191)
Safe mode is a php function, you can tell if it's on by going to ACP->Maintenance->View PHP info
Look for the safe_mode setting.

If you look through your ftp program it should tell you who the owner/group of the attach folder is.


under acp>maint>view php I found this:

safe_mode:

Local Value: On Master Value: Off

safe_mode_include_dir

Local Value: /usr/local/lib/php/ Master Value: /usr/local/lib/php/

on line 1730 in the /includes/garage_func_var.php, this is what I found:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

How do I adjust this?

MY hosting company doesn't use FTP. I log on to access my files using 6thgenmaxima.org:2222

The only confusion I might think of is when I uploaded the contents of the "upload" folder, I made all the contents into a zip file, uploaded that zip file onto my forums directory, then extracted it. Should I have uploaded the Upload folder itself or only the contents of it?

Dylanblitz 22 Mar 2010 17:27

unfortunately it might not be something I can fix. If they use safe_mode then your host probably doesn't have your account configured in a way that you can create a folder and execute things like mkdir in it.
You might ask them to remove safe_mode from your account.

deadbolt80 22 Mar 2010 17:40

Quote:

Originally Posted by Dylanblitz (Post 2008216)
unfortunately it might not be something I can fix. If they use safe_mode then your host probably doesn't have your account configured in a way that you can create a folder and execute things like mkdir in it.
You might ask them to remove safe_mode from your account.

if they remove safe mode would that help?

Dylanblitz 22 Mar 2010 18:11

It should, never had much luck working with safe_mode on. They might not do it though. From experience I've seen that hosts put on safe_mode because they don't know how to properly secure the server or they don't want to spend the time.
Will be nice when PHP 6.x comes out so we wont have to deal with that issue anymore heh.

deadbolt80 22 Mar 2010 18:22

Ah ok. So no garage install for me I guess

Are you sure i'm installing this right? i don't even know.

Dylanblitz 22 Mar 2010 19:11

Sounds like it's installed right, just getting a permissions error. I would ask the host to take a look and see if there is something messed up with the owner/group of the images/garage/attach folder.


All times are GMT. The time now is 18:33.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.