vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=328248

Yilmaz - Advanced Forum Statistics Module (AJAX) Compatible 5.6.x
by yilmaz
27 Sep 2020 20:56

10 Attachment(s)
I adapted VSa - Advanced Forum Statistics (AJAX) product for vb5.
Compatible 5.6.x
If those who want to try and share their experiences, we can develop more.

========================================
In version 1.6.0, requests and errors have been fixed and made more useful.
Note: For full performance, uninstall the previous one and install it again
========================================

========================================
In version 1.7.0, I added automatic css selection based on Module position.
The error out of module slipping in the previous flock was fixed
========================================

========================================
How to install:
========================================
Upload the content of Yilmaz - Advanced Forum Statistics (AJAX) directory to your root.
that's all it.
enjoy...

===============Important==================
After installing, go to the options and do as in the screenshot, it will not show the latest posts if you do.


Please Mark as Installed if you use this. :)
Donations always appreciated. :up:

========================================
How to uninstall:
========================================
1. Remove the package "yilmazistatistik" that located in /core/packages/
2. Go to "Manage Products" in the admincp and delete the product named "Yilmaz - Advanced Forum Statistics (AJAX)"

I would like to thank the help @Chicoynano

rodriiverduguez 29 Sep 2020 09:29

compatible 5.6.3?

yilmaz 29 Sep 2020 12:22

Quote:

Originally Posted by rodriiverduguez (Post 2604091)
compatible 5.6.3?

It works fine in 5.6.3.

Greek76 22 Oct 2020 20:25

Is this compatible with the latest version?

yilmaz 22 Oct 2020 21:48

Quote:

Originally Posted by Greek76 (Post 2604341)
Is this compatible with the latest version?

It works fine in 5.6.3.
I didn't upgrade to 5.6.4, I upgrade when I have time, I test it.

migratoria 24 Oct 2020 19:34

Installed but not works correctly in my vb 5.6.4

I tried to remove the mod but the module won't uninstall. How can I do?

yilmaz 25 Oct 2020 01:09

Quote:

Originally Posted by migratoria (Post 2604365)
Installed but not works correctly in my vb 5.6.4

I tried to remove the mod but the module won't uninstall. How can I do?

The reason is that automatic setup is active, so it is automatically installed again.
After deleting the core/packages/yilmazistatistik/ folder from FTP, you must delete the product.

Note: It works fine in 5.6.3.
I didn't upgrade to 5.6.4, when I have time, I try to upgrade to fix bugs

yilmaz 26 Oct 2020 15:08

Quote:

Originally Posted by migratoria (Post 2604365)
Installed but not works correctly in my vb 5.6.4

I tried to remove the mod but the module won't uninstall. How can I do?

I tried version 5.6.4 and it works without any problems

Blackhorse 01 Nov 2020 00:38

Does it work with 5.5.5?

yilmaz 01 Nov 2020 00:41

Quote:

Originally Posted by Blackhorse (Post 2604476)
Does it work with 5.5.5?

yes it works:up:

Blackhorse 01 Nov 2020 01:00

Thank you so much, I will install and give you a feedback with a small thankful gift

Blackhorse 01 Nov 2020 01:40

Quote:

Originally Posted by yilmaz (Post 2604477)
yes it works:up:

Hello Yilmaz, it is not working at all on my vb 5.5.5 forum, it appears in the modules area, i dragged it and choose a title, but it is not appearing, even by changing location up and down.

Blackhorse 01 Nov 2020 17:07

up recheck please

megabink 01 Nov 2020 20:01

I will give this a shot on my site...i had this on my vB4 version a few years back.
Thanks Yilmaz.:up:

Blackhorse 02 Nov 2020 23:38

Hello Yilmaz,

Your attention is needed here, please

Thanks

USC 03 Nov 2020 13:29

Quote:

Originally Posted by yilmaz (Post 2604343)
It works fine in 5.6.3.
I didn't upgrade to 5.6.4, I upgrade when I have time, I test it.

great module bro..however it doesnt work properly on 5.6.4 ..waiting for the upgrade version ..

74v 04 Nov 2020 00:17

maalesef 5.4.6 sıkıntılı

yilmaz 04 Nov 2020 23:51

Quote:

Originally Posted by Blackhorse (Post 2604491)
up recheck please

Quote:

Originally Posted by Blackhorse (Post 2604517)
Hello Yilmaz,

Your attention is needed here, please

Thanks

Quote:

Originally Posted by 74v (Post 2604539)
maalesef 5.4.6 sıkıntılı

Tested from version 5.4.x to 5.6.4.
Auto Content type ID discovery added.

The found content type ID number will show in the recent posts statistics widget when you add it from settings.

===============Important==================
After installing, go to the options and do as in the screenshot, it will not show the latest posts if you do.

https://www.vbulletin.org/forum/atta...1&d=1604533124

JmTech 14 Nov 2020 08:50

installed but cant find contenttype id

its not show as well in settings

USC 15 Nov 2020 00:48

1 Attachment(s)
hey bro can you please fix it ?
Attachment 157948
i am in dire need to this beautiful module ..

yilmaz 15 Nov 2020 18:25

I am currently working on the update.
I'll update it when it's done.

USC 16 Nov 2020 03:55

Quote:

Originally Posted by yilmaz (Post 2604668)
I am currently working on the update.
I'll update it when it's done.

thanks a million ..waiting :)

yilmaz 16 Nov 2020 05:34

In version 1.6.0, requests and errors have been fixed and made more useful.
For full performance, uninstall the previous one and install it again

To receive notifications regarding updates -> Click to Mark as Installed.

USC 17 Nov 2020 03:07

1 Attachment(s)
Quote:

Originally Posted by yilmaz (Post 2604677)
In version 1.6.0, requests and errors have been fixed and made more useful.
For full performance, uninstall the previous one and install it again

To receive notifications regarding updates -> Click to Mark as Installed.

bundle of thanks bro ..its working better now ..however there is still a minor alignment issue ..please see the attachment ..could you please fix it ..thanks for your hard work ..

yilmaz 18 Nov 2020 02:37

In version 1.7.0, I added automatic css selection based on Module position.
The error out of module slipping in the previous flock was fixed

USC 18 Nov 2020 22:11

Quote:

Originally Posted by yilmaz (Post 2604710)
In version 1.7.0, I added automatic css selection based on Module position.
The error out of module slipping in the previous flock was fixed

working perfectly now ..bundle of thanks bro :)

yilmaz 18 Nov 2020 23:56

1 Attachment(s)
Quote:

Originally Posted by USC (Post 2604718)
working perfectly now ..bundle of thanks bro :)

https://www.vbulletin.org/forum/atta...1&d=1605743733

Username HTML Markup to avoid line skipping
Search for this in templates

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and add this right above

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Like this

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


USC 19 Nov 2020 01:00

1 Attachment(s)
Quote:

Originally Posted by yilmaz (Post 2604719)
https://www.vbulletin.org/forum/atta...1&d=1605743733

Username HTML Markup to avoid line skipping
Search for this in templates

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and add this right above

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Like this

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

thank you so much ..check the screen shot out ..you are a champ bro :)

USC 19 Nov 2020 01:17

one question though ..i noticed admin private forums posts also show up in latest posts section ..i tested guests and members cant access though ..is there any way to completely hide them from guests and other usergroups ?thanks in advance ..

yilmaz 19 Nov 2020 04:52

1 Attachment(s)
Quote:

Originally Posted by USC (Post 2604721)
one question though ..i noticed admin private forums posts also show up in latest posts section ..i tested guests and members cant access though ..is there any way to completely hide them from guests and other usergroups ?thanks in advance ..

It does not show the forums you have selected here.

https://www.vbulletin.org/forum/atta...1&d=1605761392

In the new version, I add a setting based on forum permissions.

74v 19 Nov 2020 06:17

genel olarak 5.6.4 te güzel çalışıyor fakat istastiskler dikey olduğu için forumun görünüşünü uzatıyor bunları yatay siyah resimdeki gibi yapma şansımız varmı ?

yilmaz 19 Nov 2020 08:46

Quote:

Originally Posted by 74v (Post 2604723)
genel olarak 5.6.4 te güzel çalışıyor fakat istastiskler dikey olduğu için forumun görünüşünü uzatıyor bunları yatay siyah resimdeki gibi yapma şansımız varmı ?

Eskisini silip yeniden kurarsanız dediğiniz sorunların olmadığını göreceksiniz.

If you delete the old one and install it again, you will see that there are no problems you say.

74v 19 Nov 2020 17:43

maalesef yılmaz bey 74v.net bakınız nasıl duruyor

Chicoynano 19 Nov 2020 18:14

3 Attachment(s)
I try to help as much as I can, in the update if I choose to show Top Topic Starters an error appears that can be solved delete this line found in code 326 core / packages / yilmazistatistik / include / yilmazistatistik.php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


74v 19 Nov 2020 18:32

Quote:

Originally Posted by Chicoynano (Post 2604730)
I try to help as much as I can, in the update if I choose to show Top Topic Starters an error appears that can be solved delete this line found in code 326 core / packages / yilmazistatistik / include / yilmazistatistik.php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

thank you yılmaz bey halletti sadece istastiğin üzerinde 2 rakamı mevcut onun silinmesi gerek

yilmaz 19 Nov 2020 18:50

Quote:

Originally Posted by 74v (Post 2604729)
maalesef yılmaz bey 74v.net bakınız nasıl duruyor

Temanın, Stil Değişken Editörü post_border değişkeni kalınlığı 7px olduğu için etkilenen kısımlar bozuluyordu. post_border değişkeni orijinalle dönderince düzeldi.

The theme's Style Variable Editor post_border variable has a thickness of 7px, so the affected parts were getting corrupted. Fixed after returning post_border variable with original.

74v 19 Nov 2020 19:03

Quote:

Originally Posted by yilmaz (Post 2604732)
Temanın, Stil Değişken Editörü post_border değişkeni kalınlığı 7px olduğu için etkilenen kısımlar bozuluyordu. post_border değişkeni orijinalle dönderince düzeldi.

The theme's Style Variable Editor post_border variable has a thickness of 7px, so the affected parts were getting corrupted. Fixed after returning post_border variable with original.

allah razı olsun hocam peki üstünde 2 numara diye bir rakam var onu nerden kaldırcam :)

yilmaz 19 Nov 2020 19:15

Quote:

Originally Posted by 74v (Post 2604733)
allah razı olsun hocam peki üstünde 2 numara diye bir rakam var onu nerden kaldırcam :)

Halloldu, hata ararken eklemiştim, kaldırdım.

It was okay, I added it while searching for errors, I removed it.

yilmaz 19 Nov 2020 19:33

Quote:

Originally Posted by Chicoynano (Post 2604730)
I try to help as much as I can, in the update if I choose to show Top Topic Starters an error appears that can be solved delete this line found in code 326 core / packages / yilmazistatistik / include / yilmazistatistik.php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You've been very helpful.
The error has been fixed.

USC 19 Nov 2020 20:45

Quote:

Originally Posted by yilmaz (Post 2604722)
It does not show the forums you have selected here.

https://www.vbulletin.org/forum/atta...1&d=1605761392

In the new version, I add a setting based on forum permissions.

my bad bro i overlooked that option ..thank you once again for your help ..

Chicoynano 20 Nov 2020 18:43

Have a suggestion if possible. Add an icon to display the options in User Stats <div class = "table_cell_yilmaz dikyazi_tp">
<div class = "popupmenu" id = "yui-gen1">

Chicoynano 20 Nov 2020 22:43

2 Attachment(s)
An impromptu solution can be this. Add this on line 119, before <div class = \ "popupmenu ">


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Blackhorse 23 Nov 2020 20:17

3 Attachment(s)
Hello Yilmaz,

I have tried everything, impossible to work!

in Options, it is there with no name as u can see in screenshot, also screenshot for when u double click on the space at the end .

It does appear in site builder, i try to add , and it is not

I have installed reinstalled three times, same

Thank you

yilmaz 23 Nov 2020 21:22

3 Attachment(s)
Quote:

Originally Posted by Blackhorse (Post 2604790)
Hello Yilmaz,

I have tried everything, impossible to work!

in Options, it is there with no name as u can see in screenshot, also screenshot for when u double click on the space at the end .

It does appear in site builder, i try to add , and it is not

I have installed reinstalled three times, same

Thank you

If you install the attached language pack on the Arabic language pack you are using, it should be fixed.

https://www.vbulletin.org/forum/atta...1&d=1606166695

Blackhorse 24 Nov 2020 00:39

Quote:

Originally Posted by yilmaz (Post 2604792)
If you install the attached language pack on the Arabic language pack you are using, it should be fixed.

https://www.vbulletin.org/forum/atta...1&d=1606166695

if i do, it would replace the arabic language, should i choose a new language?

yilmaz 24 Nov 2020 00:49

Quote:

Originally Posted by Blackhorse (Post 2604798)
if i do, it would replace the arabic language, should i choose a new language?

No, it will not replace.
This includes additional clauses that you will install.
It is not a main language package.
Install it on the Arabic language pack you are using.

Blackhorse 24 Nov 2020 02:53

1 Attachment(s)
Quote:

Originally Posted by yilmaz (Post 2604799)
No, it will not replace.
This includes additional clauses that you will install.
It is not a main language package.
Install it on the Arabic language pack you are using.

Thank you Yilmaz,

It is done and now working in cp options

but I get now this, as in attachment

leha 29 Nov 2020 14:57

1 Attachment(s)
How to do it on 5.6.4?

yilmaz 29 Nov 2020 15:15

Quote:

Originally Posted by leha (Post 2604913)
How to do it on 5.6.4?

You should apply this screenshot

https://vbulletin.org/forum/attachme...9&d=1601236558

leha 29 Nov 2020 17:31

1 Attachment(s)
Quote:

Originally Posted by yilmaz (Post 2604914)
You should apply this screenshot

Yes but

yilmaz 29 Nov 2020 17:55

1 Attachment(s)
Quote:

Originally Posted by leha (Post 2604919)
Yes but

It will adapt to the width of the screen if you drag it under the "Page Title Module".

https://www.vbulletin.org/forum/atta...1&d=1606672501

mp3president 18 Dec 2020 15:20

With me it keeps on loading, and after 2 or 3 minutes the content will be shown.

Newest Members / Top Posters Sooner

https://www.mupload.nl/img/pzy2mm5zt0aal.jpg

Could this have to do with the size of the forum?

Topics: 85.954 Posts: 1.077.403 Members: 6.192 Active Members: 4.695

yilmaz 18 Dec 2020 15:51

Quote:

Originally Posted by mp3president (Post 2605229)
With me it keeps on loading, and after 2 or 3 minutes the content will be shown.

Newest Members / Top Posters Sooner

Could this have to do with the size of the forum?

Topics: 85.954 Posts: 1.077.403 Members: 6.192 Active Members: 4.695


Installed in the forum with 25.000 users, there is no problem.
I just installed it on a new forum, it worked fine.
My suggestion is to delete core/packages/yilmazistatistik files from ftp.

Remove from the products, download the zipTry again.

mp3president 19 Dec 2020 07:18

Alright, did that but still has trouble loading.

Is it possible that the hack is loading longer as it has to go trough a lot of forum/subforums to collect the info wich are the latest topics?

yilmaz 19 Dec 2020 11:38

I will present a new module, it will be tabbed and simple.

mp3president 19 Dec 2020 11:51

Owsome, your service is 1000%.

Thanks ;)

jskoh 19 Dec 2020 12:52

cannot disable newest member and top poster. i only need latest post.

how to do?

yilmaz 19 Dec 2020 13:44

Quote:

Originally Posted by jskoh (Post 2605245)
cannot disable newest member and top poster. i only need latest post.

how to do?

I have to add an additional option. I add the ability to disable from options in the next version.

ywwz 25 Dec 2020 13:46

Quote:

Originally Posted by mp3president (Post 2605229)
With me it keeps on loading, and after 2 or 3 minutes the content will be shown.

Newest Members / Top Posters Sooner

https://www.vbulletin.org/forum/external/2020/12/1.jpg

Could this have to do with the size of the forum?

Topics: 85.954 Posts: 1.077.403 Members: 6.192 Active Members: 4.695

Mate I am running this mod on my very very new and emtpy forum, and I have the same problem. I didn't wait for 2 minutes so nothing showed up, only "loading..."

Works fine on 5.6.4
by effeff70
27 Dec 2020 08:17

Thank for your great work!

Mboora 31 Dec 2020 20:33

Quote:

Originally Posted by yilmaz (Post 2605241)
I will present a new module, it will be tabbed and simple.

Great.

Looking forward to it.

yilmaz 01 Jan 2021 19:23

Quote:

Originally Posted by Mboora (Post 2605485)
Great.

Looking forward to it.

Done, just unread post I have to add "new" icon or text

I added a video for the demo.

https://www.youtube.com/watch?v=yMKKBN5Q3rI

Mboora 01 Jan 2021 19:34

Quote:

Originally Posted by yilmaz (Post 2605511)
Done, just unread post I have to add "new" icon or text

I added a video for the demo.

https://www.youtube.com/watch?v=yMKKBN5Q3rI

Brilliant.

Can you upload new files to this post or do I just follow the video to get the tabbed version?

yilmaz 01 Jan 2021 19:54

Quote:

Originally Posted by Mboora (Post 2605512)
Brilliant.

Can you upload new files to this post or do I just follow the video to get the tabbed version?

This is a completely separate module, I am doing my last reviews, I start a new topic when finished.

Mboora 01 Jan 2021 19:55

Quote:

Originally Posted by yilmaz (Post 2605514)
This is a completely separate module, I am doing my last reviews, I start a new topic when finished.

Okay.

Apologies.

I will leave you to concentrate.

mr.firas 27 Feb 2021 09:13

dont work with 5.6.4

Mr Peabody 27 Feb 2021 22:31

Quote:

Originally Posted by mr.firas (Post 2606476)
dont work with 5.6.4

Yes it does.

mr.firas 28 Feb 2021 21:56

i am very sorry the problem is sloved and work done now

WanaGo 19 Jul 2021 06:47

Hi. Any way to get this working on VBulletin Cloud?

al3bed 19 Jul 2021 15:20

Helllo,

I have little problem here.. I tried to uninstalled as mentioned above then reinstall the product but I got no widget.. I tried to add the widget to different pages but no luck! Any idea what is the problem here?

update ..
------------------
I got this fixed by disabling css and templates as files

Brakedirt 19 Dec 2021 21:00

Hi,

On 5.6.5 i get
mod_fcgid: stderr: PHP Warning: Use of undefined constant VB_API - assumed 'VB_API' (this will throw an Error in a future version of PHP) /core/includes/init.php on line 199,

php 7.4

lange 23 Dec 2021 17:46

Quote:

Originally Posted by Brakedirt (Post 2607950)
Hi,

On 5.6.5 i get
mod_fcgid: stderr: PHP Warning: Use of undefined constant VB_API - assumed 'VB_API' (this will throw an Error in a future version of PHP) /core/includes/init.php on line 199,

php 7.4

Just to replace VB_API by 'VB_API' on line 199 inside /core/includes/init.php.

Works fine on 5.6.5 / PHP 8.0.12

Brakedirt 15 Jan 2022 22:37

Quote:

Originally Posted by lange (Post 2607960)
Just to replace VB_API by 'VB_API' on line 199 inside /core/includes/init.php.

Works fine on 5.6.5 / PHP 8.0.12

Thank You

mofeu 26 Jan 2022 15:17

thank you very much!!!

newguy 19 Mar 2022 00:21

I installed and all I get is "loading" nothing will load and show

newguy 19 Mar 2022 00:30

1 Attachment(s)
vb 5.6.4 and php 7.3 sorry I forgot to add that to my post.

yilmaz 19 Mar 2022 00:48

Quote:

Originally Posted by newguy (Post 2608347)
vb 5.6.4 and php 7.3 sorry I forgot to add that to my post.

This is an old plugin I don't intend to update it anymore, use this plugin as an alternative.

https://www.vbulletin.org/forum/showthread.php?t=328483


All times are GMT. The time now is 08:20.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.