vBulletin Mods

The Official vBulletin Modifications Site

gItemStats - World of Warcraft Itemstats
by Gryphon
05 Mar 2007 06:53

1 Attachment(s)
What is it?

gItemStats is a modification for vBulletin which allows you to display popup World of Warcraft item information on your fourms.

See this thread for the continuation of this modification.

Oll1 05 Mar 2007 11:30

Thank you very much!

I like the new Itemsstats with socket support :)

*thumbs up*

wstahlhut 05 Mar 2007 13:05

I do see some oddness if you edit a post with item BBcode in them...

ethics 05 Mar 2007 14:44

Anyway to make it so we can add a button for the editor? I know there's a way to do that with the custom bb code option in the admin. But need to know what replacements to use in the code.

bprell 05 Mar 2007 16:09

I was wondering if someone could walk me through a standard install process. I feel kind of dumb because the instructions just say to upload it and it should work. I'm not going to lie, I'm not very well-versed in vBulletin (or mods to it) as of yet. Here's what I did:

1) Uploaded the "include" and "itemstats" folder to my vbulletin directory on the web server.

2) Tried a test post...that didn't work. The text just showed up at [item] My Item[/item]

3) Realized that I never imported the included "product-gItemStats.xml" so I did that.

4) Tried another post. Still didn't work, but this time the text was indicated to be a hyperlink. It did quickly flash to an error page that said:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'DBUSER'@'localhost' (using password: YES) in E:\websites\forum_name\forums\itemstats\includes\sqlhelper.php on line 30
string(40) "Unable to connect to SQL host: localhost"
Still didn't work after that.

My problem is, I'm not sure if I missed a simple step that is just not causing it to work, or if I legitimately need to go in and edit something (not sure what that would be). I just know that I followed the instructions to "upload it and go" and I'm not having very much success.

If anyone could help me shed a little light on this, it would be greatly appreciated. Even if its just a matter of "ok dummy, here's exactly what you need to do, step by step", that's fine. Just not real sure what to do from here.

Thanks in advance!

Gryphon 05 Mar 2007 16:43

Well, I was afraid of that. Looks like you did everything correctly, however I tried to avoid having people need to edit any files but it looks like it might be something I can't get away from. Let me investigate it a bit more and see what I can find out.

If anyone has mysql connect errors, they can enter their database information into itemstats/config.php, and if this is the case, then the gItemStats options probably will not work correctly as well, for these options you will have to adjust in itemstats/config_itemstats.php

I tried to make it automatically use the vBulletin config, but depending on certain server configurations this may not work as the Itemstats config will probably reset what I have tried to set...if that makes any sense.

bprell 05 Mar 2007 16:53

Out of curiosity, I tried to edit the config.php file with my mySQL information. Still did not work and got the error


Failed to update item: Netherwind Crown (Table 'forums.item_cache' doesn't exist)
Failed to update item: Netherwind Crown (Table 'forums.item_cache' doesn't exist)
Not the end of the world. I think I'll back off the change to the file I just did and wait to hear something more fun and exciting from someone that knows what they are doing (versus me monkeying around with stuff and screwing it up) :)

Thanks for responding!

Gryphon 05 Mar 2007 16:55

wstahlhut, what kind of oddness? It appears to work fine for me.

Ethics, I will look into doing that.

bprell, I am currently working on a fix for this.

*Edit: A fix is up, let me know if this works for you.

wstahlhut 05 Mar 2007 20:45

when you edit or quote this is what the quoted code looks like

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I did break the [URL] bbcode here so you can see...

Gryphon 05 Mar 2007 21:14

Hmm interesting, I can not get my forums to reproduce that.

bprell 05 Mar 2007 22:21


Originally Posted by Blackjack (Post 1196313)
wstahlhut, what kind of oddness? It appears to work fine for me.

Ethics, I will look into doing that.

bprell, I am currently working on a fix for this.

*Edit: A fix is up, let me know if this works for you.

Well something is definitely up. As soon as I uploaded the code it brought my vbulletin to its knees....won't hit the main page at all. Tried backing it out but that didn't help anything...must've overwritten some file somewhere. :(

The error I'm receiving is the following:


Fatal error: Cannot redeclare handle_bbcode_item() (previously declared in E:\websites\flockofemu\forums\includes\functions_gitemstats.php:767) in E:\websites\flockofemu\forums\itemstats\vbulletin_itemstats.php on line 10
You can see the error yourself if you'd like. www.flockofemu.com . If you have any thoughts, they'd be appreciated.

(I know this isn't the place for vbulletin support...it's my own deal as I'm the one that uploaded the code. Just figured I'd respond and see if anyone else knew anything.)

Gryphon 05 Mar 2007 22:26

Yeah, the product needed to be updated prior to upload the files.

You should be able to delete the contents of itemstats\vbulletin_itemstats.php to recover functionality and get the product installed.

bprell 05 Mar 2007 22:34

Just to verify what you're saying, I deleted the actual contents of that file while leaving everything else in tact. This is the error the forums are giving:


Warning: require_once(E:\websites\flockofemu\forums/includes/functions_gitemstats.php) [function.require-once]: failed to open stream: No such file or directory in \global.php(356) : eval()'d code on line 5

Fatal error: require_once() [function.require]: Failed opening required 'E:\websites\flockofemu\forums/includes/functions_gitemstats.php' (include_path='.;C:\php5\pear') in E:\websites\flockofemu\forums\global.php(356) : eval()'d code on line 5
I apologize for continuing to post this here as you're kind of my "lifeline" right now. :) If I need to take this to another place, just let me know.

Thanks again.

Gryphon 05 Mar 2007 22:36

It looks like functions_gitemstats.php is not uploaded possibly?

v1.02 is updated to prevent this from happening if the files are not available on the server.

bprell 05 Mar 2007 23:12

Just wanted to let you know that this resolved my issue...I'll post another update once I get a chance to load the new code. Thanks again for all of your help!

All times are GMT. The time now is 06:29.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.