vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

dougdirac 05 Sep 2012 10:49

D'oh.. beat me too it.

Broken use profile links
by naomi.rosenberg
05 Sep 2012 16:24

Hi,

In the course of de-spamming, when you get to /inlinemod.php, it says "Spam-o-matic has performed the following actions" and displays a bunch of links to user profiles.

These links point to /user.php, which does not exist.

Is this a know issue?

Thanks

N

Syxguns 05 Sep 2012 19:32

Quote:

Originally Posted by naomi.rosenberg (Post 2362898)
Hi,

In the course of de-spamming, when you get to /inlinemod.php, it says "Spam-o-matic has performed the following actions" and displays a bunch of links to user profiles.

These links point to /user.php, which does not exist.

Is this a know issue?

Thanks

N

That list is new registrations, that have not ever made a post. New registrations have to post before they are considered moderated, even if you do not use the S-O-M or vB moderation of posts.

Many people register and read but never post. I have done that on a number of forums. I'm not a spammer, I just don't have any information to post.

naomi.rosenberg 06 Sep 2012 10:05

The problem is that the links are broken. The names of those users are clickable links. The links point to a non-existent page called /user.php.

Is this a known issue or should I file a bug report?

Thanks.


Quote:

Originally Posted by Syxguns (Post 2362956)
That list is new registrations, that have not ever made a post. New registrations have to post before they are considered moderated, even if you do not use the S-O-M or vB moderation of posts.

Many people register and read but never post. I have done that on a number of forums. I'm not a spammer, I just don't have any information to post.


Syxguns 06 Sep 2012 10:42

Quote:

Originally Posted by naomi.rosenberg (Post 2363025)
The problem is that the links are broken. The names of those users are clickable links. The links point to a non-existent page called /user.php.

Is this a known issue or should I file a bug report?

Thanks.

I'm not sure about that. I though the link should point to usercp.php but that doesn't seem to be correct.

I've personally never worried about that as it has to do with users that share the same IP and so forth. Maybe someone else is a little more familiar with this and could give you more detail. I don't know that submitting the issue would be something that would get fixed. There hasn't been an update on this mod in quite a while.

I just look at the list, but for the most part the information that is given may be accessed through the AdminCP if you need to do anything, but I have never messed with it. Basically the information looks like this:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The information is pretty much standard info that you should already know as an Admin of the site. This of course also depends on which modifications that you use, but I personally don't have a problem with it. Maybe someone else could help you out here.:)

killerford 07 Sep 2012 11:31

I'm getting sick of the spammers on my forum and I've been directed here.. I'm hoping to use this and to stop the spammers on my forum. I've just downloaded the file and reading through the read me information and came across this at the bottom.

'* Please note, for this plugin to work, cURL must be installed on the server
or allow_url_fopen enable in PHP settings'

I don't know where or how to change or do any of those. Do I need to change one of these for this mod to work? If so could someone tell me how?

kh99 07 Sep 2012 11:50

Quote:

Originally Posted by killerford (Post 2363310)
'* Please note, for this plugin to work, cURL must be installed on the server
or allow_url_fopen enable in PHP settings'

I don't know where or how to change or do any of those. Do I need to change one of these for this mod to work? If so could someone tell me how?


You can change allow_url_fopen in the php.ini file. I think cURL is a package that has to be installed. In either case, unless you do your own server admin that would be something to ask your host about.

If you're not sure if about those settings, you can go to "View PHP Info" under Maintenance in the admincp. Under the section header "core" it should show the value for allow_url_fopen. I believe if cURL is installed it will have it's own section showing the settings for that module.

Edit: yeah, I should probably have put that second paragraph first, and started out by saying that you may not have to change anything.

rhody401 07 Sep 2012 19:13

I suggest trying it first, to see if it's broken. Most likely those are already enabled, and it'll work fine. :)

I also suggest turning off the nickname check against the stopforumspam.com database. You'll get false positives from legitimate people with this option on. (default)

fsSnowboard 08 Sep 2012 01:47

I got the following error when trying to install v2.0.2 on a fresh upgrade of vBulletin 4.2.0 PL2.

Quote:

Database error in vBulletin 4.2.0:

Invalid SQL:
CREATE TABLE IF NOT EXISTS `glowhostspamomatic_log`(
`date` DATETIME NOT NULL,
`ip` VARCHAR(15) NOT NULL,
`email` VARCHAR(255) NOT NULL,
`username` VARCHAR(255) NOT NULL,
`message` VARCHAR(255) NOT NULL,
`is_blocked` TINYINT NOT NULL DEFAULT "0",
`user_hash` VARCHAR(50) NOT NULL,
`user_id` INT NOT NULL
) TYPE=MyISAM;;

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 10
Any ideas?

Syxguns 08 Sep 2012 02:22

Quote:

Originally Posted by fsSnowboard (Post 2363532)
I got the following error when trying to install v2.0.2 on a fresh upgrade of vBulletin 4.2.0 PL2.



Any ideas?

Yes, replace TYPE=MyISAM with ENGINE=MyISAM There should be 3 instances of this in the XML file. You will need Notpad++ to view and make the changes you may download it here: Notpad++ download

fsSnowboard 08 Sep 2012 13:14

that got it, thanks

Syxguns 08 Sep 2012 19:36

Quote:

Originally Posted by fsSnowboard (Post 2363644)
that got it, thanks

Make sure to NOT select the check user name option. Only check e-mail and IP address.

ishtarsgate 08 Sep 2012 23:17

I just installed my Spam-o-Matic last night, and was absolutely thrilled with it until I noticed a few spammers getting on. Took me a while to realise that happened. Stop Forum Spam is down... Drat and darn it!

One of the Glow Host options is: What should happen if the remote connection times out when querying the new registration? And it was set to Allow Registration.

I realised that the remote connection must be timing out and so I tried to get on to Stop Forum Span in another tab, and that's when I found out it was down.

I didn't think there was any point in setting it to Block Registration because that way, a lot of innocent people could get caught by it.

So I've had to stop user registrations totally for a while, while SFS get it sorted out.

I'm wondering though how often SFS gets brought it down, since so many of us are reliant on them?

Alibass 08 Sep 2012 23:35

Occasionally but not often. Everyone has maintenance to do from time to time.

I keep my registration blocked. If they are legit users they will comeback later and register. Rather loose a few than have a ton of spammers mucking up my site.

-A

ishtarsgate 08 Sep 2012 23:38

Hi Alibass, that's good to know that SFS are not down that often.

Yes, I think that keeping registration turned off is a much better option than having spammers all over the site.


All times are GMT. The time now is 05:42.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.