vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

GerstnerUSA 11 Apr 2013 02:36

Quote:

Originally Posted by ForceHSS (Post 2415618)
You need to change the settings in this mod and the default settings for modding posts

I am not sure what settings you are referring to?

I have set the mod to have SFS check IP and check e-mail addresses, but SOM has yet to deny a single registration.

I have had over 40 new registrations since i re-installed the mod today (12 hours ago).
38 Spammers Permanently Banned
26 Spammy Posts Automatically Moderated


I just checked one of the moderated posts on my forum and it was posted by:
User Details:
Username: nawfuscuncasy
User ID Number: 451
User E-mail: [email protected]
User Registration IP Address: 168.63.134.90
User IP Address for Selected Post: 168.63.134.90

I did a search on StopForumSpam and it shows:
Found 236 entries for "168.63.134.90"

The first 50 entries on the search show the same e-mail and IP address as the person registered on my forum. I would assume that this user should have been denied registration by SOM, but it wasn't...

Any Suggestions?

Bluemax712 11 Apr 2013 05:11

Quote:

Originally Posted by GerstnerUSA (Post 2415649)
I am not sure what settings you are referring to?

I have set the mod to have SFS check IP and check e-mail addresses, but SOM has yet to deny a single registration.

I have had over 40 new registrations since i re-installed the mod today (12 hours ago).
38 Spammers Permanently Banned
26 Spammy Posts Automatically Moderated


I just checked one of the moderated posts on my forum and it was posted by:
User Details:
Username: nawfuscuncasy
User ID Number: 451
User E-mail: [email protected]
User Registration IP Address: 168.63.134.90
User IP Address for Selected Post: 168.63.134.90

I did a search on StopForumSpam and it shows:
Found 236 entries for "168.63.134.90"

The first 50 entries on the search show the same e-mail and IP address as the person registered on my forum. I would assume that this user should have been denied registration by SOM, but it wasn't...

Any Suggestions?

Is this the only Mod you have running on your server - have you disabled all others?

Syxguns 11 Apr 2013 09:16

Quote:

Originally Posted by GerstnerUSA (Post 2415649)
I am not sure what settings you are referring to?
Any Suggestions?

GerstnerUSA,
Some of my settings may differ from others, it depends mostly on the amount of security that you need. This is my one and only mod for stopping bad registration. The only other thing that I use is Solve Media but that is to help generate a little revenue! So spammers give it your best shot, I make money every time you try.

This may be long, but maybe it will help others as well. I will not note everything because it is user preference.

First Akismet is for Blogs:

Enabled
Post Count: 5
Enter your key
Easy Cleanup: Yes

Stop Forum Spam IP Check: Enabled
User Name Check: Disabled (This setting may vary from user to user)
Email Check: Enabled
Desired Action: Log and Block Registration

Query Connection Errors: This one may vary from user to user as well. If the SFS database is down or unable to retrieve records you have two options. I Allow registration even if it means I may have to both remove them, block the IP and or E-mail. Always do a search before you block an IP!!

Remote Expiry: Another one that users may have set different. I have mine set to 30 but if you are having consistent a consistent problem you may want to set it higher. Just remember that if you do innocent people could have a problem being issued a dynamic address that a spammer used before them.

SFS Key:

Easy Clean Up: Yes

I used the Newbies Manager group once but I currently have it disabled. It is a good feature to turn on if you are having persistent problems. You may read about it here: http://forums.glowhost.com/programmi...ager-2382.html

I also currently have Auto Moderation Disabled.

The next few I don't even use at the time being. They primarily have to do with the Newbies group. However, there are a few more options that I do have enabled, but the list is pretty long.

See if your current settings are set up similar to mine. Maybe this will fix your issue.

GerstnerUSA 11 Apr 2013 14:22

@Syxguns @apsrfbv4

Thank you for your responses.

I don't have any other Mods installed on the forum. My website does have OpenCart running and a RapidSSL Certificate.

I have checked through my settings>options>glowhost-spam-o-matic and they all were already using the same answers you recommended:

Stop Forum Spam IP Check: Enabled
User Name Check: Disabled
Email Check: Enabled
Desired Action: Log and Block Registration
Query Connection Errors: Allow Registration
Remote Expiry: 30
SFS Key: (I have not applied for one yet, will it check IP's/e-mail's without a key?)
Easy Clean Up: Yes

The only places that i differ from your description are:
I do not have an Akismet Key
I have Auto-Moderation "Enabled"

I have checked my IP address and my e-mail address in the SFS search area, and neither come up with any results. I would assume that they would not be blocking e-mail and IP Checking from my forum.

Could there be a setting that i accidentally changed somewhere in the forum that would not allow it to communicate or receive data from external websites? (ie. not allowing it to check with StopForumSpam..)

Do i need to add the StopForumSpam website somewhere within the settings as a trusted source?

Thank you for your time...

Bluemax712 11 Apr 2013 16:57

On a test 4.2 server I tried registering the user with email [email protected]
and SOM stopped it with a "registration denied" message
It doesn't have a key installed - so it does work/block without one (normally)

One thing to check is the first option for SOM
the GroupProtect IDs is this set for 5,6,7?
Edit: then again if it is still moderating posts but not preventing signups it's probably not this setting - nm


Could that user have registered on your forum before it was added to the SFS database?


You can try doing a test register of a bad email address yourself
-Since you don't want an email sent out for the test you can disable email temporarily on your server by adding this line to includes/config.php

define('DISABLE_MAIL', 1);

- Then pick an email address from the current SFS database and try registering with it to see if it is blocked
- and remember to remove line to re-enable email after done testing :)



Also if you have root on your server?
You could capture a tcpdump during the signup and should see some traffic to www.stopforumspam.com
with a "GET /[email protected]" and a "GET /api?ip=xxx.xxx.xxx.xxx" in it


Or this may be easier to try from shell window on your server (without needing root):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and the reply back from SFS in the response.txt file should contain something like:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Bluemax712 11 Apr 2013 21:10

Quote:

Originally Posted by GerstnerUSA (Post 2415549)
Today, I uninstalled and re-installed the mod and I am still getting the same results.

Everyone is being allowed to register, but their posts are being moderated.

I am also running OpenCart on my website, so i know that cURL is running properly.

Should I try "or allow_url_fopen enable in PHP settings"? If so, where would i find the PHP Settings to change this?

Any suggestions?

in the CP--> Maintenance--> View PHP Info:
allow_url_fopen: On On
cURL support: enabled

GerstnerUSA 11 Apr 2013 21:50

@apsrfvb4

I checked in the CP--> Maintenance--> View PHP Info:
allow_url_fopen: is showing On On
cURL support: is showing enabled

From your previous post, i checked with my domain host support (explained what i wanted to try) and they said that they don't have a shell window, or root access that i can use to try and test your other suggestions.

I tried to register with an e-mail address (em***[email protected]) that is on the front page of SFS (Top e-mails submitted) and i was able to register on my forum.

I checked the SOM Log Viewer and it shows: "em***[email protected] - Passed StopForumSpam checks. Sent to vBulletin Registration System."

I have my forum set-up as a subdomain (forum.mydomain.com) , and I installed all of the files into a subdirectory (/forum) on my website, not the root directory. Would that make any difference with anything?

Thank you for all of your suggestions. I hate to ask if you have any other ideas...

Bluemax712 11 Apr 2013 22:24

other than try setting up a whole new test installation in something like forum2.mydomain.com
and see if can get it working.

Without shell access it's tuff - might even want to find another provider
especially if they don't have shell access themselves.

GerstnerUSA 11 Apr 2013 23:15

@apsrfvb4

Thank you for all of your help. I will try a fresh install on another subdomain with a new database. Once i set it up, i will update this thread with my findings.

ForceHSS 12 Apr 2013 04:07

Quote:

Originally Posted by GerstnerUSA (Post 2415806)
@apsrfvb4

Thank you for all of your help. I will try a fresh install on another subdomain with a new database. Once i set it up, i will update this thread with my findings.

got your pm all fixed now for you

the1rabbits 13 Apr 2013 05:45

A lot of legitimate users are trying to sign up but they are using the Contact Us link to tell me that they are being caught as spam and consequently unable to signup.

I'm not sure why this is actually happening when they are not spam?

Syxguns 13 Apr 2013 08:50

Quote:

Originally Posted by the1rabbits (Post 2416049)
A lot of legitimate users are trying to sign up but they are using the Contact Us link to tell me that they are being caught as spam and consequently unable to signup.

I'm not sure why this is actually happening when they are not spam?

This is most likely due to the fact that you have "Username Check" Enabled. Set that to be Disabled. Only check IP address and e-mail address. Also make sure that "Remote Expiry" is not set to high.

the1rabbits 13 Apr 2013 14:22

Quote:

Originally Posted by Syxguns (Post 2416061)
This is most likely due to the fact that you have "Username Check" Enabled. Set that to be Disabled. Only check IP address and e-mail address. Also make sure that "Remote Expiry" is not set to high.

Thanks for that tip. I'll try adjusting those settings and hopefully it no longer blocks the good users.

vbresults 13 Apr 2013 14:35

There's no reason you should have to edit PHP code. Try something simple and more effective, like this:

http://www.vbulletin.org/forum/showthread.php?t=289463

Syxguns 13 Apr 2013 16:55

Quote:

Originally Posted by vbresults (Post 2416108)
There's no reason you should have to edit PHP code. Try something simple and more effective, like this:

http://www.vbulletin.org/forum/showthread.php?t=289463

No one is editing any code here. These are adjustments within the AdminCP for this mod.


All times are GMT. The time now is 05:56.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.