vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

ihstiv 09 Dec 2011 17:05

This is a great mod - we've been using it for a while now, and it's saved us a lot of time!

We are now fine-tuning and trying to reduce the # of legitimate users that are being blocked. The first thing we've done is to turn off the username check - we had one user recently with username 'Jack' that was blocked due to his username matching on SFS..

My question is: what is the easiest way to Lift a Ban on a user? I see them listed in the log file, but I'm not finding any way to release them from the user ban..

Do I just have to go to ACP > Users > Add new user - and manually create their account?

Thanks!

ihstiv 09 Dec 2011 19:06

Quote:

Originally Posted by ihstiv (Post 2276243)
This is a great mod - we've been using it for a while now, and it's saved us a lot of time!

We are now fine-tuning and trying to reduce the # of legitimate users that are being blocked. The first thing we've done is to turn off the username check - we had one user recently with username 'Jack' that was blocked due to his username matching on SFS..

My question is: what is the easiest way to Lift a Ban on a user? I see them listed in the log file, but I'm not finding any way to release them from the user ban..

Do I just have to go to ACP > Users > Add new user - and manually create their account?

Thanks!

I think I found the answer to my own question; since no user account is created when a user is 'blocked' by spamomatic - there is no way to 'lift the ban'

Any suggestions for another approach to this that would involve lest steps than manually creating user accounts for legitimate users?

Thanks

TeknoSounds 10 Dec 2011 21:42

Turn off username checking. Since bots use fairly common names sometimes, real people will get blocked. Just keep IP and email address checking on, turn on human verification in your VB settings and ask a simple question.

cool_recep 12 Dec 2011 01:35

The best plugin on my forum after vBSEO :) Waiting for the next version ;)

hubbers72 14 Dec 2011 21:39

Hi I'm new :)

And I'm getting these errors after a relatively new installation of 4.1.8.

The only add on I have added is GlowHost Spam-O-matic

GlowHost Spam-O-matich logs
Warning: require_once() [function.require-once]: Unable to access ../upload/admincp/global.php in /home/sitename/public_html/admincp/glowhostspamomatic.php on line 11

Warning: require_once(../upload/admincp/global.php) [function.require-once]: failed to open stream: No such file or directory in /home/sitename/public_html/admincp/glowhostspamomatic.php on line 11

Fatal error: require_once() [function.require]: Failed opening required '../upload/admincp/global.php' (include_path='.:/usr/lib/php') in /home/sitename/public_html/admincp/glowhostspamomatic.php on line 11

And on the CP I get these

Tags
Parse error: syntax error, unexpected T_STRING in /home/sitename/public_html/admincp/tag.php on line 585

Manage content priority
Parse error: syntax error, unexpected T_STRING in /home/sitename/public_html/admincp/sitemap.php on line 180

Rebuild sitemap
Parse error: syntax error, unexpected T_STRING in /home/sitename/public_html/admincp/sitemap.php on line 180

But even if I disable the GlowHost pluggin I still get the last three errors. And there doesn't look anything too suspiscious on line 180.

I've renamed the admincp to another name (not shown above) but I updated that value to the correct one in glowhostspamomatic.php on line 11

Any ideas?

ForceHSS 14 Dec 2011 22:09

it says you dont have the file uploaded to your admincp folder uploading the file will fix the problem

hubbers72 14 Dec 2011 22:36

Hi, thanks for the reply.

I had a typo above. Yes the file glowhostspamomatic.php is uploaded and in the correct folder. I renamed that folder on install for security but have updated the filename on line 11 so that it matches the correct structure.

Not sure why the xml is being impacted?

maxicroma 15 Dec 2011 12:59

I keep having problems whit my forum.
When i try to delete post and its activated the Spam-O-Matic it give these error


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I need a way to fix it

Keyvan63 20 Dec 2011 19:18

Does it work with VB 4.1.8 and up?
I get errors when importing it:

Database error in vBulletin 4.1.8:

Invalid SQL:
CREATE TABLE IF NOT EXISTS `glowhostspamomatic_log`(
`date` DATETIME NOT NULL,
`ip` VARCHAR(15) NOT NULL,
`email` VARCHAR(255) NOT NULL,
`username` VARCHAR(255) NOT NULL,
`message` VARCHAR(255) NOT NULL,
`is_blocked` TINYINT NOT NULL DEFAULT "0",
`user_hash` VARCHAR(50) NOT NULL,
`user_id` INT NOT NULL
) TYPE=MyISAM;;

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 10
Error Number : 1064
Request Date : Tuesday, December 20th 2011 @ 08:17:26 PM
Error Date : Tuesday, December 20th 2011 @ 08:17:27 PM
Script : http://localhost/AW/admincp/plugin.php?do=productimport
Referrer : http://localhost/AW/admincp/plugin.php?do=productadd
IP Address : ::1
Username :XXXX
Classname : vB_Database
MySQL Version : 5.5.16


RESOLVED by:
Replace TYPE=MyISAM to ENGINE=MyISAM in the xml file it is MySQL variable which changed from this version i run.
Thank U

ForceHSS 20 Dec 2011 22:03

Quote:

Originally Posted by hubbers72 (Post 2277826)
Hi, thanks for the reply.

I had a typo above. Yes the file glowhostspamomatic.php is uploaded and in the correct folder. I renamed that folder on install for security but have updated the filename on line 11 so that it matches the correct structure.

Not sure why the xml is being impacted?

try uninstalling the plugin and reinstalling it again see if that fixes the problem

cool_recep 22 Dec 2011 02:00

4.1.9 and works fine.

[email protected] 23 Dec 2011 19:46

Absolutely brilliant, what a saviour to say the least!

I had been battling spammers on a daily basis lately, I tried all sorted.

In a space of about just over 36 hours
406 Spammers Denied Registration
3 Spammy Posts Automatically Moderated

Results speak for themselves.

One question I do have, I have perhaps 3 or so users which I know are spammers, I don't want to go banning them since it doesn't help anyone, is there a way of reporting them? Share the love I say.

Cheers

DaleM 23 Dec 2011 20:44

I can't remember when I installed mine but it's denied 11213 registrations so far and still going strong. HIghly recommend!

ArchAngelz 24 Dec 2011 14:59

I just installed this and realised that the "Spam-O-Matic" option only appears in thread view. Is it possible to have it appear also in forum view or new posts view so that we can settle many spam threads in one shot; rather than go into each thread to do it?

The Rocketeer 24 Dec 2011 16:27

Quote:

Originally Posted by [email protected] (Post 2280510)
Absolutely brilliant, what a saviour to say the least!

I had been battling spammers on a daily basis lately, I tried all sorted.

In a space of about just over 36 hours
406 Spammers Denied Registration
3 Spammy Posts Automatically Moderated

Results speak for themselves.

One question I do have, I have perhaps 3 or so users which I know are spammers, I don't want to go banning them since it doesn't help anyone, is there a way of reporting them? Share the love I say.

Cheers

there used to be way to do all this is version 1x. but he removed most good features in version 2. I asked him to fix it in the next version, but its been too long. :erm:


All times are GMT. The time now is 22:30.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.