vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

sevsev 02 Oct 2010 14:17

Amazing mod! I was getting 50+ spam bot signups and 50+ spam posts a day before. Haven't had one creep through for 2 days now.

Strauss 03 Oct 2010 19:04

once you download to site . does it work automatically or is there an on and off switch? sorry new to this thanks

joshskeety 04 Oct 2010 16:02

Any Idea why all my RSS bots are being moderated even though their post count is WAY over the amount provided in the AdminCP??

I saw one post early on with the same problem, but the dev chalked it up to his problem, but If Im having the EXACT same problem, there has to be some sort of conflict.

Thanks,

BadgerDog 04 Oct 2010 18:14

Quote:

Originally Posted by joshskeety (Post 2106690)
Any Idea why all my RSS bots are being moderated even though their post count is WAY over the amount provided in the AdminCP??

I saw one post early on with the same problem, but the dev chalked it up to his problem, but If Im having the EXACT same problem, there has to be some sort of conflict.

Thanks,

I had the same problem and finally had to turn the moderated post function of this mod OFF to stop it from happening ... ;)

Regards,
Badger

GlowHost.com 06 Oct 2010 00:15

Quote:

Originally Posted by joshskeety (Post 2106690)
Any Idea why all my RSS bots are being moderated even though their post count is WAY over the amount provided in the AdminCP??

I saw one post early on with the same problem, but the dev chalked it up to his problem, but If Im having the EXACT same problem, there has to be some sort of conflict.

Thanks,

I cant tell you why. I requested admincp logins to anyone who is having this problem so I can have a look. If I cannot duplicate it, it can't be fixed.

If logins are not something you want to give, understandable but in that case I would need exact and extremely precise instructions on your RSS settings so that I can lug them into our test forum to see what the deal is.

vbnewbieuser 06 Oct 2010 06:36

how to get Spam-O-Matic API Key?? thru your forum??

post ham in akismet database ?
by muhonki
06 Oct 2010 08:51

When I mark post as "validate" (if it was incorrectly marked as spam), does spam-o-matic post it as ham to Akismet database ?

DarkWolf74 07 Oct 2010 17:21

Quote:

Originally Posted by GlowHost.com (Post 2097513)
By the way, if someone wants to show me this in action I might be able to find a fix for it faster if it is really an issue with Spam-O-Matic. I cannot duplicate it so if someone wants to let me login to their admincp to see the problem it might lead to an answer sooner. I need to be able to duplicate it in order to fix it.

I'm having the same issue, where the post count of the set user in RSS Poster is not being honored. Letting you into the admincp would do little to help correct or debug this issue, but I'll dig through the code and see what I can find.

My speculation is that the RSS Poster Robot does not load any information of the set poster such as their post count.

The only work around that comes to mind is to modify Spam-O-Matic to verify the post count variable and if null, to get the post count from the userid itself.

Duplication is not hard...

1) Set up an RSS Feed with the following.
--- http://news.google.com/news?q=news&output=rss
--- Username: Anyone who has high post count and should NEVER be moderated.

2) In Spam-O-Matic Settings.
--- Auto-Moderation: Keywords -> Add "news"

3) Wait.. Anything with "news" in it will be put into moderation.

If this does duplicate the problem. Yay. Fix it.. :D
If not, let me know and I'll put up a dev forum and make sure that the problem is happening so that you can have full access and see exactly what is happening.

GlowHost.com 08 Oct 2010 17:37

Quote:

Originally Posted by vbnewbieuser (Post 2107298)
how to get Spam-O-Matic API Key?? thru your forum??

Spam-O-Matic doesn't have an API Key. Akismet and StopForumSpam have keys, you can get those on the associated websites.

Quote:

Originally Posted by muhonki (Post 2107312)
When I mark post as "validate" (if it was incorrectly marked as spam), does spam-o-matic post it as ham to Akismet database ?

No, that would not make a lot of sense I guess. If it does, it would be a bug to report. The only time users are submitted to Akismet is:

A) If you have submission enabled in your S-O-M settings.
B) If you delete posts as spam.

GlowHost.com 08 Oct 2010 17:38

Quote:

Originally Posted by DarkWolf74 (Post 2107742)

If this does duplicate the problem. Yay. Fix it.. :D
If not, let me know and I'll put up a dev forum and make sure that the problem is happening so that you can have full access and see exactly what is happening.

Thanks for the documentation. I will try to get this tested and figure out what the deal is.

Sax on the Web 12 Oct 2010 09:24

Submitting spammer data to Stopforumspam.com won't work.
What to look?
thanks,

maokaang 13 Oct 2010 08:14

I'm having the same problem with all my RSS feed threads being moderated (all S-O-M versions including 1.2.8).

I have Akismet switched off in Spam-O-Matic.
RSS threads generated are being moderated on every occasion. Almost without exception, none of the words in 'Auto-Moderation: Keywords' appear in the thread.

Here are my settings for one of the RSS feeds:

Feed is Enabled: Yes
Title: BBC News Asia-Pacific
URL of Feed: http://feeds.bbci.co.uk/news/world/asia_pacific/rss.xml
Check Feed Every... 30 minutes
Maximum Items to Fetch: 0

Search Items for Words Only:
Quote:

Thai
Thailand
Bangkok
"Chiang Mai"
"Hua Hin"
Pattaya
Search Item Body: checked
User Name: (An Admin User with 500+ posts)
Forum: (A selected forum)
Allow Smilies : No
Display Signature: No
Convert HTML to BB Code: Yes
Title Template: {feed:title}

Body Template:
Quote:

{feed:description}

[url={feed:link}]Read full article ...[/url]

[color=gray][size=1](This thread was generated automatically by Mywebsite.com from the BBC News Asia-Pacific RSS Feed)[/size][/color]
Post Items as Threads: selected
Post Icons: (one icon selected)
Make Thread Sticky: No
Moderate Thread: No
Thread Action Delay (Hours): 0
Unstick Sticky Thread After Delay: No
Close Thread After Delay: No
Post Items as Announcements: not selected
(last two announcement options n/a)


Relevant Spam-O-Matic settings are:

Auto-Moderation: Enabled
Auto-Moderation: Minimum Post Count: 5
Auto-Moderation: URL Count: 0
Auto-Moderation: Post Action: Moderate Post


Hope that helps.

Regards

maokaang 13 Oct 2010 08:36

A separate issue and further suggestion:

In functions_ghsom.php, the modcp directory is hard coded twice:

Line 317: "../modcp/banning.php?do=banuser&u='.$user['userid'].'"
Line 562: "modcp/moderate.php?do=posts"


Many people opt to change the name of their admincp and modcp directories. Without altering the code above, they'll get 404 errors when the above lines are executed.

Perhaps 'modcp' should be replaced with something equivalent to:

{$vbulletin->config[Misc][modcpdir]}



Great mod by the way. Got my vote last month. :up:

Regards
Paul

nkumaran 13 Oct 2010 15:23

Great mod.

GlowHost.com 13 Oct 2010 15:24

Thanks for the detailed information maokaang

I have not been able to get any RSS hits on the 2.0 beta version that we are testing but I am going to plug your settings in there to be sure.

Thanks for the vote and kind words. I will also look into those hardcoded modcp URLs.


All times are GMT. The time now is 08:44.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.