vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=328628

vBulletin 3.8.14 (PHP 7.4) - RELEASE
by Dr.CustUmz
27 Feb 2021 13:47

If you need vBulletin 3 with support for upto php 7.4 I have just bundled together a package and plan on supporting it.

This is NOT a complete vBulletin, This is NOT a Null! You will still need to have a legit copy of vBulletin 3.8.11, And yes although against vBulletin policy, someone has to update it, there are many of us who still use vB3 and we should HAVE to upgrade to other versions to get support.

Now I know releasing this is 100% a profit loss not only to myself, but to others who charge for such services also, but I feel with the more and more host providers only utilizing PHP 7 vBulletin 3 customers deserve some kind of support.


Updated to 3.8.14
You can find out more HERE!

lange 27 Feb 2021 14:21

1 Attachment(s)
Thank you for your share.

I see on your website
Quote:

Products Confirmed Incompatible with PHP 7.4
CYB - Chatbox
I can confirm that Cyb Chatbox is compatible with PHP 7.4.11.

Dr.CustUmz 27 Feb 2021 14:31

Those are the only 2 products I have installed on my forum that I did not make and both of them threw an error after upgrading, easy enough to fix, but by default the error was there.

lange 27 Feb 2021 14:45

2 Attachment(s)
I've dabbled in this product a lot and I'm not a coder but everything is working fine now.

The following Attachments can help:

Dr.CustUmz 27 Feb 2021 14:55

Quote:

Originally Posted by lange (Post 2606483)
I've dabbled in this product a lot and I'm not a coder but everything is working fine now.

The following Attachments can help:

your chatbox is modified, and not the original version located here:
https://www.vbulletin.org/forum/showthread.php?t=177552

So I stand by my statement, the default product does NOT work, and will need to be modified to support php 7.4

I'm not saying I do not know how to fix it (I have already)

In fact, your version strips some of the options just to be compatible ;)

lange 27 Feb 2021 15:14

I know you are a very good coder! :up:

I have to thank Pinkmilk again with this product because he helped me a lot in the following topic: https://www.vbulletin.org/forum/show...29#post2601729

Dr.CustUmz 06 Mar 2021 04:02

3.8.14 update

wangyu1314 06 Mar 2021 05:46

a good job. thank you.
Do you plan to be compatible with PHP8.0? Thank you.
VB 3.8.X has been officially EOL, but I think it is still very easy to use, it has many useful functions that VB5.X or XF2.3 still does not exist..

Dr.CustUmz 06 Mar 2021 05:55

when my server provider includes php 8 I will begin updating for it. although I may hold off for the first couple iterations, because like php7 alto of changes were made in between revisions. So I may wait for example 8.4

And yea I love vb3, the simplicity of it yet it has everything you need, and people dont realize ANY feature in all these new forum softwares, ANY FEAUTURE AT ALL can be brought to vb3. You are only limited by your creativity, ...and your wallet lol.

lange 06 Mar 2021 14:02

I am also interested in a PHP 8 compatible version.

boss22 10 Mar 2021 19:35

Quote:

Originally Posted by lange (Post 2606481)
Thank you for your share.

I see on your website
I can confirm that Cyb Chatbox is compatible with PHP 7.4.11.

i got this error when install your product above (chatbox for 7.4 PHP)


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

some help?

regards

lange 11 Mar 2021 00:04

I already had this error message in the past. You have to remove and reinstall the mod every time you get this error message.

take a look at https://www.vbulletin.org/forum/show...83&postcount=4

boss22 11 Mar 2021 00:38

Quote:

Originally Posted by lange (Post 2606617)
I already had this error message in the past. You have to remove and reinstall the mod every time you get this error message.

take a look at https://www.vbulletin.org/forum/show...83&postcount=4

I did it but error message come up whole time! Reinstalled and installed many times and made changes in plugin!

lange 11 Mar 2021 01:30

1 Attachment(s)
Try the attach file on a new install (uninstall your old install) and install the attach file.


Tested 10 min ago, it work fine on 3.8.11 & 7.4.x

boss22 11 Mar 2021 11:28

Quote:

Originally Posted by lange (Post 2606620)
Try the attach file on a new install (uninstall your old install) and install the attach file.


Tested 10 min ago, it work fine on 3.8.11 & 7.4.x

Thanks - works fine!


All times are GMT. The time now is 05:11.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.