vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=184267

vbAnonymizer
by Dismounted
03 Jul 2008 12:02

4 Attachment(s)
vbAnonymizer

Description:
This is a hack to "anonymize" all outgoing links from your forum to prevent the referrer information from being sent.

Installation:
All the installation information is in the package.

What's different about this one?
Unlike the other anonymizing hacks, this one is integrated with vBulletin, meaning it shows a nice message along with your forum's headers and footers.

Changes:
2 Templates
6 Plugins
2 Files

Other Versions:
vbAnonymizer for 3.6 - http://www.vbulletin.org/forum/showthread.php?t=131292

Uninstall Note
If you are having troubles with URLs after uninstalling this modification, please run the script in this post.

Dismounted 03 Jul 2008 12:03

Change Log:

3/10/2008 - Version 3.0
- Rewrite of Code to Streamline for Efficiency
- Fixed Local URL Issues
- Fixed No Follow Attribute Issues
- Renamed Local URLs list to Whitelist
- Added Ability to Rename 'redirector.php'

3/07/2008 - Version 2.8
- Fixed XSS Flaw
- Fixed Several Other Issues
- Updated ReadMe
- First 3.7 Release

24/4/2007 - Version 2.7
- Fixed Issues With rel="nofollow"
- Fixed Input Clean Variable
- Fixed Rewriting Issues

23/4/2007 - Version 2.6
- Added Option To Add rel="nofollow"
- Improved URL Encryption

2/4/2007 - Version 2.5
- Fixed 'No Delay' Issues
- Fixed Script Typos

29/3/2007 - Version 2.4
- Phrased WOL
- Fixed '&' Issues
- Fixed Compatibility Issues
- Added Function To Specify Path To Script

28/3/2007 - Version 2.3
- Slimlined Code

20/11/2006 - Version 2.2
- Fixed Custom BB Codes Not Working After vbAnonymizer Is Installed
- Fixed Posts Prior To Installing vbAnonymizer Containing URL's Not Being Anonymized
- Countdown Timer Can Be Disabled

19/11/2006 - Version 2.1
- Added Countdown Timer For Delay

19/11/2006 - Version 2.0
- Fixed Compatibility Problems
- Fixed Several Type Errors
- Fixed Injection Exploits
- Fixed URL's Not Being Anonymized In Signatures
- Fixed URL's With '&' Not Anonymizing Properly
- Added WOL Locations (Link on profile is the about page).
- Added "About" page, can be accessed by "./redirector.php?do=about"
- Added Customizable Redirection Page Text
- Added Clickable URL On Redirection Page

12/11/2006 - Version 1.0
- Initial Release

verino 03 Jul 2008 12:08

is this related with the cookies also ?

:D

Dismounted 03 Jul 2008 12:11

Sites cannot read another site's cookies.

verino 03 Jul 2008 12:37

Quote:

Originally Posted by Dismounted (Post 1565649)
Sites cannot read another site's cookies.

sorry, my stupid.

*installed*

ShiZoPhreN 03 Jul 2008 12:46

Hello,

I have more Errors ^^

But it is in German

when i go into a thread that i become in vB-System-Message

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and over the logo are this


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Thanks for help and sorry for my bad english :P

7lanet 03 Jul 2008 12:47

:up::up::up::up::up:

You are hero .

:D

KURTZ 03 Jul 2008 12:47

thx for sharing Hanson ... ;)

Dismounted 03 Jul 2008 13:00

Quote:

Originally Posted by ShiZoPhreN (Post 1565674)
Hello,

I have more Errors ^^

But it is in German

when i go into a thread that i become in vB-System-Message

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and over the logo are this


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Thanks for help and sorry for my bad english :P

Please download the 2.8 package and follow the upgrade procedure. The package was updated a few minutes after I attached it, as there were a few critical bugs in there. You must have gotten the old one :).

ShiZoPhreN 03 Jul 2008 13:25

Thanks it works :)

Qwest 03 Jul 2008 15:15

If you can add a blacklist feature to this that would be incredible and I would very likely give you my next born child.

Ex: a feature where you can add urls that you DON'T want to allow linking to. It would give the user a special "not allowed" message or something on the redirection page.

redlabour 03 Jul 2008 15:23

Quote:

Originally Posted by Qwest (Post 1565783)
Ex: a feature where you can add urls that you DON'T want to allow linking to. It would give the user a special "not allowed" message or something on the redirection page.

KILLERFEATURE :up:

parks 03 Jul 2008 21:05

thanks looks nice..............

aspeach 03 Jul 2008 23:21

Love the mod. But I need to find out how to use it with htaccess/htpasswd. When being redirected, members in my forum are prompted for a user/password. Any edits that can prevent this?

redlabour 03 Jul 2008 23:36

Quote:

Originally Posted by aspeach (Post 1566206)
Love the mod. But I need to find out how to use it with htaccess/htpasswd. When being redirected, members in my forum are prompted for a user/password. Any edits that can prevent this?

Canīt reproduce this Error. Using this Mod since Years now with a lot of different .htaccess Configurations. Never problems.

Please post excactly what you mean.

Hornstar 03 Jul 2008 23:58

excellent idea on the blacklist feature, i'd have many sites that I could add to the blacklist (but then again, i do enjoy censoring those sites ^^ )

anyway, nice to see your still releasing stuff Dismounted :)

bada_bing 04 Jul 2008 00:48

Works great thanks

Dismounted 04 Jul 2008 06:53

Quote:

Originally Posted by aspeach (Post 1566206)
Love the mod. But I need to find out how to use it with htaccess/htpasswd. When being redirected, members in my forum are prompted for a user/password. Any edits that can prevent this?

When they click the link to redirector.php or when they are redirected from redirector.php?
Quote:

Originally Posted by hornstar1337 (Post 1566244)
excellent idea on the blacklist feature, i'd have many sites that I could add to the blacklist (but then again, i do enjoy censoring those sites ^^ )

I've been thinking of adding the blacklist feature, but don't really want to mess anything else up :p.
Quote:

Originally Posted by hornstar1337 (Post 1566244)
anyway, nice to see your still releasing stuff Dismounted :)

Yea, it has been a while. And it has been a while since I'm logged onto GzN too.

Forum Lover 04 Jul 2008 07:26

Dismounted, I got little issues here,

I usually login at my site as, hxxtp://www.mysite.com/forum/ now, if someone put a link as hxxp://mysite.com/forum/ its redirecting.

how can i fix this?

I already put local address as : .myste.com www.mysite.com forum.mysite.com

dreads 04 Jul 2008 12:38

very nice ;D

aspeach 04 Jul 2008 18:16

Well redlabour, my site is protected with htaccess/htpasswd. You know how the login box pops up when you enter the site? When you click on the link, the redirect page pops up, then when the countdown is done, that same box pops up again and wants a user/pass to leave my site. That's it in a nutshell. And thanks for that quick response btw!

ikorolis 05 Jul 2008 00:53

hey my friend
update your mod 2.7 to 2.8 and give me this error see threats/topics/messages on my forum


Warning: Invalid argument supplied for foreach() in [path]/includes/init.php(293) : eval()'d code on line 68

how to fix?

now is disable this mod please tell me how to fix this error to see enable your mod/hack (i like this mod/hack)

OK im fixed (uninstalled complete your mod) and (installed again)

now its working fine all.

Q-v-n-s-Q 05 Jul 2008 02:42

cool, i was looking for this..thank for the update

Dismounted 05 Jul 2008 08:08

Quote:

Originally Posted by aspeach (Post 1566791)
Well redlabour, my site is protected with htaccess/htpasswd. You know how the login box pops up when you enter the site? When you click on the link, the redirect page pops up, then when the countdown is done, that same box pops up again and wants a user/pass to leave my site. That's it in a nutshell. And thanks for that quick response btw!

Are you sure it's not the site being linked to that requires a login?

aspeach 05 Jul 2008 13:59

No it's my site Dismounted. Then I put inj the u/p to my site and it brings me to the linked site. I'm thinking that all I need to do is put the u/p into the code somewhere but can't figure out where. Might also be noteworthy that htaccess/htp is in a subdomain directory where the forum resides and not the domain directory. Thanks for the reply. :)

Forum Lover 06 Jul 2008 03:33

My local links are also anonymized. Dismounted, how can I fix it?

Forum Lover 07 Jul 2008 18:50

simple bump, if its ok.

Dismounted 08 Jul 2008 07:17

What happens if you edit the post and save it again (removing the URL tags, but keeping the original link)?

fattony69 09 Jul 2008 02:21

Love the mod, but how do I have it not do it for links to other parts of the site for example other posts or threads?

Dismounted 09 Jul 2008 06:51

It should do that by default.

7lanet 09 Jul 2008 15:28

I subscribed to https://www.google.com/webmasters/tools
Google has sent warnings to me about the topics which contain links reorientation
What is the solution

Dismounted 09 Jul 2008 16:14

Please actually post the "warning"...

7lanet 09 Jul 2008 17:09

Error HTTP: 301 (final total was)
Title URL:http://www.7lanet.com/vb/t34739-new-post.html
Title URL:http://www.7lanet.com/vb/t34742-new-post.html
Title URL:http://www.7lanet.com/vb/t34733-new-post.html
Title URL:http://www.7lanet.com/vb/t34747-new-post.html
Title URL:http://www.7lanet.com/vb/t34735-new-post.html
Was found at:08 / 07 / 2008

this message

Quote:

URL addresses that could not be pursued
When the experienced eye of the URL addresses of your Sitemap file, we found that some URL addresses can not be accessed by Googlebot because it contains the operations redirect too many. Please change the URL addresses on file, which re Sitemap direction and replace the destination URL (goal reorientation). The submission of all arable URL addresses in force.

Raptor 09 Jul 2008 20:35

Is it possible to have this on a per forum basis ?

I only have a couple of forums out of 100+ that I need to anonymize

Thanks

Dismounted 10 Jul 2008 07:40

Quote:

Originally Posted by 7lanet (Post 1571066)

This is not caused by vbAnonymizer - it is caused by redirection on top of redirection by vBulletin.
Quote:

Originally Posted by Raptor (Post 1571270)
Is it possible to have this on a per forum basis ?

I only have a couple of forums out of 100+ that I need to anonymize

Thanks

Anything is possible ;). It is not currently coded in though.

Dr. Bantham 10 Jul 2008 22:54

After uninstalling this product, it appears that the revised URL with the "redirector.php" remains intact, which is seems to negate the link from working altogether.

Dismounted 11 Jul 2008 07:03

That should not happen - try clearing your post cache.

Dr. Bantham 11 Jul 2008 11:49

Quote:

Originally Posted by Dismounted (Post 1572517)
That should not happen - try clearing your post cache.

I am not certain, but I believe I may have tried that. It had only revised ten URL references, so I searched these out and manually changed them in the end. Someone should test this in order to be certain, as it appeared to me that new posts were being changed forever in lieu of on the fly. The mod was performing as intended, but for me it was interfering with other modes (particularly AME).

Dismounted 11 Jul 2008 12:26

What conflicts were you having with AME?

dadoc 12 Jul 2008 04:38

Hey Dismounted,
I understand what this mod does but would you be able to explain why it is important to have this mod installed?

What are the benefits?

redlabour 12 Jul 2008 07:20

Quote:

Originally Posted by Dismounted (Post 1572679)
What conflicts were you having with AME?

I use AME and have no Conflicts with vbAnonymizer.

Quote:

Originally Posted by dadoc (Post 1573247)
Hey Dismounted,
I understand what this mod does but would you be able to explain why it is important to have this mod installed?

Nobody can see in their Stats that you linked to one of their Articles.

Dismounted 12 Jul 2008 07:55

Quote:

Originally Posted by dadoc (Post 1573247)
Hey Dismounted,
I understand what this mod does but would you be able to explain why it is important to have this mod installed?

What are the benefits?

Also explained in the 3.6 thread, it basically removes the referrer header from HTTP requests (geeky tech stuff ;), don't stress). Some sites track the referrer header, to see who has come from where to access their sites.

xoutlawz00x 12 Jul 2008 08:36

why is this hack important im courious

Dismounted 12 Jul 2008 09:03

Please see the post above yours...:rolleyes:

rockylinux 12 Jul 2008 12:36

but this MOD. anonymize also the links between those images of the tags [IMG] ... because they are more subject than you referents in their host

Dismounted 12 Jul 2008 13:19

It's not practical because you would proxy your image through your server anyway, meaning the server that hosts the image will see your site.

NickyNet 15 Jul 2008 15:30

hi Dismounted,

do you know if vbAnonymizer will work with VB Project Tools too (i hoooppppeeee)?

Thank you in advance and have a nice day..

[EDIT]
tested on friends forum.. working fine! :up:

thank you!

Dismounted 16 Jul 2008 09:09

Quote:

Originally Posted by NickyNet (Post 1575942)
do you know if vbAnonymizer will work with VB Project Tools too

It should work with any modification that uses the vBulletin BB code class.

therealyaya 16 Jul 2008 12:45

thanks wery good

KURTZ 17 Jul 2008 14:26

Hanson, i've a big trouble, with your hack enabled i can't grab any embed video onto my board ... i use the passivevid hack

GlitchersCorner 17 Jul 2008 18:23

Possible to have a feature that records all links that have gone through vbAnonymizer?

KURTZ 17 Jul 2008 19:17

i just found another trouble ... i've the snap shots installed onto my board and with your hack they don't work ... :(

Kendothpro 20 Jul 2008 19:07

Just a piece of advice for those of you relying "heavily" on this mod: browsers such as opera or safari will still show redirect.php as the referrer, so you can and will be traced if some of your users click on a link using those browsers

cnutter 23 Jul 2008 18:23

Dismounted, Just a FYI I am having issues with uninstalling your hack. I uninstall it and all links that are leaving the site still show the redirect.php link and when you try to follow it you get a 404 error. Ive tried to fix this a few ways and doesnt see to want to uninstall right.

Skavenger 24 Jul 2008 02:39

Is there any way to exclude some forums? Thanks.

Dismounted 24 Jul 2008 09:55

Quote:

Originally Posted by cnutter (Post 1582389)
Dismounted, Just a FYI I am having issues with uninstalling your hack. I uninstall it and all links that are leaving the site still show the redirect.php link and when you try to follow it you get a 404 error. Ive tried to fix this a few ways and doesnt see to want to uninstall right.

I believe I provided help on the same issue in the 3.6 thread. I would suggest looking there as well.
Quote:

Originally Posted by Skavenger (Post 1582733)
Is there any way to exclude some forums? Thanks.

No, not at the moment.

Raptor 24 Jul 2008 12:54

just put this at the bottom of your footer. works in ALL browsers and works perfect on my boards


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


cnutter 24 Jul 2008 15:37

Quote:

Originally Posted by Dismounted (Post 1582916)
I believe I provided help on the same issue in the 3.6 thread. I would suggest looking there as well.

Well, I just searched the mod and went though the first 12 or so pages by hand and maybe Im blind but I cant find it. A page number or link would be helpful thanx. I am currently using the mod and dont intend to uninstall it but If I have to to try and get another mod to work I need to be able to figure this out.

Edit: I seem to have found after alot more searching someone talking to you about it in on page 24 / 25 of the 3.6.x mod threads. But I didnt see you give a fix other than telling them to search the db and excuting SQL Query. You never gave the SQL Query to run that I can see or find.

ErrorLog 24 Jul 2008 23:23

Thank You ..!

Dismounted 27 Jul 2008 06:35

1 Attachment(s)
Quote:

Originally Posted by Raptor (Post 1583023)
works in ALL browsers

Not really. Some people have Javascript enabled - your code will fail for them.
Quote:

Originally Posted by cnutter (Post 1583101)
I seem to have found after alot more searching someone talking to you about it in on page 24 / 25 of the 3.6.x mod threads. But I didnt see you give a fix other than telling them to search the db and excuting SQL Query. You never gave the SQL Query to run that I can see or find.

Upload the attached script to your forum root directory (where showthread.php is) and run it.

cnutter 28 Jul 2008 13:00

Quote:

Originally Posted by Dismounted (Post 1585018)
Not really. Some people have Javascript enabled - your code will fail for them.

Upload the attached script to your forum root directory (where showthread.php is) and run it.

Thanx guy. I am still using your product though I will keep this for use in future if I need to uninstall it to get something else working.

Dismounted 28 Jul 2008 13:58

Quote:

Originally Posted by cnutter (Post 1585867)
Thanx guy. I am still using your product though I will keep this for use in future if I need to uninstall it to get something else working.

Also, note that it should only be needed for some installations before 2.8 (ie. if you originally installed vbAnonymizer before 2.8 was released, this might be needed).

cnutter 29 Jul 2008 20:18

Quote:

Originally Posted by Dismounted (Post 1585903)
Also, note that it should only be needed for some installations before 2.8 (ie. if you originally installed vbAnonymizer before 2.8 was released, this might be needed).

The only version I have installed of this product ever was 2.8 and I incountered the uninstall issue.

DesiMix 30 Jul 2008 12:57

Ha, i just love this beacuse its nice saying u will be redirect :P

Al3malka.com 07 Aug 2008 13:26

hope you help me

i used vbanonymizer and uninstalled it but i have aproblem when i put url in forum and submit it // look

http://www.al3malka.com/vb/!p!http://www.al3malka.com/vb/t22674.htm

and before uninstalling it when i submit an article the url//

http://www.al3malka.com/vb/!p!http://www.al3malka.com/vb/redirector.php?url=http://www.al3malka.com/vb/t22674.htm

so we have the same problem when installing and uninstalling this product i need solution for this problem please:confused:

cnutter 07 Aug 2008 14:33

Quote:

Originally Posted by Al3malka.com (Post 1593337)
hope you help me

i used vbanonymizer and uninstalled it but i have aproblem when i put url in forum and submit it // look

http://www.al3malka.com/vb/!p!http://www.al3malka.com/vb/t22674.htm

and before uninstalling it when i submit an article the url//

http://www.al3malka.com/vb/!p!http://www.al3malka.com/vb/redirector.php?url=http://www.al3malka.com/vb/t22674.htm

so we have the same problem when installing and uninstalling this product i need solution for this problem please:confused:

This is the post were dismount attached the script to run to fix the uninstall issue. While I havnt tried it hope this works for you. He said it does.
http://www.vbulletin.org/forum/showp...8&postcount=60

Al3malka.com 07 Aug 2008 15:57

thx but i tried this script before but the same problem

the prolem is with internal links only , extrnal urls no problem with it

and when i disable hooks the problem disapear

Al3malka.com 07 Aug 2008 21:18

still waiting :(

KURTZ 08 Aug 2008 10:58

Hanson what about my troubles? :)

Dismounted 08 Aug 2008 15:33

Quote:

Originally Posted by Al3malka.com (Post 1593337)
hope you help me

i used vbanonymizer and uninstalled it but i have aproblem when i put url in forum and submit it // look

http://www.al3malka.com/vb/!p!http://www.al3malka.com/vb/t22674.htm

and before uninstalling it when i submit an article the url//

http://www.al3malka.com/vb/!p!http://www.al3malka.com/vb/redirector.php?url=http://www.al3malka.com/vb/t22674.htm

so we have the same problem when installing and uninstalling this product i need solution for this problem please:confused:

I don't really understand your problem - please explain further as your English is confusing me a lot.
Quote:

Originally Posted by KURTZ (Post 1593934)
Hanson what about my troubles? :)

Your troubles?

katie hunter 09 Aug 2008 01:36

Hi I have a question,

If someone runs a scrip i don't know what kind, but he runs a scrip to get all my Rapidshare and megaupload links then he report them so i get massive link deletion , would this mod prevent his scrip from finding all the links i post on my forum ?

Dismounted 09 Aug 2008 09:34

No amount of obfuscation will prevent someone from browsing your forums to see a link. If you don't want links to be seen - don't post them.

yemenihor 09 Aug 2008 17:06

During the opening the following link
http://www.0000.com/vb/redirector.ph...tp://00000.com

Show me the error 500

Bad server

What is the solution?

katie hunter 09 Aug 2008 19:14

Quote:

Originally Posted by Dismounted (Post 1594608)
No amount of obfuscation will prevent someone from browsing your forums to see a link. If you don't want links to be seen - don't post them.

U don't need to sound like you're screaming.. Thanks anyways!

Dismounted 10 Aug 2008 08:27

Quote:

Originally Posted by yemenihor (Post 1594818)
During the opening the following link
http://www.0000.com/vb/redirector.ph...tp://00000.com

Show me the error 500

Bad server

What is the solution?

Error 500 indicates an error with server configuration, not with a script. Please provide actual URLs.
Quote:

Originally Posted by katie hunter (Post 1594884)
U don't need to sound like you're screaming.. Thanks anyways!

Where inside my post was I "screaming"?

yemenihor 10 Aug 2008 13:22

Quote:

Originally Posted by Dismounted (Post 1595243)
Error 500 indicates an error with server configuration, not with a script. Please provide actual URLs.

Where inside my post was I "screaming"?

Ok

this link
http://www.sh22y.com/vb/redirector.p...p://google.com

And that there was a solution by the server, please put and will be implemented

Awaiting your response

darkpilgrim 10 Aug 2008 22:04

Hi,

Installed fine. When I enable - bbcode_parse_complete_precache - I get an error. If my working link is www.mozilla.com then with the plugin active, it becomes:
http://www.mysite/pathto/redirector....mozilla.com%2F and I get a message saying page cannot be found.

What am I missing? Thanks :)

Y-ZOOM 12 Aug 2008 00:20

nice one man

but i got something strange

like this
http://Mysite.com/vb/redirector.php?...06423e8377d%2F

i mean it's repeater

im sorry for my language

maybe u got what i mean
thanks

Corndog235 12 Aug 2008 02:44

Does this help with SEO?

Dismounted 12 Aug 2008 14:16

Quote:

Originally Posted by yemenihor (Post 1595360)
Ok

this link
http://www.sh22y.com/vb/redirector.p...p://google.com

And that there was a solution by the server, please put and will be implemented

Awaiting your response

Most likely - there is some server configuration issue. A wild guess by me would be mod_security or something similar, blocking legitimate requests.
Quote:

Originally Posted by darkpilgrim (Post 1595741)
Hi,

Installed fine. When I enable - bbcode_parse_complete_precache - I get an error. If my working link is www.mozilla.com then with the plugin active, it becomes:
http://www.mysite/pathto/redirector....mozilla.com%2F and I get a message saying page cannot be found.

What am I missing? Thanks :)

Please provide a URL.
Quote:

Originally Posted by Y-ZOOM (Post 1596534)
nice one man

but i got something strange

like this
http://Mysite.com/vb/redirector.php?...06423e8377d%2F

i mean it's repeater

im sorry for my language

maybe u got what i mean
thanks

Please provide actual URLs.
Quote:

Originally Posted by Corndog235 (Post 1596618)
Does this help with SEO?

I don't believe so - although I am not experienced in this field.

ssslippy 12 Aug 2008 16:22

Can I filter what url's this will not effect? I pull data from an external site via a url and anon links break it.

rmxs 27 Aug 2008 09:50

hello,
i use vbanonymizer and i change my domain from www.domain.com to domain1.com
al the redirects to redirector was domain.com and after the domain change is still to domain.com and not to domain1.com (New links its with new domain)

How can i change the old redirector urls?

I try to unistall the vbanonymizer byt the link doesnt change (that mean if you unistall it you cannot clik the links)

rmxs 01 Sep 2008 07:22

Someone??

Dismounted 02 Sep 2008 09:53

Try running the script attached here. Be sure to backup everything though - I make no guarantees to how it will pan out.

maf1973 04 Sep 2008 17:01

After i install this mod and click on a Link following error message appears:

You don't have permission to access /forum/redirector.php on this server.

I set the chmod from redirect.php to 777 but no changes.

What can i do?

Dismounted 05 Sep 2008 11:59

You probably have mod_security/Suhosin/Hardened PHP installed. The error usually happens if the rules are too strict - TBH, I don't know exactly what to change, as I have not experimented with them.

rmxs 08 Sep 2008 09:22

I get this error when i try the unistall fix Fatal error: Call to undefined function vbflush() in /home/rmxs/domains/rmxsmania.com/public_html/Vb/vbanonymizer_uninstall_fix.php on line 38

Dismounted 09 Sep 2008 04:37

1 Attachment(s)
Try this one.

Cobro 10 Sep 2008 01:23

Thank you so much

rmxs 10 Sep 2008 13:25

Fixed..Finally i change the url from vb setting..Now i saw that the unistall have this code

$vbulletin->options['bburl']

unleash 11 Sep 2008 12:49

Thanks a lot for this great hack.

I have a request, can you make a form so that users can use this service to redirect their links and use it in other site like http://anonym.to/en.html do - This would be great.

Thanks in advance.

Dismounted 12 Sep 2008 12:01

I will think about it :).

S P E E D 12 Sep 2008 19:14

HoW Can Uninstall Old version ?

And

I Can uninstall new Version ?

Dismounted 13 Sep 2008 14:18

Just uninstall it from the Admin CP if you want to uninstall it.

chriskellar 16 Sep 2008 04:26

I have an issue.

The mod is rewriting images in the forum which i have a light box mod installed and now the images can't be seen with this mod installed. I attempted to uninstall it and remove the redirector rebuild all information and the images are still showing the redirect url. How can I remove this?

Dismounted 16 Sep 2008 07:46

http://www.vbulletin.org/forum/showp...5&postcount=88

rmxs 18 Sep 2008 20:29

hello in some of my links i get double http:// y?

rmxs 18 Sep 2008 20:37

Also when i try to edit the post all the links is look like this one..
Quote:

%68%74%74%70%3a%2f%2f%72%61%70%69%64%73%68%61%72%65%2e%63%6f%6d%2f%66%69%6c%65%7 3%2f%31%30%32%37%32%31%33%35%2f%41%6b%74%69%5f%50%65%69%72%61%69%6f%73%5f%32%30% 30%36%5f%43%44%5f%31%2e%72%61%72
Edit: this happends when the url its under text LIKE THIS

I know this is hex caracter http:/etc.. byt how can i fix it/

Dismounted 19 Sep 2008 07:10

Quote:

Originally Posted by rmxs (Post 1625057)
hello in some of my links i get double http:// y?

Example?
Quote:

Originally Posted by rmxs (Post 1625063)
Also when i try to edit the post all the links is look like this one..
Edit: this happends when the url its under text LIKE THIS

I know this is hex caracter http:/etc.. byt how can i fix it/

Just leave it. I may work around it in the future - but it's a lot of work for not much gain.

rmxs 19 Sep 2008 07:21

Exmple this http://%68%74%74%70%3a%2f%2f%72%61%7...%66%69%6c%65%7 3%2f%31%30%32%37%32%31%33%35%2f%41%6b%74%69%5f%50%65%69%72%61%69%6f%73%5f%32%30% 30%36%5f%43%44%5f%31%2e%72%61%72

i try to delete http:// byt still i get it on the front after save and crear cache

Can i run a query like $vbulletin->db->query_write("UPDATE post SET pagetext = REPLACE(pagetext, 'http://http://', 'http://)");


?


All times are GMT. The time now is 20:33.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.