vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=322468

HTTPS:// Error on Tapatalk
by I.G.O.T.A.
26 Apr 2016 23:24

So we're starting to move over our forums to https://. When we add the code below with a .htaccess file everything works on the desktop version, but Tapatalk then stops. Anyone see that before or have any idea how to fix it?

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Dave 26 Apr 2016 23:27

I assume you also changed your forum to use https at the URL options? Not just .htaccess?
It probably happens because Tapatalk doesn't handle a 301 redirect properly.

I.G.O.T.A. 26 Apr 2016 23:34

Quote:

Originally Posted by Dave (Post 2569674)
I assume you also changed your forum to use https at the URL options? Not just .htaccess?
It probably happens because Tapatalk doesn't handle a 301 redirect properly.

Yep did that also. Any other ideas? We can't seem to figure this one out.

Dave 26 Apr 2016 23:38

Does it work without those .htaccess rules in place?

I.G.O.T.A. 26 Apr 2016 23:41

Quote:

Originally Posted by Dave (Post 2569676)
Does it work without those .htaccess rules in place?

Yes, Tapatalk does, but then the forum has some links that need to be forced and changed to https:// and that would take us a long time to find each one.

Dave 26 Apr 2016 23:47

What if you add the following above the "RewriteRule" line:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I believe TapaTalk makes use of PHP files in the mobiquo folder so this should ignore redirects of requests to files in that folder.

I.G.O.T.A. 26 Apr 2016 23:52

Quote:

Originally Posted by Dave (Post 2569678)
What if you add the following above the "RewriteRule" line:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I believe TapaTalk makes use of PHP files in the mobiquo folder so this should ignore redirects of requests to files in that folder.

BINGO! Awesome, thanks Dave!!! It now works again, lol.

Dave 26 Apr 2016 23:54

No problem. :D

I.G.O.T.A. 26 Apr 2016 23:55

Quote:

Originally Posted by Dave (Post 2569680)
No problem. :D

I should have known better, lol. Thanks again pal!!!


All times are GMT. The time now is 06:07.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.