vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=99032

TS2Live - TeamSpeak 2.x Online Status
by Phalynx
22 Oct 2005 17:35

4 Attachment(s)
This is the vb3.5-version of the TeamSpeak Online Hack. The version for vB3.0.x you can find here.


What does this hack do?
It shows you the currently Users on FORUMHOME, just under the Who Is Online Block. As this Script queries the Server every time a user enters the Forumhome, it is not recommended to apply it on sites with high traffic. Use instead of my hack the hack "Show who is online in Teamspeak on forumhome", it works with cronjobs.
This Hack works on vBulletin on Windows (tested) and *nix (untested). It can query *nix and Windows-based TeamSpeak Servers.


Contains: 7 AdminCP settings, 11 phrases, 1 additional template, optional icon.
Installtime: <1 minutes
Difficulty: easy (1 product and 1 icon uploads)


The icon is optional. If you don't want to upload the icon, you can change it in the AdminCP to a different name.

Demo: http://www.e2160.com (scroll down)

Please click INSTALL! :)

Update for 2.0:
- No more file modifications needed, you can configure it through the AdminCP

How to Update?
- Import product, overwrite existing
- Revert the template named "forumhome_tslive"
- Check if the phrases are up to date (espacially phrase "ts_active_users")

Snake 23 Oct 2005 13:21

Thank you!

PVTRoger 25 Oct 2005 11:19

I love the idea of this hack, but am not clear (because I'm a newb at this) what I'm suppose to be changing what/where the instructions say...

##########################################################################
Please make sure that you modify also the templates and phrases with the right data to connect to your TS2 Server!
template: forumhome_tslive
phrase: ts_active_users
##########################################################################

I do have the visual part on my board now, just need to see if I can make it all work to actually show the users on Teamspeak. Here's the LINK to my board if that will help.

Phalynx 25 Oct 2005 11:43

It seems that the phrases are not working. I changed the product.xml to make the phrases GLOBAL, so now the import should work correctly.

Please download the ZIP again and make sure that you import the updated product with overwrite on.

Also I have modified the instruction you mentioned, it should be now clearer.

twitch 25 Oct 2005 19:56

I don't show the option to connect to the server like you have on your website, I just show who is online http://www.s2tg.com/forum/index.php

PVTRoger 25 Oct 2005 23:17

Phalynx

I really want this to work, as it's a great idea. I have downloaded the new zip, and installed as per your instructions. I entered in the values into the template, but dang if this wil show anyone on Teamspeak. I'm beside myself trying to figure out what I could be doing wrong.

Any help, or typical problems that you can think of will be appreciated.

Thanks in advance.

PR

PVTRoger 27 Oct 2005 16:38

Well, I guess I'm going to be forced to uninstall this. Pity as it's a great concept, and I know that many hagve made it work on their boards. If only I could get some help to work through my issues.

:ermm:

Phalynx 27 Oct 2005 20:00

Did you check if the phrases are correctly entered? Just search for them:

ts_active_users
ts_nobody_online
ts_offline

If you cannot find them, create them with this content in GLOBAL:
ts_active_users=Active chatting users @ YOURSERVER
ts_nobody_online=There is currently nobody online
ts_offline=The Server is currently offline

PVTRoger 27 Oct 2005 20:41

Phalynx

Here's what my stuff looks like (minus the xx I used to replace the actual IP)

<!-- start teamspeak live -->
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_ts_loggedin')"><img id="collapseimg_forumhome_ts_loggedin" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_activeusers].gif" alt="" border="0" /></a>
$vbphrase[ts_active_users] $teamspeak[player] $vbphrase[user]
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_ts_loggedin" style="$vbcollapse[collapseobj_forumhome_ts_loggedin]">
<tr>
<td class="alt2"><img src="$stylevar[imgdir_misc]/teamspeak.gif" border="0" /></td>
<td class="alt1" width="100%">
<div style="padding-top: 7px" class="smallfont">
<a href="teamspeak://xx.xx.xx.xx:xxxx/?channel=XXXX?password=xxxx">$teamspeak[playerlist]</a></div>
<div style="padding-top: 7px" class="smallfont">
$vbphrase[ts_join]
$vbphrase[ts_help]
</div>
</td>
</tr>
</tbody>
<!-- end teamspeak live -->

If you see anything in there that needs changing, I'd be grateful if you could tell me what it is.

Thanks

PR

PVTRoger 28 Oct 2005 21:35

What..is this to tough a nut to crack?

:surprised:

twitch 28 Oct 2005 21:49

strange it doesn't work for you, should work with no problems.

PVTRoger 29 Oct 2005 10:59

Dang, I think I would have been happier if someone said "Oh, change the "X" to a "Z" or something, anything so that I could make this work.

:disappointed:

bspiller82 29 Oct 2005 11:30

1 Attachment(s)
How you fix the display? Mine looks nothing like the included example image you included. It's not showing the IP address in the bar..

PVTRoger 29 Oct 2005 15:08

Phalynx...no ideas buddy?

:disappointed:

PVTRoger 29 Oct 2005 18:04

I have Teamspeak2. Would that possibly make a difference?


All times are GMT. The time now is 08:39.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.