vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

QuickQuestion 20 Apr 2011 00:06

I had Spam-O-Matic for a few days, and it really rocks for stopping spammers. But I came across a problem where no one can create threads or post when this mod is activated. VB 4.1.2

Can anyone toss me pointers? This is the message error that we get.

Warning: require_once(includes/functions_ghsom.php) [function.require-once]: failed to open stream: No such file or directory in [path]/includes/functions_newpost.php(443) : eval()'d code on line 32

Fatal error: require_once() [function.require]: Failed opening required 'includes/functions_ghsom.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/74/7532774/html/includes/functions_newpost.php(443) : eval()'d code on line 32

oddmud 20 Apr 2011 01:42

Quote:

Originally Posted by Trek (Post 2186160)
I've been running this for a bit now (a few weeks) and already have blocked 1255 spammers, good stuff. However, I'm seeing people that I KNOW are spammers signing up and making it through, but I have no way to manually say "This dude is a spammer" as they haven't posted yet.

Is there anyway to submit them and do all the ban type stuff as if they were automatically detected, but when they haven't posted?

I want to be able to do this based on their visitor links they're posting.

I want to be able to just click "SPAMMER" button on their profile and auto submit.

Umit 20 Apr 2011 13:07

Hello, my website got attacked by a bot with a injection, I found a way to block it, and for SPAM i bought a pro key from Akesmet.
I installed and configured this mod, but I want to see the statistics. Well in the first screenshot it should be in tab Statistics & Logs, however my isn't ? Where can I find it? Also the mainpage of my forum I see I have a "Spam-O-Matic Statistics", this is empty.

WorldCraft 20 Apr 2011 13:11

This mod is fantastic! An absolute lifesaver! Thankyou!
MOTC (century)

Alan_SP 20 Apr 2011 14:20

I have a bit of a strange problem.

Before I had vBStopForumSpam mod and it worked fine. In logs I saw that there was about 9 to 10 spamers to every new user registered. Now, I see no spamers at all in logs, but only users. There's no reason why spamers should now avoid my site, so I assume this mod just don't log them.

Also, I see there are new users, but this doesn't get reflected in WGO, in part for welcoming our latest member. Something with this mod blocks showing who latest member is. Strange...

Alan_SP 20 Apr 2011 17:41

Ok, I just reenabled vBStopForumSpam and yes, Spam-O-Matic doesn't log rejeceted spamers. Already I have one spamer logged with vBSFS, but none with SOM.

I'll test further having this two mods on, to see what's going on in WGO and last member.

amd2010 20 Apr 2011 19:52

الهاك زفت

TeknoSounds 20 Apr 2011 19:54

Please read previous posts, SFS was making too many uncessary queries to the SFS database, and so now they're supposed to first hit the vB verification first, then hit SOM.
If spammers are still getting by, might need to adjust thresholds.

GlowHost.com 20 Apr 2011 20:13

Quote:

Originally Posted by oddmud (Post 2186476)
I want to be able to do this based on their visitor links they're posting.

I want to be able to just click "SPAMMER" button on their profile and auto submit.

Per previous posts this will be in 2.5

Quote:

Originally Posted by WorldCraft (Post 2186622)
This mod is fantastic! An absolute lifesaver! Thankyou!
MOTC (century)

Glad you like it :)

Quote:

Originally Posted by Alan_SP (Post 2186696)
Ok, I just reenabled vBStopForumSpam and yes, Spam-O-Matic doesn't log rejeceted spamers. Already I have one spamer logged with vBSFS, but none with SOM.

I'll test further having this two mods on, to see what's going on in WGO and last member.

Quote:

Originally Posted by TeknoSounds (Post 2186725)
Please read previous posts, SFS was making too many uncessary queries to the SFS database, and so now they're supposed to first hit the vB verification first, then hit SOM.
If spammers are still getting by, might need to adjust thresholds.

TeknoSounds is correct.

GlowHost.com 20 Apr 2011 20:15

Quote:

Originally Posted by QuickQuestion (Post 2186454)
I had Spam-O-Matic for a few days, and it really rocks for stopping spammers. But I came across a problem where no one can create threads or post when this mod is activated. VB 4.1.2

Can anyone toss me pointers? This is the message error that we get.

Warning: require_once(includes/functions_ghsom.php) [function.require-once]: failed to open stream: No such file or directory in [path]/includes/functions_newpost.php(443) : eval()'d code on line 32

Fatal error: require_once() [function.require]: Failed opening required 'includes/functions_ghsom.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/74/7532774/html/includes/functions_newpost.php(443) : eval()'d code on line 32

You can search this thread for your answer, but basically it means you didn't install it correctly and do not have functions_ghsom.php uploaded to your includes/functions_ghsom.php directory.

StonePilot 20 Apr 2011 20:19

GOOD WORK! In the first 20 minutes it's already blocked 7 spammers.

Question: Do you have Mod tools to help delete existing spammers (slepping spammers) so I can get rid of them? I have probably 1,000 sleppers on my site that have zero form posts and zero blog posts.

Let me update my problem: I have at least 1,000 "sleepers" on the site with no way to quickly ban them. They have no blog posts and no forum posts - they appear to have been created so they can spam inside the User Profile and they also will spam people's Visitor Messages on other members User Profiles. There is an instant-ban tool that I can get installed into the user profile but I'd rather not have to do that if I don't have to.

GlowHost.com 20 Apr 2011 21:03

See that answer 2 posts above or check the FAQ on the first page.

Alan_SP 21 Apr 2011 02:17

Quote:

Originally Posted by GlowHost.com (Post 2186732)
TeknoSounds is correct.

Thank you, I didn't realize that. :)

What about this part of my problems:

Quote:

Also, I see there are new users, but this doesn't get reflected in WGO, in part for welcoming our latest member. Something with this mod blocks showing who latest member is. Strange...
With vBSFS enabled I see last registered user, with only SOM don't. I'll test further without vBSFS turned on.

Trek 21 Apr 2011 02:56

Quote:

Originally Posted by Trek (Post 2186160)
I've been running this for a bit now (a few weeks) and already have blocked 1255 spammers, good stuff. However, I'm seeing people that I KNOW are spammers signing up and making it through, but I have no way to manually say "This dude is a spammer" as they haven't posted yet.

Is there anyway to submit them and do all the ban type stuff as if they were automatically detected, but when they haven't posted?

Anyone reply to this? I'd like to be able to click a button on their profile to say "spammer" or whatnot. If this was already asked and answered, sorry but I couldn't find it in the thread and the thread is almost 900 replies now. =)

GlowHost.com 21 Apr 2011 03:34

Quote:

Originally Posted by Alan_SP (Post 2186835)
With vBSFS enabled I see last registered user, with only SOM don't. I'll test further without vBSFS turned on.

Not sure what you are referring to. Screenshots might help.

Quote:

Originally Posted by Trek (Post 2186839)
Anyone reply to this? I'd like to be able to click a button on their profile to say "spammer" or whatnot. If this was already asked and answered, sorry but I couldn't find it in the thread and the thread is almost 900 replies now. =)

It's been answered at least 2 times on this page alone, it is also in the FAQ on the first page.


All times are GMT. The time now is 00:03.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.