vBulletin Mods

The Official vBulletin Modifications Site

SSL problem
by w00fy
09 Dec 2018 16:56

2 Attachment(s)

I am running 4.2.2 Apache v2.4.25 and my host installed an ssl certificate for me yesterday on my vps it look like that part is okay, https://www.sslshopper.com/ssl-check...e=legitfta.com

Reading the posts I changed the forum url and rebuilt styles, it seems the css go missing as soon as I change the url to https, once I change back to http the forum is normal.

Please see the screen captures and let me know if anyone can point me in the right direction on how to solve this please.


snakes1100 09 Dec 2018 17:06

If your storing your css as files (Store CSS Stylesheets as Files?), change to ssl, remove the files from ftp vbulletin_css, disable the storage option in vb admincp & save, then re-enable that option & save.

w00fy 09 Dec 2018 17:45


Yes they are stored as files, how do I change to ssl?

disable the storage option in vb admincp & save? not sure I understand this part?

Sorry very novice at this.

snakes1100 09 Dec 2018 20:23

If they are stored as files, disable that option in the admincp.

FTP into server & go to clienscript/vbulletin_css & delete all the files that start with *style*

set your forum URL to https & save

Enable the css styles as files option & save

w00fy 10 Dec 2018 11:25

1 Attachment(s)
Thank you,

There are folders and files that start with style, do I delete all?

z3r0 10 Dec 2018 15:27

1 Attachment(s)
I've just looked at your site and checked the F12 tools console while loading it over https and the main issue seems to be that your all the stuff loaded from your clientscript folder is being blocked because it is being loaded from http rather than https.

You could try a quick fix of adding a new replacement variable to your skin.

Attachment 157316

w00fy 10 Dec 2018 22:17

Thank you

I did try that before and checked it again, when I do this the site will load but not fully, Most Popular Forums will just say loading shoutbox the same, and still not secure.

snakes1100 10 Dec 2018 23:30

delete all of them named style

z3r0 11 Dec 2018 07:44


Originally Posted by w00fy (Post 2597734)
Thank you

I did try that before and checked it again, when I do this the site will load but not fully, Most Popular Forums will just say loading shoutbox the same, and still not secure.

I see it's mostly loading now, but there is still a few mixed content errors in the console, mainly e365mods/holiday/font/wwflakes.ttf - If you know what that is either edit it to be https or turn it off (snowflake mod?)

As soon as you can get rid of the mixed content errors the site will show secure.

Also, your site is in the forum directory however you have a lot of 404's in the console as some images are being referenced from the root of your domain.

w00fy 11 Dec 2018 23:20

I appreciate you time and thank you.

I disabled the e365 plugin, basically my xmas lights for the forum, and the site is now showing green bar and secure on most major browsers,

I would like to use those xmas lights as my members like them,

Any idea where I might find the location to change the url to https if it's that simple.

And thank you for joining my site I seen you at 4am Calgary time just before heading off for work.

Any other tips would be appreciated.


z3r0 12 Dec 2018 08:01

I see it's looking much better now, if you have a link to the e365 mod I'll have a look at the code and see where to fix it.

I would also add the following to your headerincludes template, it will allow modern browsers to update insecure requests (http to https) wherever it can.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

w00fy 12 Dec 2018 10:44

Looks like it's in the graveyard now.

z3r0 12 Dec 2018 13:20

In that case, have a search of your templates for wwflakes.ttf and if found update the url it's on, I do think though that it will be in a plugin so you'll need to look through the e365 mod plugin's and edit the containing url accordingly.

w00fy 12 Dec 2018 22:28

1 Attachment(s)
Thanks again,

I found the zip on my pc..hope it's okay to upload here.

z3r0 13 Dec 2018 09:38

I've scanned through the files and there is no direct http reference to the file that was causing the mixed content message.

Have you updated the forum url in your admincp options to https? if not it could be pulling it in from there.

w00fy 13 Dec 2018 14:41


Yes forum url was updated to https, no big deal maybe I can find something similar.

All times are GMT. The time now is 22:40.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.