vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=328247

PHP Workaround
by SirKlutch
27 Sep 2020 16:50

Has anyone found a work around to this?
Warning: Use of undefined constant MYSQL_NUM - assumed 'MYSQL_NUM' (this will throw an Error in a future version of PHP) in /usr/www/desoroleplay/public/community2/install/init.php on line 119

vb5 lacks themes and vb4 has nice ones. However, i cant install the forum due to php version.

Hostboard 28 Sep 2020 11:27

That is a PHP warning. Should not prevent you from installing the item.

SirKlutch 28 Sep 2020 16:10

Quote:

Originally Posted by Hostboard (Post 2604067)
That is a PHP warning. Should not prevent you from installing the item.

Oh, I also get this error which doesn't allow me to install the forum software. It says "aborted".


Deprecated: Function create_function() is deprecated in /usr/www/desoroleplay/public/community2/install/includes/class_upgrade.php on line 434

Hostboard 28 Sep 2020 18:09

Can the author of the theme assist?

More than likely you would need to provide at least a snippet of the code giving the error if not the entire file. I am not the one who would be able to provide a working reply nor am I familiar with VB5.

However as it is purely a PHP issue any developer that works with PHP should be able to resolve the issue

SirKlutch 28 Sep 2020 18:19

Quote:

Originally Posted by Hostboard (Post 2604071)
Can the author of the theme assist?

More than likely you would need to provide at least a snippet of the code giving the error if not the entire file. I am not the one who would be able to provide a working reply nor am I familiar with VB5.

However as it is purely a PHP issue any developer that works with PHP should be able to resolve the issue

The issue is with the initial installation of vBulletin 4. I guess the later versions of PHP, 7.2+, don't work anymore. I was wondering if there was a way around this without being too much work. I can't seem to find any good themes for vB 5. vB 5 lacks theme options for gaming communities. My webhost refuses to allow me to use php 7.1 due to vulnerabilities.

saadessa1 29 Sep 2020 01:21

We hope the programmers will fix the problem

Hostboard 29 Sep 2020 11:08

Quote:

Originally Posted by saadessa1 (Post 2604084)
We hope the programmers will fix the problem

There will NEVER be ANY updates to VB 4 by Internetbrands. It has been End of Life for years.


All times are GMT. The time now is 03:58.

Powered by vBulletin® Version 3.8.14
Copyright © 2021, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.