vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=321950

Problem With 4.2.3 version
by ramesh_umk3
28 Feb 2016 12:29

Suddenly my forum is down today when i checked log i see below error

Parse error: syntax error, unexpected '<' in /home/xxxxxx/public_html/includes/class_core.php(4719) : eval()'d code(1) : eval()'d code on line 3

1) i disabled all plugins via config
2) uploaded all files and upgraded again

what ever i do i still see same error .. Anything else i have to do ?

thanks

--------------- Added 28 Feb 2016 at 12:40 ---------------

now i got new problem after downgrading to 4.2.2

Checking if a package is enabled for an invalid package '14' on line 392 in /home/xxxxx/public_html/vb/types.php
#0 /home/xxxxx/public_html/vb/router.php(514): vB_Types->packageEnabled('14')
#1 /home/xxxxx/public_html/vb/router.php(577): vB_Router::assertRoutes()
#2 /home/xxxxx/public_html/vb/route.php(236): vB_Router::getRouteSegmentFromClass('vBCms_Route_Lis...')
#3 /home/xxxxx/public_html/vb/route.php(260): vB_Route->__construct(false, false)
#4 /home/xxxxx/public_html/packages/vbcms/route/list.php(92): vB_Route::create('vBCms_Route_Lis...')
#5 /home/xxxxx/public_html/includes/functions.php(3668): vBCms_Route_List::getURL(Array)
#6 /home/xxxxx/public_html/includes/functions_forumlist.php(314): construct_memberaction_dropdown(Array)
#7 /home/xxxxx/public_html/forumdisplay.php(474): construct_forum_bit(6)
#8 /home/xxxxx/public_html/dbseo.php(500): require('/home/mobiles/p...')
#9 {main}

ozzy47 28 Feb 2016 14:07

There is no such thing as a downgrade. If you are having issues, restore your backup.

ramesh_umk3 29 Feb 2016 11:24

Brother ozzy i know backup would solve the issue .. i was just curious to know what thing raised that error ..

Cause even after disabling all hooks i was seeing those errors .. Lot more weird errors!!! all happened suddenly from past 3 months i didn't added new plugins nor any changes ..

And my host says me to remove DBSEO even after using the latest version

Stratis 29 Feb 2016 14:31

Maybe your server has changed php /sql version.

squidsk 29 Feb 2016 15:29

It's a template problem. It also seems like you might have changed something in the class_core.php file as line 4719 has no code on it by default, but the line before is a function call that looks like it extracts the template being rendered. What templates have you changed recently or have previously customized? One of those likely has something that 4.2.3 along with any new version of php your running is causing issues.


All times are GMT. The time now is 10:54.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.