vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

ForceHSS 09 Nov 2012 05:25

Quote:

Originally Posted by M.C. (Post 2379490)
Want to thank you for great addon first.

Have question about moderated posts/threads (may be been asked here). In statistic there is:

Spam-O-Matic Statistics

X Spammers Denied Registration

X Spammy Posts Automatically Moderated



But where they located that "moderated posts"? I don't see them....

May be you can add in options that put all moderated threads/posts into some special "Trash-bin" forum and we can put forumID for it?

WBRs

P.S. sorry my english not well

either go to your settings in your own profile or look in the admincp/Moderation

naveeid 09 Nov 2012 10:39

this mod is wonderful and has helped me a lot to control the spam

tuRiver 09 Nov 2012 11:30

Is it possible to control usergroup permissons? Who can ban or delete user?

vBBurger 09 Nov 2012 21:53

Quote:

Originally Posted by GlowHost.com (Post 2379464)
Because it was designed that way.

Why would you *reduce* the built in security of vBulletin when you could have simply detected when someone Activates before moving them to the Newbies group? Simple solution. But instead you're telling me someone intentionally coded SpamOMatic to cripple the Email Activation feature of vBulletin? Why would you do that? SpamOMatic is supposed to increase security. Not break it.

Quote:

Do you think spam bots cant click activation links if they can fill out a form?
No. Most of them DONT click activation links. Do you know why? Because theyd have to create thousands of email accounts just to do that.

We tried using just SpamOMatic alone. It didn't work. You place new users into a Newbies group ... but how does that stop them from posting? We ended up with hundreds of Spam BOT "Moderated Posts" that had to manually be deleted. One of my Moderators quit that day because he was overhwhelmed with the failure of your plug in to stop Spam.

So I took matters into my own hands and re-enabled Email Activation. Guess what? It all stopped. But a handful are now posting freely because your tool BREAKS the Email Activation function in vBulletin. Apparently the "You must activate" page deters a large percent of them because they can't activate by email like you assume. The smarter ones try posting anyways, and do so just fine because your tool doesn't stop them.

Quote:

Your choices are to either use the newbies group after registration or use the users awaiting validation group after registration.
There is absolutely no reason why this has to be an either-or situation. All you have to do is fix the problem, and SpamOMatic can be used in conjunction with Email Activation. Detect Email Activation before putting them into Newbies group. Simple. Basic code change. Is there someone a little more willing to listen that I can report this bug to?

VBB

GlowHost.com 09 Nov 2012 22:15

I guess if you don't like it, simply remove the program, problem solved.

You certainly won't get any help with an attitude like that.

vBBurger 09 Nov 2012 22:17

Attitude? I am just trying to help by reporting a bug. You copped the attitude in your response, as if I was clueless about spam botS, or forums in general. Really caught me off guard actually.

I'm not trying to damage anyone's Ego here. Just trying to avoid endless hours of deleting unnecessary spam. Which is why your tool exists. This *bug* has been confirmed on the main vBulletin forums by a couple guys now. So it would be nice if you'd acknowledge it too.

Why would you give me such a strange, arrogant response, and tell me to get over it, or uninstall it? Wow. Why not take it as a bug or feature request and improve the tool? Is your ego that huge? This isnt personal. Its a bug. It needs to be fixed. And doing so will help everyone.

Ill just pay my programmer $14 to fix your bug instead. Lose the ego.

GlowHost.com 09 Nov 2012 23:09

You are demanding special treatment. Have you ever heard of the word "please?"

Something like:

"Can you please make this mod do something that it doesn't do already?"

That would get you a lot more support than of an entire thread flaming this mod. If you understood how the mod worked, you wouldn't have this question in the first place.

Email activation puts people into the registered users group. That is the default setting of this mod when you install it.

If you do not like how vBulletin handles this, (since it is worthless, and yes, bots do click the links) you can optionally enable the Newbies system which will allow you to permission the group to your hearts content given all of the options that vBulletin allows for.

What is the point of having real people click a link to end up in the Newbies group?

Is it to make it more difficult for real people to post on your forums? Or in your mind, to prevent bots who don't click links from registering?

Actually, after reading your updated post, don't bother answering. I don't care. Go pay your $14 programmer to do whatever you want with it, he must be talented. All that anger and effort to try and save $14 bucks? Wow.

djbaxter 10 Nov 2012 02:13

And didn't you get essentially the same answer in your vBulletin.com thread?

Fatal Hazard 11 Nov 2012 15:53

I have installed it and it works but when I try to edit the settings I get this error:
https://www.vbulletin.org/forum/external/2012/11/27.png

GlowHost.com 11 Nov 2012 18:58

Check that you have set the correct permissions on the PHP files that you uploaded. Depending on your php environment they probably should be set to 644 or you can try 755 if 644 doesnt work. That or ask your hosting company to help read the messages in the Apache error logs...they will tell you exactly why Apache is forbidding you from accessing that page.

bzcomputers 12 Nov 2012 06:59

Server appears to currently be down and denying registrations even with:

StopForumSpam: Query Connection Errors
What should happen if the remote connection times out when querying the new registration?
set to Allow Registration

4 registrations in last 15 minutes denied for:
pam-O-Matic Tagged email - [email protected] Unable to connect to StopForumSpam.com. This is probably due to some temporary problems on their website: Unable to check. User passed to vBulletin registration system per your settings at 'StopForumSpam:

Unfortunately the last time the servers went down it also would not pass registrations through, even though it was set to fall back on "Allow Registration".

Edit: Looks like it may a temporary downtime, I see last week at the same time it also appears to have been down. Routine maintenance? Hope not.

https://www.vbulletin.org/forum/external/2012/11/32.jpg

ForceHSS 12 Nov 2012 08:03

http://www.vbulletin.org/forum/showp...postcount=2193

djbaxter 12 Nov 2012 14:10

Quote:

Originally Posted by ForceHSS (Post 2380451)

Not necessary. Pedigree confirmed recently that at the moment both www.stopforumspam.com and api.stopforumspam.org go to the same place. The issue has nothing to do with the URL.

Depending on where you are, you may also be timing out at times. Hurricane Sandy wreaked havoc on the east coast of the US and power is still out in many places. When I do a tracert for my own site it slows down noticeably doing hops through New York State and Atlanta,

bzcomputers 12 Nov 2012 14:41

I did have the updated "api" links already installed and was still getting no response from the server. This is coming from Texas.

What worries me is seeing nearly 4 hours of no submissions (presumably downtime) from 4:00AM to 8:00AM local time for StopForumSpam.com two weeks in a row (can't see detailed history past that from their published graphs).

Image below is directly from their site statistics:
http://www.stopforumspam.com/historygraph

https://www.vbulletin.org/forum/external/2012/11/25.jpg

Fatal Hazard 12 Nov 2012 15:06

Quote:

Originally Posted by GlowHost.com (Post 2380346)
Check that you have set the correct permissions on the PHP files that you uploaded. Depending on your php environment they probably should be set to 644 or you can try 755 if 644 doesnt work. That or ask your hosting company to help read the messages in the Apache error logs...they will tell you exactly why Apache is forbidding you from accessing that page.

Okay will do so, thanks for the help!! :)


All times are GMT. The time now is 13:49.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.