vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=240772

VSA Chatbox AJAX Addon (New Posts/New Reply Notification)
by Inflikted
19 Apr 2010 03:52

3 Attachment(s)
I originally had this posted in the VSA Chat thread however with the endless amount of posts the script is somewhat lost in there :), plus I have a small update for it to remove the notification for edited/deleted posts which many people asked for, I apologize I posted the outdated version before.


UPDATE April 27th 2010
-Added Arabic Translations Thanks Dr.osamA

UPDATE April 24th 2010
-Added in failsafe incase you don't use html markups, to default back to admincp option choice for userid color

UPDATE April 24th 2010
-Added new member registration notification
-Added username html markup for colors
-Added option to turn off various plugins/products

UPDATE April 21st 2010
-Created a product, so its easier to edit the options for people :)
-Option to name your RSSFeedBot

New Installation Instructions:
1. Make sure VSA Chatbox AJAX is installed (grab it here http://www.vbulletin.org/forum/showthread.php?t=235271)
2. Install the attached xml below in your Product section of AdminCP
3. In vbulletin options you can edit the product in VSA Chatbox Addons category

Update Instructions:
1. Remove all plugin first
2. Install this new product
3. In vbulletin options you can edit the product in VSA Chatbox Addons category

Thats about it :)

You can see an example in the photo below or on my website I have it running as well Demo: http://www.freefrag.com

Coming Soon...
Additional Requested Options from members
-Arcade win announcements
-New members announcement
-Sound Alert Option

Juggernaut 19 Apr 2010 03:55

Tagged, will try right now :D

Juggernaut 19 Apr 2010 04:38

How do I change the font color, it is lost in my forum skin, also, I haven't been able to translate the language with phrases :)

Inflikted 19 Apr 2010 04:44

you can modify the line with $message=... it's simply bbcoding involved. Currently its

First color is set to silver for the username. 2nd Color is set to white for the rest of the thread. You can remove the bbcoding and it will default to the normal color. I apologize my theme is set to dark so I left it for a dark theme, anyone with a bright theme won't be able to see squat lol. I'll post a version stripped of bbcode in a bit.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Kingdombuilder 19 Apr 2010 04:52

At the risk of looking like a complete idiot what is the ID for that you speak of to change. Trying to figure out what changing it does... Great mod by the way, it is just what I was looking for...

Inflikted 19 Apr 2010 04:58

sorry I fixed the post, instead of id it should have said userid. By default its assigned to 1. But you can create a fake forum account for a PostBot or w/e you want to call it lol. and then assign the userid of the postbot. As I have done on my site.

Juggernaut 19 Apr 2010 05:03

Exelente mod, Working perfectly now :D

Kingdombuilder 19 Apr 2010 05:49

Thanks bro will get it done now... I'm loving this mod so far...

I do however see one thing. the new threads are not updating in the chatbox, but the reply post are. Any suggestions?

Inflikted 19 Apr 2010 05:56

you would need to copy/paste whats in your plugin for new thread, possibly some edit you made went wrong.

Kingdombuilder 19 Apr 2010 06:46

now when i make a new thread i get this error:

Edit: Problem fixed thanks...

AURFSCAN 19 Apr 2010 06:53

needs to go to the last post instead of going to the first

Kingdombuilder 19 Apr 2010 06:58

See post below....

Kingdombuilder 19 Apr 2010 07:00

Quote:

Originally Posted by AURFSCAN (Post 2023614)
needs to go to the last post instead of going to the first

Not sure what you mean by this... i must tell you that i'm not a coder at all, but I'm good at following instructions...

AURFSCAN 19 Apr 2010 07:04

when I click on the link in the chatbox (new reply link) ... it takes me to the first post in that thread. being a new reply it should go to the last post in the thread.

thx

The_____KinG 19 Apr 2010 07:52

same error as kingdom builder for new threads


All times are GMT. The time now is 08:40.

Powered by vBulletin® Version 3.8.12
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.