vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=231666

[AJAX] Post Thank You Hack
by Abe1
30 Dec 2009 10:24

7 Attachment(s)
Post Thank You Hack

STAFF EDIT:
Note - The mod author has been unreachable for some time, but the vbulletin.org community has stepped up to provide a number of individual fixes over the years. ForceHSS, Hippy, and Seven Skins have all combined many of these fixes into product files.

ALL CREDIT STILL GOES TO ABE1 And this is still 'his' mod. Please still mark the mod as installed if you use any version of it.

That said so you don't need to apply a dozen + small fixes yourself you should consider downloading one of the updated packages below:

Hippy has one in this post.

AND / OR

ForceHSS has one in this post.

AND/OR

Seven Skins has one in this post.


- Original File Specs: post_thanks_7_82.zip (26.4 KB, 24844 downloads) - Original file removed, replaced with patched files including search fix (some admins noticed hackers attempting to use outdated code to exploit search in attempt to gain administrator password or similar).
- There are five total patched versions available, some with and without the search fix - I've replaced the main file with the patched versions... please be sure to download and install the correct version, the main mod post contains links to additional information and patched files!
- If Abe1 returns he can request these packages be removed.


About this hack:
One of the biggest problems on forums as you may know is 'posts boosting'. There are users who LOVE to say 'thanks' when ever they can. How can it hurt? Their post count goes up, they have nothing to loose.

There are also users who really like to express their thanks to post but don't like posting a post that looks like they're post boosting.

Then comes the moderators who have to delete people's thanks yous so a thread can look readable with out the thanks yous thrown around.

Finally comes the posters of these useful posts. They have no idea how many people really likes their posts if only some people say 'thanks'.

What this hack does is fix ALL these problems - except those users who like post boosting. This places a button called 'thanks.' When a user clicks on it, it places his username in a box right under the post saying that so-and-so says 'thanks' for the post. Every-one who clicks is placed in one box.

By giving your users the extra feature, you forum will look allot nice and organized. It is a guaranteed liking by ALL the members of your forum.


Features:
  • Uses vBulletin easy Product installer/updater/uninstaller
  • Uses AJAX technology so your users don't have to refresh when they thank.
  • Places an easy to use button next to the edit button
  • Separate looks for postbit and postbit_legacy
  • Places all Thanks into one small box
  • Uses only ONE query every time you view a showthread page!
  • Users can't thank twice
  • Option to not allow users to thank their own post
  • Guests don't see 'thanks' button
  • Counts how many thanks a user gives
  • Counts how many thanks a post gets
  • Shows how many thanks a user gave in every post of his
  • Shows how many thanks a user gave in profile
  • Shows how many thanks a user got
  • Shows how many posts or a user are thanked
  • Shows info in profile
  • Search for a users thanked posts
  • Search for all thanked posts
  • Administrator can remove all Thanks from a single post
  • Users can remove their own Thanks
  • Turn on and off hack totally
  • Turn on and off hack for only some forums
  • Option to turn off hack for all but the first post of a thread
  • Option to turn off hack for all but the first post of a thread in specific forums
  • Option to turn off hack view of date for specific or all forums
  • Option to add to post count when someone clicks 'thanks'.
  • Option to give a user who receives thanks reputation points.
  • Ban Usergroups
  • Ban Users
  • Uses Phrases
  • Cache Templates
  • Guaranteed to be liked by ALL users on your forum!
Installation information on hack:
  • Files edited: 0
  • Templates edited: 0
  • Files to upload: 8
  • Time to install: 1 minute max
Updates:


Version 7.80 (12/30/09):
  • Release of this hack for vBulletin version 4.0

Version 7.81 (01/02/10):
  • Fixed some install and uninstall database errors.
  • Made styling for postbit legacy a little better.
  • Fixed the "separator" issue.
  • Javascript file updated.

Version 7.82 (01/03/10):
  • Fixed info alignment issues in the postbit for custom edited phrases.
NOTE: *** Offer for paid services removed ***

Abe1 30 Dec 2009 10:30

A few things to note:

1) If you did not upgrade to 4.0 and want to save your thanx when upgrading; disable, but NOT uninstall the post thanx before upgrading to 4.0. Once you upgrade to 4.0 upgrade post thanx hack how you would normally upgrade a hack. It should automatically re-enable post thanx hack.

2) No searching feature yet

3) No legacy version of the box with thanx. If you have legacy enabled on your site, you will get the same box as non-legacy users.

4) If you want to move the Thanx button to near the edit post button,
open template postbit
find

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and move it under

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

5) thanx to I.am and RobbieZ for help with the pictures

6) and a big thanx to the few of you who have donated in the past few days and will do in the coming days.

RS_Jelle 30 Dec 2009 10:33

Thanks a lot!

(first :D)

Raug 30 Dec 2009 10:35

Excellent!

Just a quick question since I haven't downloaded it as I need the legacy to work, but if we still have the old hack and upgrade, will all the thanks carry over?

mgurain 30 Dec 2009 10:38

Thank You Very Much Abe1, Finally one of the Most Have is upgraded.
Many Thanks, I need to press the button here :)

linuxututs 30 Dec 2009 10:40

Super job Mate !!!

Thank You,

P.S. Still wonder why vB doesn't make simple features like this default in vB....?

lifedaniel 30 Dec 2009 10:40

Un très grand merci pour ce très bon Hack ! :)

Abe1 30 Dec 2009 10:42

Quote:

Originally Posted by Raug (Post 1942296)
Excellent!

Just a quick question since I haven't downloaded it as I need the legacy to work, but if we still have the old hack and upgrade, will all the thanks carry over?

I updated the 2nd post to reflect your 2 questions.

BozzaJos 30 Dec 2009 11:01

Damnz... first Jelle releases the DownloadsII mod and now you with the Thank You mod. The two most used features on my forum!

Fantastic job Abe, really appreciate your hard work and for converting the mod to vB4 in such a short period of time. I will upgrade this mod when I get home, hopefully everything will go fine.

One question though; You say there isn't a legacy version. With this you mean the postbit_legacy template? If so, will there be in the near future? Or is there perhaps a manual workaround?

Again, thank you so much for your hard work! Rated 5 stars and nominated it so that it can compete with the DownloadsII mod! :-D

akee 30 Dec 2009 11:05

Thanks, I'll try it

RobbieZ 30 Dec 2009 11:09

Thanks for this Abe1. Glad I could help too :D

jackichan70 30 Dec 2009 11:14

sorry, do not understand this sentence: and move it under ???

compact123 30 Dec 2009 11:15

this is my favorite mods, thank you so much ^O^

RobbieZ 30 Dec 2009 11:22

Quote:

Originally Posted by jackichan70 (Post 1942319)
sorry, do not understand this sentence: and move it under ???

AdminCp>Styles & Templates>Style Manager>Postbit

Now find this in postbit


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Highlight it, copy it and delete it.

Now find this bit in postbit


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and press enter after it and paste the first one.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


akee 30 Dec 2009 11:30

Thanks, works fine

lovechandigarh 30 Dec 2009 11:32

I'd been waiting for this. Going to install now... Cheers!

redlabour 30 Dec 2009 11:34

Still no integration of Post Groan Hack. :down: This has been promised since the first 7.x Release. :mad:

And of course a Update for Post Groan is missing for 4.0. :cool:

Magz 30 Dec 2009 11:35

Excellent

Thanks
(if there was a thanks button here too, id use it ;)

Hornstar 30 Dec 2009 11:39

This beats the rep feature by far. Love it.

The Coon 30 Dec 2009 11:40

Quote:

Originally Posted by Magz (Post 1942332)
Excellent

Thanks
(if there was a thanks button here too, id use it ;)

I agree! :cool:

Charlie98902 30 Dec 2009 12:12

Thanks for the update. I did the template edit in the postbit to move it by the edit button however it is still at the default location instead of being by the edit button.

iguano 30 Dec 2009 12:15

thanks, installed and nominated
this is necessary and important in every forum :)

saviola8x 30 Dec 2009 12:22

I like your mod. But i dont use it.
This is demo my developer this mod : http://uevf.net/forum/showthread.php...&p=283#post283

Install

coberr 30 Dec 2009 12:36

Hello, first thanks for the update.

I have a problem with the post thanks plugin.

I updated it from the last version 3.x and after I enable the plugin the server start with a high load average and forum doesnt load.

I disable all plugins/ blog and /cms and only enable the post thanks, the home page load fine but when I want to see the post there is only a blank page.

How can I check the error, I checked the error.log from the apache but there is nothing.

Thanks.

valendono 30 Dec 2009 12:36

the thumb image and the thumb hover its not showing..


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

just me or ?

Doctor Death 30 Dec 2009 12:41

I installed per directions (like other plugins) and the thank you button doesnt show... I am using default skin so there is no reason why it shouldnt. I see the code in the template but the button doesnt appear.

When I try to uninstall (because my tempate is now messy) I get this

Database error in vBulletin 4.0.0:

Invalid SQL:
ALTER TABLE `vywhbabh_user` DROP `post_thanks_user_amount`;

MySQL Error : Can't DROP 'post_thanks_user_amount'; check that column/key exists
Error Number : 1091
Request Date : Wednesday, December 30th 2009 @ 07:44:06 AM
Error Date : Wednesday, December 30th 2009 @ 07:44:06 AM
Script : http://www.ddsog.com/forums/admincp/...do=productkill
Referrer : http://www.ddsog.com/forums/admincp/...post_thanks&s=
IP Address : 70.333.40.132
Username : xxxxxxx
Classname : vB_Database
MySQL Version : 4.1.22-standard

Please help!

Thanks!

dnk.it 30 Dec 2009 12:45

Quote:

Originally Posted by valendono (Post 1942372)
just me or ?

me too

RobbieZ 30 Dec 2009 12:47

2 Attachment(s)
Quote:

Originally Posted by Magz (Post 1942332)
Excellent

Thanks
(if there was a thanks button here too, id use it ;)

Quote:

Originally Posted by The Coon (Post 1942337)
I agree! :cool:

The thanks button or image is in the zipfile under the buttons folders.

Vb4 Doesn't use buttons like they do in 3.8 and predecessors.

It is text with an image next to it. As you hover over the colour will change.

Doctor Death 30 Dec 2009 12:53

When you click on the THANKS button, the button goes away but the two separators where the button was remain... any way of removing them so it doesnt appear as if a button was supposed to be there?

valendono 30 Dec 2009 12:53

Quote:

Originally Posted by RobbieZ (Post 1942381)
The thanks button or image is in the zipfile under the buttons folders.

Vb4 Doesn't use buttons like they do in 3.8 and predecessors.

It is text with an image next to it. As you hover over the colour will change.

r u sure ?
Quote:

Stylevar - ImagePaths - Button Image Directory - Image Path: images/buttons

Kolbi 30 Dec 2009 12:53

Thank you!

Dr.osamA 30 Dec 2009 12:56

installed & nomineted

thanxxx great job

can i translet to arabic and add her plzz ?
________
Host And Design

bollie 30 Dec 2009 12:56

Quote:

Originally Posted by valendono (Post 1942372)
the thumb image and the thumb hover its not showing..


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

just me or ?

me too

Silencer Groans 30 Dec 2009 13:10

1 Attachment(s)
Thank you, my mentor

Annex in Arabic

Dr.osamA 30 Dec 2009 13:16

Quote:

Originally Posted by Silencer Groans (Post 1942395)
Thank you, my mentor

Annex in Arabic

??? ?????? ??? ???? ??? ?????

this product not the sem Post Thank You Hack !!!!
________
Royal Star Tour Deluxe

Dr.osamA 30 Dec 2009 13:18

loooooooooooooooooooool Silencer Groans

thannnnx
________
Big tits sex

Skyrider 30 Dec 2009 13:21

Any vB4 demo's or screenshots?

Silencer Groans 30 Dec 2009 13:26

Quote:

Originally Posted by Dr.osamA (Post 1942400)
loooooooooooooooooooool Silencer Groans

thannnnx

Modified

بالغلط حطيته يا اسامة ^^

Gnoll 30 Dec 2009 13:33

No error @ install , works nice :)

Installed , 5 Star

coberr 30 Dec 2009 13:36

I have a problem.

When I click on the Thanks I get the follwoing:

http://img683.imageshack.us/img683/1580/sc2.jpg

Charlie98902 30 Dec 2009 13:36

1 Attachment(s)
Okay refreshed my cache now it is in its default location by the I icon but it is also by the edit button any ideal how to remove the one by the IP icon? See attachment

EDIT: Never mind I forgot to remove the other hook :D

TimberFloorAu 30 Dec 2009 13:36

No images showing.. any help plz

eTiKeT™ 30 Dec 2009 13:43

Thank you I was waiting at :)
Installed

Veer 30 Dec 2009 13:46

I upgraded and enabled the product, but there is nothing in postbit & postbit_legacy, doesn't show anything.

movslow 30 Dec 2009 13:52

Quote:

Originally Posted by redlabour (Post 1942330)
Still no integration of Post Groan Hack. :down: This has been promised since the first 7.x Release. :mad:

And of course a Update for Post Groan is missing for 4.0. :cool:

Same here, can't install one w/o the other.

Waiting on Post Groan now.

woffie 30 Dec 2009 13:54

Installed and nominated. Thanks for this.

Abe1 30 Dec 2009 13:58

Quote:

Originally Posted by valendono (Post 1942372)
the thumb image and the thumb hover its not showing..


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

just me or ?

Does the included of the post thanx javascript get put on the page?

Quote:

Originally Posted by Doctor Death (Post 1942375)
I installed per directions (like other plugins) and the thank you button doesnt show... I am using default skin so there is no reason why it shouldnt. I see the code in the template but the button doesnt appear.

When I try to uninstall (because my tempate is now messy) I get this

Database error in vBulletin 4.0.0:

Invalid SQL:
ALTER TABLE `vywhbabh_user` DROP `post_thanks_user_amount`;

MySQL Error : Can't DROP 'post_thanks_user_amount'; check that column/key exists
Error Number : 1091
Request Date : Wednesday, December 30th 2009 @ 07:44:06 AM
Error Date : Wednesday, December 30th 2009 @ 07:44:06 AM
Script : http://www.ddsog.com/forums/admincp/...do=productkill
Referrer : http://www.ddsog.com/forums/admincp/...post_thanks&s=
IP Address : 70.333.40.132
Username : xxxxxxx
Classname : vB_Database
MySQL Version : 4.1.22-standard

Please help!

Thanks!

This looks like you are uninstalling. and that it does not have that table. Try reinstalling then uninstall.
Quote:

Originally Posted by Doctor Death (Post 1942385)
When you click on the THANKS button, the button goes away but the two separators where the button was remain... any way of removing them so it doesnt appear as if a button was supposed to be there?

I added the separator in the last minute. I didn't have a chance to fully test it. I will look into it.
Quote:

Originally Posted by FF|Skyrider (Post 1942402)
Any vB4 demo's or screenshots?

When I get a few minutes to play graphic artist.

reimic 30 Dec 2009 14:00

I installed, uploaded all and activated all but there is still no thank you button? Ok I see it now, but i its not in all forums and the image is missing. I uploaded the images to the /images/buttons folder..

rbu 30 Dec 2009 14:02

Quote:

Originally Posted by Veer (Post 1942424)
I upgraded and enabled the product, but there is nothing in postbit & postbit_legacy, doesn't show anything.

I have the same issue but only with IE and compatibility mode enabled. It hides all the postbits.

F.nk 30 Dec 2009 14:04

Thank you very much, this addon is very necessary :D

ragarcia87 30 Dec 2009 14:04

I upgraded my board from 3.8.4 PL1 to 4.0.0 PL1. I had the mod install before but uninstalled all my mods at one point. When I install this it will not show in the postbit or postbit legacy. It will show the stats on the members profiles but not in the postbit.

BTW, thank you for this wonderful mod :D

Multiplying Thanks Buttons / Images
by gbechtel
30 Dec 2009 14:05

2 Attachment(s)
Installed and sorta working...

Seems the thanks images progressively multiply as you go down the page, the farther the post is down the thread the more thanks images appear...

Also displays the same behavior with the information in postbit see attachment thanks1

See attachment, any ideas?

Charlie98902 30 Dec 2009 14:06

2 Attachment(s)
Abe1 here is some screens from mine if you want to use them however I made the extra template edit to move the thanks button to the right instead of the left. Feel free to use these in your first post. Sorry no screen to view your thanks. I looked and didn't see the view your thanked post etc....

Charlie98902 30 Dec 2009 14:07

Quote:

Originally Posted by gbechtel (Post 1942437)
Installed and sorta working...

Seems the thanks images progressively multiply as you go down the page, the farther the post is down the thread the more thanks images appear...

See attachment, any ideas?

I bet you have this in there 3 times? Look carefully and see.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


I.am 30 Dec 2009 14:10

I get the same db error Doctor Death, i've tried to re-install and uninstall it but without success the db error is there.

How can i fix it?

Thanks

reimic 30 Dec 2009 14:10

2 problems i can't solve:

1) There is no image showing up. Only the text "Thanks".
2) Why the thank you button is not in all threats? In some threats i have only a blank space.

bluidkiti 30 Dec 2009 14:10

I did what you said for moving the button over by the Edit button but the Thanks button didn't move. Any suggestions?

gbechtel 30 Dec 2009 14:14

Quote:

Originally Posted by Charlie98902 (Post 1942439)
I bet you have this in there 3 times? Look carefully and see.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Where would I be looking for this Charlie??

valendono 30 Dec 2009 14:16

@Abe1
Yes, it does, I know theres have images to show because of that, but the thumb images not showing.. thumb and hover.. it doesn't mean anything to paste the css in here..

Charlie98902 30 Dec 2009 14:16

Quote:

Originally Posted by gbechtel (Post 1942449)
Where would I be looking for this Charlie??

In the postbit be sure there is only one template hook like this.

Doctor Death 30 Dec 2009 14:18

Quote:

This looks like you are uninstalling. and that it does not have that table. Try reinstalling then uninstall.
Tried that and still got DB error... will retain this mod as I know you are working hard on fine tuning it --- and I truly appreciate your work. Thanks on behalf of all who use it -- I can imagine you are swamped with comments.

Thanks again.

Doc

www.ddsog.com

I.am 30 Dec 2009 14:20

This is my db error:

Quote:

Database error in vBulletin 4.0.0:

Invalid SQL:
SELECT * FROM post_thanks AS post_thanks INNER JOIN user AS user USING (userid) WHERE post_thanks.postid IN (826786,826923,826925,826928,827636,827643,828288,828291,828300,828316,828330,82 8421,828434,828439,828447,828899,831966,831970,832457,832460,832467,832529,83259 8) ORDER BY post_thanks.username ASC;

MySQL Error : Table 'xxxxx_xxxxxx.post_thanks' doesn't exist
Error Number : 1146
Request Date : Wednesday, December 30th 2009 @ 09:17:52 AM
Error Date : Wednesday, December 30th 2009 @ 09:17:53 AM
Script : http://forum.com/showthread.php?t=132731&page=4
Referrer : http://forum.com/
IP Address : xx.xx.xxx.xxx
Username : xxxxx
Classname : vB_Database
MySQL Version : 5.0.85-community-log

gbechtel 30 Dec 2009 14:21

Quote:

Originally Posted by Charlie98902 (Post 1942452)
In the postbit be sure there is only one template hook like this.

Yes only one :confused: hmmmm

KristerSwe 30 Dec 2009 14:27

Quote:

Originally Posted by valendono (Post 1942372)
the thumb image and the thumb hover its not showing..


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

just me or ?

Same for me :confused:

reimic 30 Dec 2009 14:35

I think this is script is very BETA yet. You should update the version. But i think when all bugs are gone, this is a great addon.

Abe1 30 Dec 2009 14:51

Quote:

Originally Posted by ragarcia87 (Post 1942436)
I upgraded my board from 3.8.4 PL1 to 4.0.0 PL1. I had the mod install before but uninstalled all my mods at one point. When I install this it will not show in the postbit or postbit legacy. It will show the stats on the members profiles but not in the postbit.

BTW, thank you for this wonderful mod :D

You may be missing some template hooks. please compare with original and see what you are missing.
Quote:

Originally Posted by gbechtel (Post 1942437)
Installed and sorta working...

Seems the thanks images progressively multiply as you go down the page, the farther the post is down the thread the more thanks images appear...

Also displays the same behavior with the information in postbit see attachment thanks1

See attachment, any ideas?

Very weird. This would have happened back in one of the vb versions when they first came out with the template hooks. I had them fix it and everyone would have this problem if it still existed. Do you have any edited php files?
Quote:

Originally Posted by reimic (Post 1942442)
2 problems i can't solve:

1) There is no image showing up. Only the text "Thanks".
2) Why the thank you button is not in all threats? In some threats i have only a blank space.

Do you have more then one style?



I used to offer free support to install on your web site. If you want me to install on your site now, and make sure you have a 100% working hack, it will cost $50. I will guaranty it works 100% after I install or no payment. If though there really is a bug in my code, then installation will be free. Many of you may have a conflicting hack, or a your own edit you once did. I can't figure out most problems without seeing what your site is like. For this I will charge. If it ends up as a bug in my code, (does not included conflicting errors with other hacks) then you will not be charged. PM me for details. I'd love to help you all but time has me constrained.

valendono 30 Dec 2009 14:53

@abe1
reimic problem is same like the other problem including me..

1) There is no image showing up. Only the text "Thanks".

I.am 30 Dec 2009 14:54

I have already sent you a pm regarding my db errorn and i can't uninstall it

Charlie98902 30 Dec 2009 14:54

Database error posters ensure that all the .php files are installed as I almost missed the upload of the one that goes just in the root directory.

rbu 30 Dec 2009 14:58

If you are using Legacy...

post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_javascript

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_postbit
find <div class="postbody"> and change it to <div class="postbody" style="margin-left:0;">

I.am 30 Dec 2009 14:59

Quote:

Originally Posted by Charlie98902 (Post 1942475)
Database error posters ensure that all the .php files are installed as I almost missed the upload of the one that goes just in the root directory.

I have re-upload all files twice none error in this phase.

Thanks

bluidkiti 30 Dec 2009 15:01

Quote:

Originally Posted by Abe1 (Post 1942292)
4) If you want to move the Thanx button to near the edit post button,
open template postbit
find

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and move it under

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

When I move the Thanks button near the Edit button the Blog This Post button moves with it. Any suggestions?

Abe1 30 Dec 2009 15:06

Quote:

Originally Posted by reimic (Post 1942465)
I think this is script is very BETA yet. You should update the version. But i think when all bugs are gone, this is a great addon.

Excuse me? There have been no proven bugs. Anything I found so far is someone not installin correctly or updating the files. No bugs yet found.

Abe1 30 Dec 2009 15:07

Quote:

Originally Posted by bluidkiti (Post 1942478)
When I move the Thanks button near the Edit button the Blog This Post button moves with it. Any suggestions?

They both move since they are both using that plugin. You can change the order that the plug-in execute though and get the thanx button to the left of the blog button. The plug-in name it something like postbit_complete.

valendono 30 Dec 2009 15:08

Quote:

Originally Posted by rbu (Post 1942476)
If you are using Legacy...

post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_javascript

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_postbit
find <div class="postbody"> and change it to <div class="postbody" style="margin-left:0;">

Its work ! Thanks.

Abe1 30 Dec 2009 15:09

Quote:

Originally Posted by rbu (Post 1942476)
If you are using Legacy...

post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_javascript

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_postbit
find <div class="postbody"> and change it to <div class="postbody" style="margin-left:0;">

Thanx for the tip. I will look into adding that.

Abe1 30 Dec 2009 15:10

Quote:

Originally Posted by valendono (Post 1942473)
@abe1
reimic problem is same like the other problem including me..

1) There is no image showing up. Only the text "Thanks".

Do you have more then 1 style?

ragarcia87 30 Dec 2009 15:11

Thanks Abe1 for your speedy response :D

I will compare the two styles and see whats up. :D

valendono 30 Dec 2009 15:13

only 1 default style and rbu post fix it.. :)

dont worry anymore, thanks for upgrade.. chill out bro..

Cyrus [Hwluxx] 30 Dec 2009 15:14

Thx for update Abe1

I just installed it with overwrite the old 7.7 Version, working perfect.

reimic 30 Dec 2009 15:23

deleted

reimic 30 Dec 2009 15:27

Quote:

Originally Posted by valendono (Post 1942483)
Its work ! Thanks.

it also helps for me! but there is still one problem. in some threats there is no thank you button. only a blank space. have you an idea?

Charlie98902 30 Dec 2009 15:45

Quote:

Originally Posted by reimic (Post 1942503)
it also helps for me! but there is still one problem. in some threats there is no thank you button. only a blank space. have you an idea?

Are they your posts?

I'm getting an error
by Cmangum
30 Dec 2009 15:45

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in [path]/post_thanks.php on line 57.

I'm pretty sure I have everything from the upload file in the right places

abbasbsp 30 Dec 2009 16:02

Quote:

Originally Posted by rbu (Post 1942476)
If you are using Legacy...

post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_javascript

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_postbit
find <div class="postbody"> and change it to <div class="postbody" style="margin-left:0;">

thanks. nice tip ....

mandingo 30 Dec 2009 16:29

Quote:

Originally Posted by Charlie98902 (Post 1942352)
Thanks for the update. I did the template edit in the postbit to move it by the edit button however it is still at the default location instead of being by the edit button.

Quote:

Originally Posted by bluidkiti (Post 1942443)
I did what you said for moving the button over by the Edit button but the Thanks button didn't move. Any suggestions?

Make the template edit in postbit_legacy instead

elwachiman 30 Dec 2009 16:31

The hack does not work with internet explorer, trying to put to thank the post puts it blank and send the user a quick response shows no thanks, uninstalled for now, besides changing the poer button Quick Response button to thank

Charlie98902 30 Dec 2009 16:36

Quote:

Originally Posted by mandingo (Post 1942552)
Make the template edit in postbit_legacy instead

Thanks but I use the postbit and forgot to add and remove a template edit as I needed to.

dnk.it 30 Dec 2009 16:38

Quote:

Originally Posted by rbu (Post 1942476)
If you are using Legacy...

post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_javascript

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_postbit
find <div class="postbody"> and change it to <div class="postbody" style="margin-left:0;">

this fix my problem as well, thanks :)

vulture 30 Dec 2009 16:45

wrong error

DBStattoo 30 Dec 2009 17:10

Quote:

Originally Posted by rbu (Post 1942476)
If you are using Legacy...

post_thanks_box

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_javascript

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


post_thanks_postbit
find <div class="postbody"> and change it to <div class="postbody" style="margin-left:0;">

Nice thanks :D

reimic 30 Dec 2009 17:11

Quote:

Originally Posted by Charlie98902 (Post 1942513)
Are they your posts?

Ok sorry. I am an idiot! ;)

DBStattoo 30 Dec 2009 17:11

Nice hack install and nominate :up:

vulture 30 Dec 2009 17:15

Getting the following error when upgrading from 5.3


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Edit: v5.3 is disabled when I do the upgrade

Charlie98902 30 Dec 2009 17:25

Try removing all of the thank you hack and do a clean install of the newest version here. It's worth a shot.

vulture 30 Dec 2009 17:28

Was thinking that but then I guess all users loose their thanks.

No big deal I guess. I'll backup the DB before I do that though!

Charlie98902 30 Dec 2009 17:32

I am no coder but it is a shot in the dark. I agree with the loss of thanks my members lost the same too as I uninstalled the 3.8 version before I upgrade the forum but they understand too.

AdamSC 30 Dec 2009 17:46

Hi there, thanks for the great post - I am trying to figure out how I can make this appear on a custom skin - what do I add and to which template file?

vulture 30 Dec 2009 17:48

The install assumes that the relevant fields on the table don't exist. Is there not a way of checking to see if they already exist and skip?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


coloradomoms 30 Dec 2009 17:50

Installed and Love it!

Is there a way to install this a second time to make it say "hugs" and track separately? Just curious. :)

ETA - I moved the postbit thingy to make the thanks go next to editpost, but its still under the avatars and stuff. No big deal, just curious as to why it isn't moving. I did the legacy thing and refreshed, cleared cache, etc. still didn't budge. I guess it just wants to hang out over there. ;)


All times are GMT. The time now is 03:52.

Powered by vBulletin® Version 3.8.14
Copyright © 2020, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.