vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=161576

Amazon Store Integration
by mikelbeck
31 Oct 2007 02:55

2 Attachment(s)
Finally, I've gotten around to putting together a version of the Amazon Store integration mod for vBulletin 3.6.

This mod allows you to add an Amazon store to your vBulletin. You can set it to search for a particular keyword, for different types of items - CDs, DVDs, Clothing, etc. A sample of the store in action is available here: http://www.lidragracing.com/amazon_store.php.

You will need to sign up for Amazon Web Services to get an AWS key in order for this to work. In addition, you need to have PHP 5 installed on your server.

Installation is very simple, upload 3 files, import the xml file and then add a link to the store in your navigation bar. See the attached file "ECS Amazon Store.txt" for the exact installation instructions.

Give it a try, let me know what you think. Make sure you click "Mark as Installed" if you've installed it.

Also, if you intall it and use it, please post the URL you have it installed at so I can see how it's being used.

{edit}

To upgrade to a newer version, re-upload the php files and then import the xml product file. Afterwards go to the admin control panel to check to make sure all of the fields are filled in properly.

yahoooh 31 Oct 2007 03:32

can u make it with catgories?

cjshirlaw 31 Oct 2007 03:37

Wow, I will be installing this later and I will let you know how I get on. Nice one!!:up:

mikelbeck 31 Oct 2007 04:01

Quote:

Originally Posted by yahoooh (Post 1372451)
can u make it with catgories?

What do you mean?

yoyoyoyo 31 Oct 2007 05:25

Thanks for sharing - I installed and went to view the store and got this error

Quote:

Fatal error: Call to undefined function: simplexml_load_file() in /home/mysite/public_html/forum/amazon_store.php on line 55
do we enter the AWS key or the AWS secret key? I tried both and got the same error.

bigcurt 31 Oct 2007 05:32

Don't really need it but it looks great. Thanks for the submission.

PoetJA-1975 31 Oct 2007 07:09

Interesting - but Amazon already has what's called an A-Store that can easily be embedded in webpages with IFrame: http://jpicforum.info/view.php?pg=shopjpic

Question: What makes this modification any better?

At anyrate - thanx for the sharing ;)

Jacquii.

projectego 31 Oct 2007 10:20

/me clicks install :)

Thanks!

mikelbeck 31 Oct 2007 11:38

Quote:

Originally Posted by yoyoyoyo (Post 1372494)
Thanks for sharing - I installed and went to view the store and got this error



do we enter the AWS key or the AWS secret key? I tried both and got the same error.

You would enter the AWS access key.

As for the error you're getting - are you using PHP 5?

yoyoyoyo 31 Oct 2007 12:24

Thanks for the info. No - I am not using php 5, my php version is 4.4.7

I installed it on a test forum with no other hacks installed and got the same error.

I sure hope I can get it going - I like it a lot better than the A-store. Do you get affiliate payments from purchases at this store?

Lemmy rules! :)

mikelbeck 31 Oct 2007 12:51

Quote:

Originally Posted by yoyoyoyo (Post 1372660)
Thanks for the info. No - I am not using php 5, my php version is 4.4.7

I installed it on a test forum with no other hacks installed and got the same error.

You need to have php 5 or higher, the simplexml_load_file() function isn't available in php 4.

Quote:

I sure hope I can get it going - I like it a lot better than the A-store. Do you get affiliate payments from purchases at this store?
Yes, that's the whole idea. I've just realized that I didn't put in the AssociateTag, though, so you can't track your site's searches... I'll update it to add that.

Quote:

Lemmy rules! :)
You got that right!

yoyoyoyo 31 Oct 2007 13:51

Quote:

Originally Posted by mikelbeck (Post 1372671)
You need to have php 5 or higher, the simplexml_load_file() function isn't available in php 4.

aw ding dang it - is there any way to get this going for 4.4.7?

mikelbeck 31 Oct 2007 14:20

Quote:

Originally Posted by yoyoyoyo (Post 1372687)
aw ding dang it - is there any way to get this going for 4.4.7?

Not easily... the reason I held off on putting this together for 3.6.8 was because it was such a pain to decode XML with PHP 4. PHP 5 makes it real easy, instead of blocks and blocks of confusing code it's just a single function call.

toucan42 31 Oct 2007 15:03

looking forward to the associate id addition - will install once that's in place - nice mod!

mikelbeck 31 Oct 2007 15:11

I'm posting it now...


All times are GMT. The time now is 00:12.

Powered by vBulletin® Version 3.8.13
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.