vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=319623

Fluid YouTube/Vimeo BBcodes (auto-created)
by MarkFL
25 Jul 2015 19:23

4 Attachment(s)
This product creates 2 new BBCodes that will allow your users to post YouTube/Vimeo videos in fluid containers, i.e., containers that will dynamically resize if the browser window is resized to always maintain a 16:9 aspect ratio and to maintain left/right margins based on a defined percentage of the parent element's width.

Once installed, instruct your users that they merely need to include the video identifiers within the BBCode tags. For example:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Features:
  • Upon installation, your database is edited to create the two new BBCodes thereby eliminating the need for you to go through the tedious process of manually adding them yourself.
  • A button for each BBCode is added to your editor's toolbar.
  • The CSS of the video elements is configurable via the product settings.

Update: version 1.1
  • Added code so that CSS is rendered on the scripts necessary for the videos to display correctly when previewing a post or viewing in the topic review.
Update: version 1.2
  • Added the option to define a maximum width for the videos.
Update: version 1.3
  • Added support for CMS articles.
Update: version 1.4
Update: version 1.5
  • Template now cached.
Update: version 1.6
  • Added support for CMS previews.

Update: version 1.7
  • Added support for SSL.
The BBCode buttons in the editor toolbar:

http://www.vbulletin.org/forum/attac...1&d=1437852009

A YouTube video in a post:

http://www.vbulletin.org/forum/attac...1&d=1437852009

Upon clicking the BBCode buttons in the editor toolbar, you simply need to enter the video's identifier between the generated tags.

To Install:

Download and extract the attached .zip file.

Upload the contents of the "upload" folder to your root directory. This is the image files for the BBCode buttons.

In AdminCP go to Plugins & Products -> Manage Products -> Add/Import Product.

Click on "Choose File" and browse to the product xml file that was packaged in the .zip file.

Click "Import"

Visit the product's settings to configure the CSS (there are default values, so the product will run without having to initially set the settings). Each setting has an explanation of its use.

http://www.vbulletin.org/forum/attac...1&d=1442242111

Support for this product can be found here:

akz645 30 Jul 2015 09:26

Could you do one for facebook too, please?

MarkFL 30 Jul 2015 09:58

Quote:

Originally Posted by akz645 (Post 2551694)
Could you do one for facebook too, please?

Perhaps eventually...I wdon't do facebook and I would have to figure out how to integrate their embed code format. :)

RyanCB 06 Aug 2015 06:25

Hello, our site is using SSL and i have mod'd the links in the plugin to be https: . The video shows but when you try to hit play it says an error has occurred. Any ideas what we are missing? Link to our test thread.

https://www.boostedforums.net/showth...6-Youtube-Test

RichieBoy67 06 Aug 2015 07:33

Very Good Mark! Thanks!

MarkFL 06 Aug 2015 14:36

Quote:

Originally Posted by RyanCB (Post 2552197)
Hello, our site is using SSL and i have mod'd the links in the plugin to be https: . The video shows but when you try to hit play it says an error has occurred. Any ideas what we are missing? Link to our test thread.

https://www.boostedforums.net/showth...6-Youtube-Test

I only see a blank video element when I follow the link. Can you post what your HTML replacement for the BBCode looks like after your edit?

Fizzgig 10 Aug 2015 10:20

Quote:

Originally Posted by MarkFL (Post 2552239)
I only see a blank video element

Hi ..im getting the same, just comes up with error ...thanks

MarkFL 10 Aug 2015 17:06

Quote:

Originally Posted by Fizzgig (Post 2552548)
Hi ..im getting the same, just comes up with error ...thanks

What error message are you getting?

Fizzgig 10 Aug 2015 18:29

Hi..its the same error when the video has been removed on youtube...

MarkFL 10 Aug 2015 18:38

Quote:

Originally Posted by Fizzgig (Post 2552566)
Hi..its the same error when the video has been removed on youtube...

Hmm...okay, would you please post:
  • A link to one of your pages containing such a video.
  • The video's identifier (what you are putting in between the tags) on the page to which you link so I can try it on my dev site.

Fizzgig 10 Aug 2015 18:45

http://sandstormradio.org/showthread...st&p=40#post40

https://www.youtube.com/watch?v=gHtTrcTJADU

MarkFL 10 Aug 2015 18:54

That video plays fine for me on my dev site...does the post contain the following?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


MarkFL 10 Aug 2015 19:05

Update: version 1.1
  • Added code so that CSS is rendered on the scripts necessary for the videos to display correctly when previewing a post or viewing in the topic review.

Fizzgig 10 Aug 2015 19:27


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

that plays ok

MarkFL 10 Aug 2015 19:30

Quote:

Originally Posted by Fizzgig (Post 2552572)
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

that plays ok

My apologies for not including the instructions on how to actually use the BBCode in my initial post (which I will fix next). Thank you for your patience. :up:


All times are GMT. The time now is 13:51.

Powered by vBulletin® Version 3.8.12
Copyright © 2019, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.