vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

ForceHSS 10 Sep 2012 14:56

Quote:

Originally Posted by bzcomputers (Post 2364223)
I will give that a shot, but without knowing exactly which urls in the file to change and which ones to leave alone I worry I might screw something up. Since the mod does seem to work correctly when their servers are up I'm not sure even changing the api address would do much to solve my original issue.

My concern still is that the issue I had really didn't revolve around whether the server could be contacted or not but rather what it did when it couldn't be contacted. When it couldn't be contacted it didn't do what it said it did nor what the settings chosen in the admincp were set up for it to do.

Is this product no longer supported by the original author? Seems like this mod has been abandoned by GlowHost.com, their last post was close to a year ago. Not really a product that many large vB forums could live without!

As it says in that post change all of them. If it does not work you can always install the unedited one again? But if you do use this new URL you need to register with them and get a new api

dougdirac 10 Sep 2012 17:36

My installation is working fine, and I didn't make any modifications to the code. SFS has occasionally been unreachable in the last few weeks, but has always come back eventually. I don't see what benefit there is to changing the URLs from www. to api.

dougdirac 10 Sep 2012 17:40

Quote:

Originally Posted by cooljeba (Post 2364211)
Just installed.. Can i totally get rid of Captcha now ?

You should a least keep one first line of defense to weed out most of the less advanced spambots. If not a Captcha, then at least a challenge question.

bzcomputers 10 Sep 2012 21:48

Quote:

Originally Posted by dougdirac (Post 2364334)
My installation is working fine, and I didn't make any modifications to the code. SFS has occasionally been unreachable in the last few weeks, but has always come back eventually. I don't see what benefit there is to changing the URLs from www. to api.

From the forum posts at StopForumSpam.com and their twitter posts it sounds like the api address at api.stopforumspam.com will be the more robust one (providing mirrors, erc.) that will allow for a lot less downtime in case of issues. The current address does not have all these capabilities and supposedly will not be getting them (from what I can tell) but still may work for some time. Currently both are working, but it is something everyone using this mod should keep on top of.

http://www.stopforumspam.com/forum/v...ic.php?id=4653

https://twitter.com/StopForumSpam

stalkingdatoast 11 Sep 2012 05:35

1 Attachment(s)
Im getting this error while trying to upload the xml file durigng installation. Please help!

Syxguns 11 Sep 2012 05:46

@stalkingdatoast
1) Did you upload all files before trying to import the XML file?

2) Open PHPMyAdmin and make sure the have the table vb_glowhostspamomatic_log If you do not then create the table and then try it again.

ForceHSS 11 Sep 2012 05:53

1 Attachment(s)
Quote:

Originally Posted by stalkingdatoast (Post 2364517)
I'm getting this error while trying to upload the XML file during installation. Please help!

Here is the SQL for that table, you can add it manually from PHPMyAdmin

SNATCH3R 11 Sep 2012 06:15

I am facing a problem when i install the mod...gives me database error.....

Database error in vBulletin 4.2.0:

Quote:

Invalid SQL:
CREATE TABLE IF NOT EXISTS `abc_glowhostspamomatic_log`(
`date` DATETIME NOT NULL,
`ip` VARCHAR(15) NOT NULL,
`email` VARCHAR(255) NOT NULL,
`username` VARCHAR(255) NOT NULL,
`message` VARCHAR(255) NOT NULL,
`is_blocked` TINYINT NOT NULL DEFAULT "0",
`user_hash` VARCHAR(50) NOT NULL,
`user_id` INT NOT NULL
) TYPE=MyISAM;;

MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 10
Error Number : 1064
Request Date : Tuesday, September 11th 2012 @ 12:10:14 AM
Error Date : Tuesday, September 11th 2012 @ 12:10:14 AM
Script : http://www.mydomain.com/admincp/plug...=productimport
Referrer : http://www.mydomain.com/admincp/plug...?do=productadd
IP Address : 18.222.140.59
Username : Admin
Classname : vB_Database
MySQL Version : 5.5.23-55

Can somebody update me what could be the issue

Syxguns 11 Sep 2012 06:38

Quote:

Originally Posted by SNATCH3R (Post 2364523)
I am facing a problem when i install the mod...gives me database error.....
Can somebody update me what could be the issue

Your MySQL Version : 5.5.23-55 doesn't recognize TYPE=MyISAM. There are 3 instances of it in the XML file. Open the XML and replace the 3 occurrences with ENGINE=MyISAM

That will fix the problem.

fly 11 Sep 2012 13:52

vB.org REALLY needs an option for a wiki post after the OP like other sites do.

dougdirac 11 Sep 2012 14:09

Thanks for the detail. Sounds like this mod could use an update.

I'd like the option of using Spam-O-Matic on the thread level as well as the post level.

mark99 11 Sep 2012 14:37

Quote:

Originally Posted by slherzog (Post 2363922)
Well, after searching the db and plugin files, I realized that there's a file uploaded to includes/ that would surely have the stopforumspam URL and it does! :D

Open includes/functions_ghsom.php and find/replace every instance of www.stopforumspam.com with api.stopforumspam.org

Tested and works. :cool:

Really good catch, swapped and will keep an eye on that.

Macsee 13 Sep 2012 22:12

Quote:

Originally Posted by slherzog (Post 2363922)
Well, after searching the db and plugin files, I realized that there's a file uploaded to includes/ that would surely have the stopforumspam URL and it does! :D

Open includes/functions_ghsom.php and find/replace every instance of www.stopforumspam.com with api.stopforumspam.org

Tested and works. :cool:

Can anyone confirm that this is actually a requirement i.e. that we have to change all mentions of stopforumspam.com in file functions_ghsom.php?

If that was an isolate incident with SFS going down a few days ago then ... they seem to have had another of those isolated incidents today!

dougdirac 13 Sep 2012 22:43

I didn't do any of those changes and things are working fine for me, for now. It did set to block registrations if SFS is unavailable, however.

djbaxter 13 Sep 2012 23:43

Quote:

Originally Posted by Macsee (Post 2365197)
Can anyone confirm that this is actually a requirement i.e. that we have to change all mentions of stopforumspam.com in file functions_ghsom.php?

If that was an isolate incident with SFS going down a few days ago then ... they seem to have had another of those isolated incidents today!

No, they are not necessary at all. The issues people were experiencing had nothing to do with the specific URL but with database outages and a surge in spam in all forms over the past few days.


All times are GMT. The time now is 16:07.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.