vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

Spam-o-Matic Log
by BoardWizard
06 Jul 2012 17:55

Why doesn't the Spam-O-Matic log not show under my Statistics and Log in the AdminCP? I've seen it on a screenshot for someone else's. Is there another way to look at the statistics?

valedumi 06 Jul 2012 18:40

I have the same issue, I can see the "Spam-O-Matic Statistics " in the "What's Going On?" vut no statistics.
I have the latest build vBulletin 4.2.0 Patch Level 2.
Thanks

Syxguns 06 Jul 2012 20:09

Quote:

Originally Posted by BoardWizard
Why doesn't the Spam-O-Matic log not show under my Statistics and Log in the AdminCP? I've seen it on a screenshot for someone else's. Is there another way to look at the statistics?

Go to AdminCP > Settings > Options > GlowHost - Spam-O-Matic

Set all of these to YES:

Statistics: Display Number of Denied Registrations?

Statistics: Display Number Of Banned Spammers?

Statistics: Display Number Of User Details submitted to StopForumSpam?

Statistics: Display Number Of Post Details submitted to Akismet?

Statistics: Display Number Of Automoderated Posts?

Statistics: Display Number Of Removed Posts?

Quote:

Originally Posted by valedumi
I have the same issue, I can see the "Spam-O-Matic Statistics " in the "What's Going On?" vut no statistics.
I have the latest build vBulletin 4.2.0 Patch Level 2.
Thanks

The statistics will show in the WGO. Just follow the above instructions.

If you have a busy forum, you should do two things. First add a question in the "Contact Us" about registration problems. Second you should check the logs every so often to see if a user was not permitted access to the forum that should have been. This also helps you decide if certain settings should be turned off in the SOM settings.

Hope that information helps!

rhody401 06 Jul 2012 20:10

Maybe it didnt have any activity yet?

BoardWizard 06 Jul 2012 21:17

Quote:

Originally Posted by Syxguns (Post 2345578)
Go to AdminCP > Settings > Options > GlowHost - Spam-O-Matic

Set all of these to YES:

Statistics: Display Number of Denied Registrations?

Statistics: Display Number Of Banned Spammers?

Statistics: Display Number Of User Details submitted to StopForumSpam?

Statistics: Display Number Of Post Details submitted to Akismet?

Statistics: Display Number Of Automoderated Posts?

Statistics: Display Number Of Removed Posts?



The statistics will show in the WGO. Just follow the above instructions.

If you have a busy forum, you should do two things. First add a question in the "Contact Us" about registration problems. Second you should check the logs every so often to see if a user was not permitted access to the forum that should have been. This also helps you decide if certain settings should be turned off in the SOM settings.

Hope that information helps!

Those options were all set to YES and my statistics appear in WGO but just not in the Statistics & Logs in the admin CP. I don't know why.

everydayforums 06 Jul 2012 21:23

Mine didn't show instant, had to wait for activity..

Syxguns 06 Jul 2012 21:31

1 Attachment(s)
Quote:

Originally Posted by BoardWizard
Those options were all set to YES and my statistics appear in WGO but just not in the Statistics & Logs in the admin CP. I don't know why.

Create a new user, you should not be blocked by SOM. Then after the user is created check your stats in the AdminCP. It should then list the new user and say, passed.... sent to registration. Let me know if that works for you. The log should look similar to this:

BoardWizard 06 Jul 2012 21:31

I've had the Spam-O-Matic for about a week now. Theres 28 posts banned and 1 user registration that was denied

Syxguns 06 Jul 2012 23:05

Quote:

Originally Posted by BoardWizard (Post 2345614)
I've had the Spam-O-Matic for about a week now. Theres 28 posts banned and 1 user registration that was denied

Interesting! Open your PhpMyAdmin and check the database to make sure you have the following tables:

glowhostspamomatic_log
glowhostspamomatic_remotecache
glowhostspamomatic_stats

There may have been an error in the upload of the mod.

imported_dfmafia 07 Jul 2012 04:24

uninstalled.

over 3,000 blocked over past week - only 3 people were able to register.

many of my friends could not register due to being flagged as a spammer.

only stats that showed were blocked registrations.

vB 4.2.0 PL 2


went with a different product to cure my spammer block requirements

Syxguns 07 Jul 2012 05:04

Quote:

Originally Posted by imported_df+++++ (Post 2345698)
uninstalled.

over 3,000 blocked over past week - only 3 people were able to register.

many of my friends could not register due to being flagged as a spammer.

only stats that showed were blocked registrations.

vB 4.2.0 PL 2


went with a different product to cure my spammer block requirements

Did you have check user name enabled? What system did you switch to?

imported_dfmafia 07 Jul 2012 21:28

random questions and advanced registration system - works for keeping bots at bay

yes, check username was enabled

Syxguns 07 Jul 2012 21:38

Quote:

yes, check username was enabled
That was what was causing the issue. When I disabled that and only had IP Address and e-mail address enabled it worked perfect.

I have the VSA Advanced Registration mod and I love it. It does work for keeping bots at bay, but it doesn't work for blocking IP addresses, and e-mails.

imported_dfmafia 07 Jul 2012 23:50

I'll give it another go.
site still in work but taking registrations now as i clean up styles.

thnx for the assist. uername is disabled but ip and email are enabled.


are there still issues with KeyCAPTCHA? full stats never showed on the WGO for me at anytime. just Spammers Denied Registration.

Syxguns 08 Jul 2012 00:20

Quote:

Originally Posted by imported_df+++++ (Post 2345938)

are there still issues with KeyCAPTCHA? full stats never showed on the WGO for me at anytime. just Spammers Denied Registration.

I'm not sure about the keyCAPTCA, as I don't use it. However, the stats for GlowHost only shows, "Spammers Denied Registration" and "Number of spam posts moderated" if that feature is turned on.

You may not have everything set up correctly. There are a lot of little things to do as in making a new usergroup for new members, setting the amount of posts that are moderated, etc. I set the moderated post to 2 because it moderates everything. In other words the first two posts are moderated even if they are legitimate posts. Kind of a pain, and I may set it to just the first post. Normally the first post is all you need to know if they are a spammer or not. You of course have to turn off links, signatures, etc on the new member, but this gives you the opportunity to look at the user profile or have the mods look at the profile for you. Setting up e-mails about new registrations to the mods takes care of this for you.


All times are GMT. The time now is 21:50.

Powered by vBulletin® Version 3.8.14
Copyright © 2022, MH Sub I, LLC dba vBulletin. All Rights Reserved. vBulletin® is a registered trademark of MH Sub I, LLC
Copyright ©2001 - , vbulletin.org. All rights reserved.