vBulletin Mods

The Official vBulletin Modifications Site

Zarxrax 12 Nov 2017 14:43


Originally Posted by In Omnibus (Post 2591049)
StopForumSpam will catch a good deal of it if set up to check both IP addresses and e-mail addresses. Unfortunately, it won't catch everything.

The new Recaptcha will catch virtually all spambots but human spammers can still bypass it.

I find the most effective spam tool is still using the Question And Answer function. If you ask questions that only real people with a genuine interest in your forum can answer, and that don't have "yes" or "no" or "true" or "false" type answers it will stop most of the spam most of the time.

If, for example, you are a math forum, and you ask "How many pieces of pii are in a circle?" only a math nerd would even understand the question. It's not something answerable by a bot or most human spammers.

LOL, the stopforumspam website links to this plugin as the way to implement it on vbulletin 4.
I also have Question and Answers set up on registration that can not be solved by a bot, but that isn't helping lately. I would imagine that any good bot software would keep a database of questions and answers so they only have to be answered once, anyways.

Zarxrax 12 Nov 2017 14:47


Originally Posted by handruin (Post 2591050)
I had the same issue but I can help you fix this. The issue is that the code only looks for "http" urls and not "https", among others when acting on the auto moderation.

Download this plugin and extract the files on your drive. Open the file named "product-glowhostspamomatic.xml" with a text editor.

Search for all instances of this line; I believe there are two of them.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace that line so that it looks like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This change will catch all variations of URLs being posted in your forum, not just if they start with http or https so this does a much better job of catching spam.

Under Admin > Manage Products > Add/Import Product:
Once you've made the changes, you can install the plugin again but make sure to select the radio button to "Allow Overwrite".

Thanks, I think that might actually be the problem. I'm going to look into the possibility of turning off this plugin altogether if I can find another solution, but if not, I will make these edits.

postcd 11 Dec 2017 20:03

Hello, i am getting following error many times, and i am getting it only regarding this vB module, and from multiple vB forums hosted on same server of mine:


Invalid SQL:
INSERT INTO glowhostspamomatic_log(`date`, `ip`, `email`, `username`, `message`, `is_blocked`, `user_hash`) VALUES (now(), "85.174.*.*", "*@yandex.ru", "*", "Spam-O-Matic Tagged email - *@yandex.ru Unable to connect to StopForumSpam.com. This is probably due to some temporary problems on their website: Unable to check. User passed to vBulletin registration system per your settings at \'StopForumSpam: Query Connection Errors\'", "0", "**long*string*here");;

MySQL Error : MySQL server has gone away
Error Number : 2006
Request Date : Monday, December 11th 2017 @ 10:41:15 AM
Error Date : Monday, December 11th 2017 @ 10:42:26 AM
Script : http://mysitehere.com/register.php?do=addmember
Referrer : https://mysitehere.com/register.php?do=addmember
IP Address : 85.174.*.*
Username : *usernamehere*
Classname : vB_Database
MySQL Version :
MySQL server also gone away everytime i try to report spammer using this vB module (Glowhost spam-o-matic)

It do not appear like stopforumspam banned my server IP:

curl http://api.stopforumspam.org/api?username=spammer&json^C
[1]+ Done curl http://api.stopforumspam.org/api?username=spammer
root@host1 [/]# curl "http://api.stopforumspam.org/api?username=spammer&json"
I can login my SFS account, no problem.

All times are GMT. The time now is 17:33.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
Copyright ©2001 - , vbulletin.org. All rights reserved.