vBulletin Mods

The Official vBulletin Modifications Site
https://www.vbulletin.org/forum/showthread.php?t=248042

Zarxrax 12 Nov 2017 13:43

Quote:

Originally Posted by In Omnibus (Post 2591049)
StopForumSpam will catch a good deal of it if set up to check both IP addresses and e-mail addresses. Unfortunately, it won't catch everything.

The new Recaptcha will catch virtually all spambots but human spammers can still bypass it.

I find the most effective spam tool is still using the Question And Answer function. If you ask questions that only real people with a genuine interest in your forum can answer, and that don't have "yes" or "no" or "true" or "false" type answers it will stop most of the spam most of the time.

If, for example, you are a math forum, and you ask "How many pieces of pii are in a circle?" only a math nerd would even understand the question. It's not something answerable by a bot or most human spammers.

LOL, the stopforumspam website links to this plugin as the way to implement it on vbulletin 4.
I also have Question and Answers set up on registration that can not be solved by a bot, but that isn't helping lately. I would imagine that any good bot software would keep a database of questions and answers so they only have to be answered once, anyways.

Zarxrax 12 Nov 2017 13:47

Quote:

Originally Posted by handruin (Post 2591050)
I had the same issue but I can help you fix this. The issue is that the code only looks for "http" urls and not "https", among others when acting on the auto moderation.

Download this plugin and extract the files on your drive. Open the file named "product-glowhostspamomatic.xml" with a text editor.

Search for all instances of this line; I believe there are two of them.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace that line so that it looks like this:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This change will catch all variations of URLs being posted in your forum, not just if they start with http or https so this does a much better job of catching spam.

Under Admin > Manage Products > Add/Import Product:
Once you've made the changes, you can install the plugin again but make sure to select the radio button to "Allow Overwrite".

Thanks, I think that might actually be the problem. I'm going to look into the possibility of turning off this plugin altogether if I can find another solution, but if not, I will make these edits.

postcd 11 Dec 2017 19:03

Skip this message, my problem. Solved

Hello, i am getting following error many times, and i am getting it only regarding this vB module, and from multiple vB forums hosted on same server of mine:

Quote:

Invalid SQL:
INSERT INTO glowhostspamomatic_log(`date`, `ip`, `email`, `username`, `message`, `is_blocked`, `user_hash`) VALUES (now(), "85.174.*.*", "*@yandex.ru", "*", "Spam-O-Matic Tagged email - *@yandex.ru Unable to connect to StopForumSpam.com. This is probably due to some temporary problems on their website: Unable to check. User passed to vBulletin registration system per your settings at \'StopForumSpam: Query Connection Errors\'", "0", "**long*string*here");;

MySQL Error : MySQL server has gone away
Error Number : 2006
Request Date : Monday, December 11th 2017 @ 10:41:15 AM
Error Date : Monday, December 11th 2017 @ 10:42:26 AM
Script : http://mysitehere.com/register.php?do=addmember
Referrer : https://mysitehere.com/register.php?do=addmember
IP Address : 85.174.*.*
Username : *usernamehere*
Classname : vB_Database
MySQL Version :
MySQL server also gone away everytime i try to report spammer using this vB module (Glowhost spam-o-matic)

It do not appear like stopforumspam banned my server IP:
Quote:

curl http://api.stopforumspam.org/api?username=spammer&json^C
[1]+ Done curl http://api.stopforumspam.org/api?username=spammer
root@host1 [/]# curl "http://api.stopforumspam.org/api?username=spammer&json"
{"success":1,"username":{"frequency":0,"appears":0}}r
I can login my SFS account, no problem.
UPDATE: i found these timeouts happening only from time to time. And during one timeout i tried to run this command on my hosting server: wget -O /dev/null stopforumspam.com and it timeout and shown SFS IPs and i searched logs for these IPs and also firewall and found these SFS IPs was banned on my firewall because somehow ended up in abuseipdb and stopforum spam blocklist, it could be also my fault.

Skip this message, my problem. Solved

Version 5.X
by BasilFawlty
09 Feb 2018 15:23

Are there any plans to update this mod to work with Version 5.X of vBulletin? (I did a search of this thread but came up empty).

GlowHost.com 09 Feb 2018 17:49

There are no plans for vBulletin 5. The code base is too different and it would have to be written from scratch it looks like.

Total666 23 Feb 2018 21:22

I believe I have the program set to moderate posts from spammers , and it says it is moderating them . But I have 0 moderated post . Wrong Settings ? thanks

BGObsession 25 Feb 2018 20:35

I have used this add-on for years. Prior to Dec 2017, it was stopping numerous spammer account registration attempts. Since late last year, I have only a handful of registrations blocked according to my Glowhost logs.

Anyone else noticed the add-on activity dropping to almost zero? I've made no major changes during that time frame in terms of my site.

BGObsession 04 Mar 2018 12:16

***cricket chirps***

More and more here - zero responses when posting questions :(

In Omnibus 04 Mar 2018 13:01

Quote:

Originally Posted by BGObsession (Post 2593268)
***cricket chirps***

More and more here - zero responses when posting questions :(

I found this plugin ceased being effective years ago. Spambots can create accounts faster than any software can identify and block them. The most effective spam protection I've found is still the Question And Answer combined with the banning of free e-mail addresses. A lot of administrators don't like to block freemail providers like outlook, google, yahoo, aol, etc. but those are what spambots use. Spammers do not pay for e-mail addresses.

BGObsession 04 Mar 2018 16:28

I appreciate the insight - but I'm trying to figure out why this add-on stopped functioning (regardless of how effective it is)? Prior to the October-December 2017 timeframe, it was blocking hundreds of attempted registrations per day. It began dwindling to just a few a week in Jan 2018 and now the logs show zero registrations blocked.

In Omnibus 04 Mar 2018 17:30

Quote:

Originally Posted by BGObsession (Post 2593272)
I appreciate the insight - but I'm trying to figure out why this add-on stopped functioning (regardless of how effective it is)? Prior to the October-December 2017 timeframe, it was blocking hundreds of attempted registrations per day. It began dwindling to just a few a week in Jan 2018 and now the logs show zero registrations blocked.

Hard to answer since I don't use it any longer. Are you having a large number of spam accounts getting by it? Maybe they found a way around it.

BGObsession 05 Mar 2018 16:59

No. That's the weird part. I've not had a single spam registration, but the GlowHost add-on appears to have completely stopped working.

Master Of Unive 09 Mar 2018 06:44

Quote:

Originally Posted by BGObsession (Post 2593296)
No. That's the weird part. I've not had a single spam registration, but the GlowHost add-on appears to have completely stopped working.

Better ask on their site.

rcull 09 Mar 2018 12:59

It is still working for me, thankfully. It logged 37 rejections yesterday! Spamming was getting so bad I wondered if my site was going to survive! Could it could be a server issue. A few years ago I changed virtual servers, and chose GlowHost because they wrote Spam-O-Matic.
Perhaps other hosts are upgrading things that are stopping the program from working properly, while GlowHost is being more careful?

My site is an automotive related site, the only registration that comes by regularily is one where they register with BMW in a field I call "Cars I Own". There is occasionally a post attempt with the registration.

BasilFawlty 23 Mar 2018 17:41

Quote:

Originally Posted by rcull (Post 2593403)
It is still working for me, thankfully. It logged 37 rejections yesterday! Spamming was getting so bad I wondered if my site was going to survive! Could it could be a server issue. A few years ago I changed virtual servers, and chose GlowHost because they wrote Spam-O-Matic.
Perhaps other hosts are upgrading things that are stopping the program from working properly, while GlowHost is being more careful?

My site is an automotive related site, the only registration that comes by regularily is one where they register with BMW in a field I call "Cars I Own". There is occasionally a post attempt with the registration.

Working for me too. I have it running along side reCaptcha mod. Now, the reCaptcha seems to be stopping most and so the numbers I see stopped in GlowHost Spam-o-matic is much less, but I do still see a few now and them. Running 4.2.5 by the way.


All times are GMT. The time now is 22:25.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright ©2001 - , vbulletin.org. All rights reserved.