View Single Post
  #761  
Old 27 Jan 2012, 20:22
Mark.B Mark.B is offline
 
Join Date: Feb 2004
Those with the "<br />" issue.

I have just spent an hour or so sorting this out and I think I have a solution. I think this only works if you have the lightweight style options hack as well.

The issue: Reply to thread still uses CKEditor. If you switch the template back to a simple textarea, as it was before, the quote isn't passed.

To fix:

Copy the contents of template editor_toolbar_off to editor_ckeditor.

This gives you the quote, but gives you all sorts of <br /> tags and other HTML stuff.

This issue is caused when the user has the WYSIWYG set, so we need to turn that off in the mobile style.

Add the following plugin:

Product: Lightweight Style Options
Hook Location: editor_toolbar_switch
Execution order: 5
PHP Code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Give it a whirl, seems to have worked for me.
Reply With Quote