Thread: Join the convo!
View Single Post
  #2  
Old 25 May 2020, 03:20
In Omnibus's Avatar
In Omnibus In Omnibus is offline
 
Join Date: Apr 2010
Real name: Kris
I currently use 5 but I have licenses for 5, 4, and 3. The primary reason I use 5 is because I don't want to use ten plus year old core PHP, deprecated SQL, HTML 4.0 transitional, and CSS 2.0. Third party modifications aside these are a nightmare to maintain and entirely non-compliant with modern privacy and security requirements and expectations. Any version can be made to work if you want to spend all your time making it work. I'd rather spend my time on other things, like content and membership engagement.

I hesitate to get into a discussion about competing software here, sufficed to say I've always looked at XenForo as an updated version of vBulletin 4, which is exactly what it is. And by updated I mean the PHP, SQL, HTML, and CSS are the current standards. But the general functionality, features, themes, modifications, etc. are all ten plus year old ideas. People are generally resistant to change, so a lot of them went to something that was just a more modern version of what they know, XenForo.

I have no idea what they have done or intend to do with that product in the future, nor do I have any interest in it. The manner with which they left vBulletin and had a functional product such a short tie later leads me to believe they were developing XF on vBulletin time. It would also explain a lot about the end of their time on vBulletin and the state of the product at that time.

Are you wasting your time? Of course not. Develop products that serve your own interests and if you want to offer them to other vBulletin 3 users there are still a good number of them out there.
Reply With Quote