Thread: New Posting Features - [DBTech] Advanced User Tagging v3 (vB4)
View Single Post
  #1233  
Old 24 May 2019, 16:29
Raptor Raptor is offline
 
Join Date: Nov 2001
This plugin breaks the forums if server is PHP 7.1 or 7.2


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This is a well-known error message with PHP 7.1 and PHP 7.2 as you can see in the StackOverflow threads below:

https://stackoverflow.com/questions/...s-as-parameter
https://stackoverflow.com/questions/...edirect=1&lq=1

According to the above threads, the $this value is breaking the PHP function. In this case, the following PHP function breaks the functionality:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

In order to test it, I temporarily commented out the &$this value and set the PHP version to 7.1.

After removing the value the forums function correctly.

I actually went to pay for the pro version but it seems DBTech don't support Vbulletin any more. Lost business for them I guess.

If someone can fix this so it works in PHP 7.1 that would be great.
Reply With Quote