Thread: Integration with vBulletin - [Neoobs] Teamspeak3 Integration
View Single Post
  #235  
Old 07 Feb 2013, 17:29
richardevans123 richardevans123 is offline
 
Join Date: Sep 2012
Originally Posted by max1982 View Post
Still not working i have made server on my machine and tested the plugin still say connection time out, any idea?

also there is no link in the quick links to the plugin on the forum any one elss having this problem
Make sure you've got Server Query Access, and give the permissions to the Guest Server Query usergroup.

You'll have to use the Advanced Permissions Settings

This error message says one or more permissions the TSViewer does require are not allowed on the server.

Step 1 - enable Advanced permission system

Open the TeamSpeak 3 client. Click at the top menubar on Settings and then Options. The Options window is now open.

Click there then on the left sidebar on Application, put there then under Misc a check mark at Advanced permission system.

Close now the Options window with a click on the OK Button.


Step 2 - allow the permissions



Dont be suprised, an fresh installed TS3 server does not have this permissions allowed by default. Thats why almost everybody does see this error code 2568 error message when he wants to use a TSViewer. The following screenshot shows which permissions have to be allowed additionally:
Connect to your TeamSpeak 3 server and open this window by clicking in the top menubar on Permissions and then Server Groups.

First change the display of the permissions to Show names (Dropdown menu in the center at the bottom of this window).

Select now on the left side at Server Groups the Guest (8).

In the center, the mainarea of this window you see the complete permissions of your server divided into categories (Global, Virtual Server, Channel, Group, ...). Those you can fold out to see which further subcategories and permissions you can find there.

Search now the permissions in their categories and allow them as displayed in the screenshot (by doubleclicking it, a check mark at Value will get set automatically, with that the permission is allowed then). Should the permission have been already added (black instead of grey text) and a check mark be missing at Value then allow this permission by setting the check mark at Value.

Done
Reply With Quote