Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 05 Dec 2009, 18:00
hirlas hirlas is offline
 
Join Date: Jul 2006
Question Run error / installed fine

Anyone else have this issue? The install went without any issues, but when trying to run the arcade I get this error. Is mysql too old? Or because I have added az in front of all of my tables? (to prevent issues on the server from multiple VB instances)

I am running php 5.29 / mysql 4.027

<error below>

mySQL query error: SELECT user.userid, user.avatarid, user.avatarrevision, avatar.avatarpath, customavatar.filename, NOT ISNULL(filedata) AS hascustom, customavatar.dateline FROM (SELECT * FROM azuser WHERE userid=2) AS user LEFT JOIN azavatar AS avatar ON avatar.avatarid = user.avatarid LEFT JOIN azcustomavatar AS customavatar ON customavatar.userid = user.userid WHERE customavatar.userid=2 OR user.userid=2

mySQL error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT * FROM azuser WHERE userid=2) AS user LEFT JOIN azavatar
mySQL error code:
Date: Saturday 05th 2009f December 2009 09:55:09 AM
Reply With Quote
Comments
  #2  
Old 05 Dec 2009, 21:57
MrZeropage's Avatar
MrZeropage MrZeropage is offline
 
Join Date: Nov 2003
Real name: Marcel
you are using mySQL < 4.1 and this means the optimized query can not be used.
Normally ibProArcade tries to detect your mySQL-version and use the corresponding query, but this seem to fail on your site.

This version of ibProArcade are you using ?
__________________
Get the most installed modification for your vBulletin (more than 8400 installations and 144.000 downloads!):
ibProArcade 2.7.3+ download here | Click here to enter the ibProArcade-Support-Section
Reply With Quote
  #3  
Old 05 Dec 2009, 22:52
hirlas hirlas is offline
 
Join Date: Jul 2006
I downloaded and installed the latest version:

v2.6.9+ (Released 28th November 2009)
Reply With Quote
  #4  
Old 05 Dec 2009, 23:08
MrZeropage's Avatar
MrZeropage MrZeropage is offline
 
Join Date: Nov 2003
Real name: Marcel
...and it was a fresh install ?

Please provide access to your FTP via PM to me and I will try to find out what the problem is and why mySQL-version-detection does not work here...
__________________
Get the most installed modification for your vBulletin (more than 8400 installations and 144.000 downloads!):
ibProArcade 2.7.3+ download here | Click here to enter the ibProArcade-Support-Section
Reply With Quote
  #5  
Old 05 Dec 2009, 23:08
hirlas hirlas is offline
 
Join Date: Jul 2006
I will pm you the info. Thank you!
Reply With Quote
  #6  
Old 05 Dec 2009, 23:56
MrZeropage's Avatar
MrZeropage MrZeropage is offline
 
Join Date: Nov 2003
Real name: Marcel
Problem solved - mySQL 4.0.27 running, but mysql_get_client_info() gives back 4.1.22

Now implemented a new config-setting to avoid such problems... in ibProArcade v2.7.0+ you will find (in /arcade/functions/dbclass.php)
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

set this to TRUE to force using the "old" SQL-command for mySQL < 4.1 and if mySQL-version-detection fails

@hirlas:
this is already implemented and activated on your site
__________________
Get the most installed modification for your vBulletin (more than 8400 installations and 144.000 downloads!):
ibProArcade 2.7.3+ download here | Click here to enter the ibProArcade-Support-Section
Reply With Quote
  #7  
Old 06 Dec 2009, 00:00
hirlas hirlas is offline
 
Join Date: Jul 2006
I'm sending a little thank you your way!
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 23:57.

Layout Options | Width: Wide Color: