Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AME3 - Auto Media Embeding and Video Extender Details »
AME3 - Auto Media Embeding and Video Extender
Mod Version: 3.0.1, by The Geek (Coder) The Geek is offline
Developer Last Online: May 2015 I like it Show Printable Version Email this Page

vB Version: 4.0.0 Rating: (97 votes - 4.72 average) Installs: 1361
Released: 21 Dec 2009 Last Update: 17 Jan 2010 Downloads: 10171
Not Supported DB Changes Uses Plugins Additional Files External Content  

From the makers of Smooth and Jazz comes the singing sensation my mom has been waiting months for:

AME3. Bigger. Badder. Bestest.

NOTE ABOUT vB4.0.3: ------------------------------------------------------------

vBulletin 4.0.3 has changed the way video codes are handled and in the process, inadvertently broke AME3. I have submitted a bug report and believe that the issue will be quickly resolved. There is a manual fix you can apply for 4.0.3 here in the interim.
-----------------------------------------------------------------------------------------------

AME3 is the sequel to the multi award winning AME 1x and AME 2x systems. AME3. This time, its different.
AME3 does 3 things:
  • It allows users to simply paste URLs into their message without having to use the video bbcode or video popup box.
  • It allows you to add, edit and customise the video definitions that ship with vB4
  • It allows you to import community created definitions to extend the system in ways you otherwise couldn't.
Now you can use AME anywhere you can use video bbcode: posts, blogs, visitor messages, the CMS, etc...

Note that I am releasing this early for beta testing and general feedback. There is currently a bug in RC2, RC4 and 4.0.0 that will prevent AME from working however there is a workaround posted below.

I have written a pretty comprehensive readme and attached it seperatly to this post. I suspect both this post and the readme will get updated as AME3 becomes finalised.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	wysiwyg.jpg
Views:	11384
Size:	179.5 KB
ID:	107851   Click image for larger version

Name:	postbit.jpg
Views:	9152
Size:	159.5 KB
ID:	107852  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #1471  
Old 29 Jan 2017, 10:19
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
I went https on my site and old definitions were using http protocol, so it means videos are considered problem.

I tried to sort this out with AME, but it didn't worked. It was strange, I had correct definitions (just change http to https and leave rest as it is, it works this way with youtube, which is main source of videos, guess it works for some other services), but it didn't helped.

Till I found that some definitions worked, some not.

Well, problem was that at least for me AME didn't changed correctly video_bbcode template. I needed manually to edit template. After that, videos work.

Not sure what went wrong.

In case that someone of you have same problem.
Reply With Quote
  #1472  
Old 23 Feb 2017, 02:14
incisor incisor is offline
 
Join Date: May 2006
Originally Posted by Alan_SP View Post
Well, problem was that at least for me AME didn't changed correctly video_bbcode template. I needed manually to edit template. After that, videos work.
could you elaborate please...
Reply With Quote
  #1473  
Old 23 Feb 2017, 18:29
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
It's as I wrote: AME for some reason didn't changed video_bbcode template.

You edit video definition, you save it. But it doesn't get saved into video_bbcode template. Some did get saved. This gave me idea to check template and there I manually entered correct (https) definitions.

Which also lead me to remember that I tried to make some definitions (facebook) that didn't worked. Now I think that this is because AME didn't saved definitions into template. If I try again to play with this, I'll check template manually, just to be sure I have it there also.
Reply With Quote
  #1474  
Old 22 Jul 2017, 20:55
sticky sticky is offline
 
Join Date: Sep 2003
I apologize if I missed it but does anyone have this working with Instagram?
Reply With Quote
  #1475  
Old 25 Jul 2017, 10:18
unitedpunjab's Avatar
unitedpunjab unitedpunjab is offline
 
Join Date: Feb 2006
Real name: Dhillon
Instagram

RegEx:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replacement HTML:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #1476  
Old 26 Jul 2017, 02:26
sticky sticky is offline
 
Join Date: Sep 2003
Originally Posted by unitedpunjab View Post
Instagram

RegEx:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replacement HTML:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
It's adding the video tags but the embed code isn't working for some reason?

Last edited by sticky; 26 Jul 2017 at 02:33.
Reply With Quote
  #1477  
Old 26 Jul 2017, 09:51
unitedpunjab's Avatar
unitedpunjab unitedpunjab is offline
 
Join Date: Feb 2006
Real name: Dhillon
This url format works for me,


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #1478  
Old 27 Jul 2017, 14:08
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Anyone have any clue what is going on here?


If you quote reply a guy who has more than 1 AME processed tweet, anything you type appears inside the quote box. If I edit a post that somebody quoted and remove all of the twitter embeds except one and then save it, the text will then be outside of the quote box and fixed. So..anyone have any idea? I thought it could be related to the quote expander I have but I removed that on a test style and no go.
Reply With Quote
  #1479  
Old 27 Jul 2017, 22:33
sticky sticky is offline
 
Join Date: Sep 2003
Originally Posted by unitedpunjab View Post
This url format works for me,


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
I appreciate your help but the replacement html code just isn't working for me. Just no embed for some reason.

Not sure what to do but thanks for trying.
Reply With Quote
  #1480  
Old 28 Jul 2017, 03:32
sticky sticky is offline
 
Join Date: Sep 2003
Originally Posted by unitedpunjab View Post
Instagram

RegEx:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replacement HTML:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Would someone else be able to double check if this works or if it is the code perhaps?
Reply With Quote
  #1481  
Old 30 Jul 2017, 22:33
Alan_SP's Avatar
Alan_SP Alan_SP is offline
 
Join Date: Nov 2009
You can always check my post here: https://www.vbulletin.org/forum/show...postcount=1473 (my previous post on this thread).

You may have same problem as I had. And in this case, whatever code you use, it wouldn't work. Unless you manually edit video bbcode template.
Reply With Quote
  #1482  
Old 07 Aug 2017, 13:41
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Originally Posted by bfdzio View Post
Anyone have any clue what is going on here?


If you quote reply a guy who has more than 1 AME processed tweet, anything you type appears inside the quote box. If I edit a post that somebody quoted and remove all of the twitter embeds except one and then save it, the text will then be outside of the quote box and fixed. So..anyone have any idea? I thought it could be related to the quote expander I have but I removed that on a test style and no go.
https://www.vbulletin.org/forum/show...postcount=1478

Anyone have any idea on this problem?
Reply With Quote
  #1483  
Old 09 Aug 2017, 13:53
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Bumping for my problem above
Reply With Quote
  #1484  
Old 25 Aug 2017, 15:30
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Originally Posted by bfdzio View Post
Anyone have any clue what is going on here?


If you quote reply a guy who has more than 1 AME processed tweet, anything you type appears inside the quote box. If I edit a post that somebody quoted and remove all of the twitter embeds except one and then save it, the text will then be outside of the quote box and fixed. So..anyone have any idea? I thought it could be related to the quote expander I have but I removed that on a test style and no go.
I will pay somebody up front to help solve this problem!
Reply With Quote
  #1485  
Old 28 Nov 2017, 17:29
bfdzio bfdzio is offline
 
Join Date: Oct 2007
Originally Posted by bfdzio View Post
Anyone have any clue what is going on here?


If you quote reply a guy who has more than 1 AME processed tweet, anything you type appears inside the quote box. If I edit a post that somebody quoted and remove all of the twitter embeds except one and then save it, the text will then be outside of the quote box and fixed. So..anyone have any idea? I thought it could be related to the quote expander I have but I removed that on a test style and no go.
Just wanted to post that I fixed this in case anyone else runs into the issue. Had given up but then other day took another crack at it and got it fixed in 5 minutes.

Replaced the embed code under "Display" for the mod in the AME CP to this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 23:46.

Layout Options | Width: Wide Color: