Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
GTPosting Rules: Posting Rules near editor Details »
GTPosting Rules: Posting Rules near editor
Mod Version: 1.1.2, by Princeton (Coder/Designer) Princeton is offline
Developer Last Online: Aug 2018 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (14 votes - 4.79 average) Installs: 145
Released: 17 Oct 2006 Last Update: 13 Jun 2007 Downloads: 848
Not Supported Uses Plugins Template Edits  

Custom modification brought to you by Joe Velez (aka Princeton vbulletin.org Admin).

Sometimes, it's the little things in life that makes us happy:

GTPosting Rules is a NO TEMPLATE EDITS mod to display Posting Rules near the editor. This mod will add the Posting Rules to all editors including quickreply and quickedit. Take a look at the following attachments if you do not understand what I mean.

Show your support and click Mark As Installed, Nominate For MOTM, or Support Developer.

All you have to do is upload the "product-gtpostingrules.xml" file via the Plugins & Products System.

No template edits required.

by Princeton, GO-TOTAL LLC, Vineland, NJ USA

To exclude rules from showing up under the editor, open the GTPR: Process Rules: editor_toolbar_end plugin and add the THIS_SCRIPT value of page to the $excludegtprules array.


History:

v 1.1.2 : Fixed Quick Edit problems and added option to exclude specific pages.
v 1.1.1 : Fixed Template Edit Error
v 1.1.0 : Fixed rules from displaying in Edit Signature.
v 1.0.0
: Missing template in xml.

You may also be interested in:

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	1editor.jpg
Views:	1929
Size:	21.4 KB
ID:	54807   Click image for larger version

Name:	1quickedit.jpg
Views:	2203
Size:	38.3 KB
ID:	54808   Click image for larger version

Name:	1quickreply.jpg
Views:	2723
Size:	34.1 KB
ID:	54809  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add Posting Rules Near Editor Princeton vBulletin 3.5 Add-ons 12 07 Apr 2008 13:57
BLS - addon to RULES AND USER AGREEMENT HACK: rules to selected forum Bolas vBulletin 3.0 Full Releases 21 25 Nov 2006 14:16
BLS - addon to RULES AND USER AGREEMENT HACK: rules to child forum Bolas vBulletin 3.0 Full Releases 0 13 Apr 2005 22:35

  #31  
Old 13 Jan 2007, 22:59
da420 da420 is offline
 
Join Date: Nov 2005
Thanks Princeton...

Seems to work fine everywhere but the quick editor. Did the quick editor template edit, and whenever I do a quick edit, no text shows up in the editor box. I revert that template, and it works fine without the posting rules though. Until that is fixed, I will continue to have this installed, just without the quick edit template edit. :P
Reply With Quote
  #32  
Old 14 Jan 2007, 18:31
category category is offline
 
Join Date: Jul 2005
I have a question how come when you edit a thread instead of the text you have its blank?
Reply With Quote
  #33  
Old 14 Jan 2007, 18:35
category category is offline
 
Join Date: Jul 2005
you made a mistake in your manual installation

FIND IN postbit_quickedit:
$newpost[message]</textarea>


REPLACE WITH:
</textarea></div>
<div class="smallfont" align="center"><strong>$vbphrase[posting_rules]</strong>:
<phrase 1="misc.php?$session[sessionurl]do=bbcode" 2="$bbcodeon">$vbphrase[vb_code_is_x]</phrase>,
<phrase 1="misc.php?$session[sessionurl]do=showsmilies" 2="$smilieson">$vbphrase[smilies_are_x]</phrase>,
<phrase 1="misc.php?$session[sessionurl]do=bbcode#imgcode" 2="$imgcodeon">$vbphrase[img_code_is_x]</phrase>,
<phrase 1="$htmlcodeon">$vbphrase[html_code_is_x]</phrase>
</div>
you should not remove $newpost[message] in your edit becuase if you try to edit your post it will be blank
Reply With Quote
  #34  
Old 16 Jan 2007, 18:35
puertoblack2003's Avatar
puertoblack2003 puertoblack2003 is offline
 
Join Date: Aug 2005
Originally Posted by category View Post
you made a mistake in your manual installation



you should not remove $newpost[message] in your edit becuase if you try to edit your post it will be blank
thanks for the heads up one of my mods told me about it and was having that problem but when adding that $newpost[message] it seem to solve the problem i think that Manuel script install probably a typo.
__________________
Android Custom Creations
Reply With Quote
  #35  
Old 17 Jan 2007, 11:17
Orcun Orcun is offline
 
Join Date: Dec 2005
Need to add a Custom Mark like <!--NaBura--> to Showthread_quickreply toget rules under the WYSIWYG editor like here and changed the Case switch statement according to change.

Thanks
Reply With Quote
  #36  
Old 20 Jan 2007, 15:53
Princeton's Avatar
Princeton Princeton is offline
 
Join Date: Nov 2001
Real name: Joe Velez
good catch ... I've updated the zip file Jan 15th for those interested.
__________________
Former vBulletin.org Staff Member

Latest Articles:
Liquid Layout = Less Ad Revenue?
How to Monetize Your Site
Improve Web Page Performance
How To Write For The Web


If it needs instructions, there's room for improvement.
Give users what they actually want, not what they say they want. And whatever you do, don't give them new features just because your competitors have them!
Reply With Quote
  #37  
Old 20 Jan 2007, 22:29
StarBuG's Avatar
StarBuG StarBuG is offline
 
Join Date: Dec 2001
Because the product did not work for me (rules showed up above the editor and below the editor buttons like bold)
I did the manual install and discovered a few errors in your txt file.

I have attached a working version with these errors corrected.

I have also moved the rules inside the editor when writing with the advanced editor because of consistency, this is also included into this txt.
However, I don't know if this will conflict with your smiley below editor mod, cause I don't use it.

So use my modification in "editor_toolbar_on" at your own risk!

Thank you for this nice Hack

StarBuG
Attached Files
File Type: txt Product_GTPostRules_MANUAL_installation.txt (5.0 KB, 29 views)
Reply With Quote
  #38  
Old 24 Jan 2007, 16:33
arena's Avatar
arena arena is offline
 
Join Date: Oct 2006
thanks
Reply With Quote
  #39  
Old 28 Jan 2007, 16:22
Shazz's Avatar
Shazz Shazz is offline
 
Join Date: Jun 2006
Location: Utah
Real name: Shawn
Thanx!
/me installs
Reply With Quote
  #40  
Old 29 Jan 2007, 01:31
Shazz's Avatar
Shazz Shazz is offline
 
Join Date: Jun 2006
Location: Utah
Real name: Shawn
Originally Posted by da420 View Post
Thanks Princeton...

Seems to work fine everywhere but the quick editor. Did the quick editor template edit, and whenever I do a quick edit, no text shows up in the editor box. I revert that template, and it works fine without the posting rules though. Until that is fixed, I will continue to have this installed, just without the quick edit template edit. :P
Same reason
Had to unistall
Reply With Quote
  #41  
Old 29 Jan 2007, 05:07
da420 da420 is offline
 
Join Date: Nov 2005
Shazz, read category's post.
Reply With Quote
  #42  
Old 01 Feb 2007, 12:37
DementedMindz DementedMindz is offline
 
Join Date: Jan 2006
In your manual install you have this

FIND IN showthread_quickreply:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


REPLACE WITH:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


ok now if you do it that way it will show the rules on top of the textarea the way I changed it to show on the bottom like this site was this

FIND IN showthread_quickreply:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Add Under it:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Last edited by DementedMindz; 14 Feb 2007 at 20:50.
Reply With Quote
  #43  
Old 03 Feb 2007, 13:02
Smiry Kin's's Avatar
Smiry Kin's Smiry Kin's is offline
 
Join Date: Dec 2005
nice!

/me installs
Reply With Quote
  #44  
Old 12 Feb 2007, 01:21
Chicago_VLNU_4s Chicago_VLNU_4s is offline
 
Join Date: Mar 2006
Location: Chicago
Real name: Moreno 4
ahhh!! another one for 3.6.4. Will this ever be available for 3.5.4?

nevermind... found your 3.5.4 on here > http://www.vbulletin.org/forum/showthread.php?t=113795 .

thanks alot buddy. INSTALLED

Last edited by Chicago_VLNU_4s; 12 Feb 2007 at 01:36.
Reply With Quote
  #45  
Old 22 Feb 2007, 00:38
PixelFx PixelFx is offline
 
Join Date: Dec 2002
Arrow

just wanted to say thanks for this mod, I've added it to my site, cleaned up the templates through the manual install figoured I'd post a few screenshots ..

I have small issue, in that not sure where to center my advaned edit window, but otherwise everything all good thanks for sharing, I added your smilie addon as well .
Attached Images
File Type: jpg posting-rules.jpg (49.8 KB, 25 views)
File Type: jpg posting-rules2.jpg (40.4 KB, 25 views)
File Type: jpg posting-rules3.jpg (62.9 KB, 30 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 13:26.

Layout Options | Width: Wide Color: