Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 04 Aug 2019, 11:15
Younicode Younicode is offline
 
Join Date: Feb 2008
Bunny! only login long response - timeout issue

Hi,

We have a very strange issue about singing in to our forum. The issue is that it takes too long after insertion of the login's data to receive the response from the server and be directed to the main page. The rest of the forum works very well. once you get logged in after lots of trying everything is ok.

The error is ERR_TIMED_OUT.

There is no issue for the database connection I checked.
The issue arose a week ago after having lot's of fake users registrations. I have delete all the fake users and activated DDOS detection and blocking in the server (Linux debian).
DDOS deflate , APF and BFD have been installed and configured.
I have updated PHP, apcache2 and mysql and phpmyadmin to theri last versions.

The problem however still exists and I do not have any idea about how to solve the issue.

The only thing that comes to my mind is maybe the issue of sessions and cookies but I do not see any error.

Could anyone please help me about resolving the issue?

Thanks.
Reply With Quote
  #2  
Old 04 Aug 2019, 12:05
Seven Skins's Avatar
Seven Skins Seven Skins is offline
 
Join Date: Sep 2008
Try .. in adminCP

path to save cookies ..default is slash "/"
cookie domain .. default is "blank"
forum URL
Forum Component URL

and .htaccess to see if login.php is being redirected.

check everywhere if it is http or https .. it should be only one not mixture of both
Reply With Quote
  #3  
Old 04 Aug 2019, 20:07
Dave Dave is online now
 
Join Date: Jun 2010
Real name: Dave
Also if you have any plugins that interact with the login process, disable them one by one. It's possible one of them performs a HTTP(S) call behind the scenes that times out.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #4  
Old 06 Aug 2019, 20:47
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Originally Posted by Dave View Post
Also if you have any plugins that interact with the login process, disable them one by one. It's possible one of them performs a HTTP(S) call behind the scenes that times out.
Nice to see you here Dave!

OP - Check server logs.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #5  
Old 12 Aug 2019, 14:16
Younicode Younicode is offline
 
Join Date: Feb 2008
Hi,

I did everything to fix the issue but it still does not work.
I have reinstalled the Debian operating system in the VPS and imported everything again.
The hooks are disabled from the config file.
The response takes too long to be received and the timeout error still persists.

It should be related to something to server but I don't know what.

The same issue exists in signing into phpmyadmin.

The strange thing is that all the rest of the website works well. if your session is not destroyed you can access it properly. Currently i myself cannot log in to the forum.

There is no error log in the operating system log files.

I don't know what is wrong.
I asked form the hosting company to check if everything is wrong with them but the technicians of the server told me the only available opened port are http, https, and mysql and i don't personally think this is related.

I sometime see php allocation memory issue in the apache2 log but increasing the limit in php.ini did not resolve the problem.

Using a test php file I checked db connection, session and cookie creation and all work.

I appreciate if anyone can help me.



Thanks.
Reply With Quote
  #6  
Old 12 Aug 2019, 14:52
In Omnibus's Avatar
In Omnibus In Omnibus is offline
 
Join Date: Apr 2010
Real name: Kris
Are you using a php.ini file?

If so what are the these settings?

memory_limit = ${PHP_MEMORY_LIMIT}

max_execution_time = (30)
Reply With Quote
  #7  
Old 12 Aug 2019, 16:05
Younicode Younicode is offline
 
Join Date: Feb 2008
Yes, i use php.ini.

I recently switched to use php 7.1 instead of 5.6 and here are the settings:

memory_limit = 128M
max_execution_time = 30


But why a simple login response should require more resources of time and limit?
However, nothing changed by increasing the above limits.

I wish I could find a way to trace the issue and figure out the real source of it.

Thanks.
Reply With Quote
  #8  
Old 12 Aug 2019, 20:41
In Omnibus's Avatar
In Omnibus In Omnibus is offline
 
Join Date: Apr 2010
Real name: Kris
Originally Posted by Younicode View Post
Yes, i use php.ini.

I recently switched to use php 7.1 instead of 5.6 and here are the settings:

memory_limit = 128M
max_execution_time = 30


But why a simple login response should require more resources of time and limit?
However, nothing changed by increasing the above limits.

I wish I could find a way to trace the issue and figure out the real source of it.

Thanks.
128MB is nothing by today's script standards. The first thing I would do is increase that value to 512MB and see if that resolves your issue. You can also try increasing the timeout value to 60 but I would try the memory value first.
Reply With Quote
  #9  
Old 14 Aug 2019, 16:36
Younicode Younicode is offline
 
Join Date: Feb 2008
Hi,

The issue is resolved. It was some block from the server administration side on the VPS done from the hosting company.
The did not explain what was it exactly but after communicating with them they resolved it.


Thanks everyone.
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Extended timeout for whois online without changing cookie timeout Jakeman vBulletin 2.x Full Releases 21 30 Nov 2006 03:38


Tags
login, mysql, phpmyadmin, timeout


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:59.

Layout Options | Width: Wide Color: