Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 23 Oct 2013, 21:58
VAG VAG is offline
 
Join Date: Jul 2010
site hacked by lasttouch

www.vagcommunity.com

did a full re-install of everything and removed thousands of suspicious files. Blog is up, forum is still not up. How to fix that?
Install folder deleted.

Thanks for your help.
Reply With Quote
  #2  
Old 23 Oct 2013, 22:37
tbworld tbworld is offline
 
Join Date: Oct 2008
The following guides and best practices should get you up and running again. Be thorough when using them, and sorry you were hacked.

http://www.vbulletin.com/forum/blogs...vbulletin-site
http://www.vbulletin.com/forum/blogs...ve-been-hacked
http://www.vbulletin.com/forum/blogs...vbulletin-site
http://www.vbulletin.com/forum/forum...-1-vbulletin-5
Reply With Quote
  #3  
Old 25 Oct 2013, 12:00
Skivey Skivey is offline
 
Join Date: Feb 2008
do you do a database backup? I use mysqldumper for that and use perl to create auto daily backups. I also got hacked this week and ended up just restoring. Getting my site back took all of 15 minutes which then allowed me the time to follow all of the same links as above to then fix any holes.

As of now im ok.....

--------------- Added 25 Oct 2013 at 12:01 ---------------

failing that, email the hacker and thank them for finding a hole in your site and ask them for help in fixing it.
Reply With Quote
  #4  
Old 25 Oct 2013, 12:46
VAG VAG is offline
 
Join Date: Jul 2010
I removed all malicious files and did a reinstall of all the software but I still cannot get the forum to work. As I was planning to take it down anyway, might save myself the troubles and shut it all down right now.
Reply With Quote
  #5  
Old 25 Oct 2013, 12:56
Skivey Skivey is offline
 
Join Date: Feb 2008
reinstall of the software? so you set up a new database? if its a fresh install i highly doubt it... im guessing this isnt the case as you would still have posts and users. Did you do any backups of your database?

Adding to above, in cleaning ive just found 15 new admins...... and a bunch of new plugins.....
Reply With Quote
  #6  
Old 12 Nov 2013, 16:16
VAG VAG is offline
 
Join Date: Jul 2010
My customer wants the old forum back up and running. So I need to dig deeper. Everything is replaced by the new files and all malicious files have been removed. There is some nasty redirect at http://www.vagcommunity.com/forum/forum.php which I can't replace. So i am asking for your help.
I can access admincp without problems. And sadly, I have no backup of the database..

Anyone?
Reply With Quote
  #7  
Old 12 Nov 2013, 16:41
Bladed Bladed is offline
 
Join Date: Nov 2013
Search your database for the code. It's in there and you need to delete it. you'll need to search multiple times to make sure it is gone.
Reply With Quote
  #8  
Old 12 Nov 2013, 21:18
VAG VAG is offline
 
Join Date: Jul 2010
Finally it's fixed Thanks for the help. There was some malicious code in the database.
Reply With Quote
  #9  
Old 13 Nov 2013, 09:27
Skivey Skivey is offline
 
Join Date: Feb 2008
I use a program called mysqldumper

It does auto backups of each database daily and deletes 3 day old ones. It allows you to upload sql files in excess of 50mb (which is the limit for a lot of hosts) and you can also download all backups.

As I said above, I also got hacked and just by resetting the database from the previous backup I lost 0 posts and threads and got my site back up and working within 5 minutes.

Id suggest you do this also, its a brilliant program.

Matt
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 01:41.

Layout Options | Width: Wide Color: