Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Video-Directory Remixed Details »
Video-Directory Remixed
Mod Version: 1.3.0, by Jaxel (Coder) Jaxel is offline
Developer Last Online: Sep 2013 I like it Show Printable Version Email this Page

This modification is currently quarantined.
vB Version: 3.8.x Rating: (86 votes - 4.83 average) Installs: 704
Released: 06 Jan 2009 Last Update: 31 Jul 2009 Downloads: 7955
Not Supported DB Changes Uses Plugins Auto-Template Additional Files External Content Is in Beta Stage  

This mod has been rewritten for vB4x here: http://www.vbulletin.org/forum/showthread.php?t=240677

This modification is based on the Video-Directory modification by Survivor and vBPoint.org.
His mod is NOT dead, its still alive and kicking; but he has informed me that he just doesn't have the time to maintain it and give support. So until he is able to work on it agian; I've been doing a series of updates.

What is this mod?

This mod adds a fully featured and fully integrated video directory archive to your forums. Users can add their favorite videos from their favorite video service to the directory. I only support a few select hosters; but the hoster scripting is XML base, so any user can create their own scripts for any number of hosting services. The old MyVideo and Sevenload scripts from Survivor's version will still work, but they wont pull in Keyword/Tagging information, nor the video length time codes.

Basic Feature Listing:
  • Fully integrated into the vBulletin user database and product manager.
  • Fully phrased and built on templates for easy reskinning and styling.
  • Fully administratable and a myriad of settings for personalization.
  • Complete customization of permissions based on usergroups.
  • Landing page for broad information and fully featured tag cloud.
  • Category profiles for videos.
  • Contribution profiles for users.
  • Keyword profiles for tag cloud.
  • Built in comment system for videos.
  • Search function for titles and descriptions.
  • RSS feed of videos.
Product Demo:
http://www.8wayrun.com/video.php
Installation Procedure:
  1. Upload all files in the "upload" directory to your forum root.
  2. CHMOD /videothumbnails/* and /includes/videoserviceapi to 777.
  3. Import the product "product-videodirectory.xml" in your Product Manager.
  4. Follow the on screen instructions to configure your video hoster settings.
  5. Refresh your administration control panel to see the new navigation links.
NOTES:
vBulletin 3.7.0 instituted a new avatar-thumbnail system. There is a high probability that you are unaware of this new system and may have failed to setup your vBulletin to make use of it. Make sure that a directory called /thumbs is located in your avatar directory and CHMOD it to 777. Then go into Maintenance > Update Counters and run the Rebuild Custom Avatar Thumbnails process.
Upgrade Procedure:
  1. Upload all files in the "upload" directory to your forum root.
  2. Take note of the information stored in Limits of Videos > General Settings.
  3. Import the product "product-videodirectory.xml" in your Product Manager.
  4. Re-establish your previous Limits settings in Videos > General Settings.
  5. Re-import ALL of your hosters and settings in Videos > Manage hosters.
    • You MUST remember to re-import your hosters after upgrading.
NOTES:
You may lose your category dataman when you upgrade. If no categories are listed after an upgrade, you will be required to rebuild your category dataman. Its very easy to rebuild it if you need to. Simply go into Videos > Manage categories, select ANY category and hit [Edit], then click [Save]. Your category dataman will automatically be rebuilt.
Roadmap for the Future:
  • Moderation
  • Favorites
  • Playlists
Don't forget to click INSTALL!

If you want to donate, I'm all for it... as I'm an unemployed computer programmer...

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	video-details.jpg
Views:	5161
Size:	103.4 KB
ID:	91814   Click image for larger version

Name:	video-add.jpg
Views:	4238
Size:	124.8 KB
ID:	91815   Click image for larger version

Name:	video-home.jpg
Views:	5501
Size:	106.7 KB
ID:	91816   Click image for larger version

Name:	admin-settings-general.jpg
Views:	2609
Size:	88.3 KB
ID:	91817  

Click image for larger version

Name:	admin-settings-tags.jpg
Views:	1360
Size:	96.9 KB
ID:	91818   Click image for larger version

Name:	admin-manage-taglist.jpg
Views:	1583
Size:	103.9 KB
ID:	91819   Click image for larger version

Name:	admin-manage-hosters.jpg
Views:	1341
Size:	131.4 KB
ID:	91820   Click image for larger version

Name:	admin-manage-categories.jpg
Views:	1410
Size:	112.8 KB
ID:	91821  

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions Video-Directory Surviver vBulletin 3.7 Add-ons 797 27 Aug 2015 08:26
Video Directory FH List Twilkey vBulletin 3.8 Add-ons 72 22 Dec 2013 20:49
Forum Home Enhancements Video Directory FH List Twilkey vBulletin 3.7 Add-ons 53 27 Sep 2009 05:33

  #241  
Old 14 Jan 2009, 13:56
ArnyVee's Avatar
ArnyVee ArnyVee is offline
 
Join Date: Mar 2008
I had an issue with the thumbnails again this morning. Is there a way to pull just the thumbnails directly from YouTube so that I can just upload the image myself if they are not pulled in the future?

I've got the rewrite off in my .htaccess file for the applicable directory and have the directories CHMOD777 as well. So, it seems like a hit or miss thing with me and maybe when I'm pulling the info, I guess.

It seems to have issues in the morning when I upload videos early. You can see on my forum home listing that the two latest video's thumbnails are not showing.

http://www.waltdisneyboards.com/forums.php
Reply With Quote
  #242  
Old 14 Jan 2009, 14:15
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Originally Posted by ArnyVee View Post
I had an issue with the thumbnails again this morning. Is there a way to pull just the thumbnails directly from YouTube so that I can just upload the image myself if they are not pulled in the future?

I've got the rewrite off in my .htaccess file for the applicable directory and have the directories CHMOD777 as well. So, it seems like a hit or miss thing with me and maybe when I'm pulling the info, I guess.

It seems to have issues in the morning when I upload videos early. You can see on my forum home listing that the two latest video's thumbnails are not showing.

http://www.waltdisneyboards.com/forums.php
The thumbnail file clearly exists... its just a broken image: http://www.waltdisneyboards.com/vide...iuBw_kj1-U.jpg I suggest you take a look at your GD and make sure its working properly.

Originally Posted by Adam21 View Post
I have a request which i think will be useful to all - Have inline deletion of videos. Its abit of hassle to delete them one by one if some of the videos are removed from the hosters.I'm currently using phpmyadmin to delete them.Hope an improvement that allows us to delete the thumbs as well with an inline option.
Deleting a video, already deletes the thumbnail, I fixed that a while back.

Originally Posted by chikkoo View Post
Jaxel,

I appreciate the updates are coming very fast now a days, keep it up buddy.

Is it possible to have the below features in your next update?

1) Option to Display & Hide Video URL, BB Code & Embed Code. (I don't want to show them to all)

2) Option to exclude categories from related video, random video and best rated video.

3) Reported Videos to have a flag or different background color or some distinctive mark, so that admin can easily locate that video.

People are reporting some videos are removed by the Hostor, but still appearing in everywhere, that doesn't make sense to keep in the main directory.
1 - I'll get working on this...
2 - I see no reason for this, so I wont be working on it.
3 - doesn't the report link have a direct link to the video?

Originally Posted by chikkoo View Post
I have already asked this before. Seems no one has made yet.

Also is that BB Code produced is working for every1? For me not working.
It only works if you have the BB code setup on your forums.

Originally Posted by aseer_al7ob View Post
Hello Jaxel

Can you add this site to the list of sites hoster

http://clipat.maktoob.com/

Thank you
Unless the site has a publicly available API, I cant add it.
Reply With Quote
  #243  
Old 14 Jan 2009, 14:36
ArnyVee's Avatar
ArnyVee ArnyVee is offline
 
Join Date: Mar 2008
Originally Posted by Jaxel View Post
The thumbnail file clearly exists... its just a broken image: http://www.waltdisneyboards.com/vide...iuBw_kj1-U.jpg I suggest you take a look at your GD and make sure its working properly.
Aha! Found the issue!

After searching the internet for a bit and finding the URL for a thumbnail image on YouTube (which is http://img.youtube.com/vi/VIDEO_ID/default.jpg and just replace the VIDEO_ID with the actual ID of the video you are looking to grab the thumbnail from) and trying to upload it on my own, it wouldn't overwrite the file. Well, I had temporarily run out of disk space on that server!

So, now all is well. I'm just going to grab those couple of thumbnails so I don't have to delete the 'old' video and then do another new video.
Reply With Quote
  #244  
Old 14 Jan 2009, 15:19
Jaxel Jaxel is offline
 
Join Date: Sep 2005
===========================================================
Version 1.2.0
===========================================================
  • Extended support for RSS Feeds and tagging while viewing video details.
    • Now when you few video details, ALL tag RSS feeds will be selectable.
  • Added the option to turn off text fields for URL, BB Codes and Embed Codes.
    • These settings are in the settings of each individual video-hoster xml file.
    • Because of this, you MUST upgrade all your video-hosters to the 1.2.0 version.
    • No video-hosters prior to version 1.2.0 will function with this version.
    • You MUST remember to re-import all of your video hosters after upgrading.
  • FILE EDITS SINCE 1.1.9: (make sure you upload these new versions!)
    • upload/video.php
    • upload/includes/xml/videohoster-Dailymotion.xml
    • upload/includes/xml/videohoster-Metacafe.xml
    • upload/includes/xml/videohoster-YouTube.xml
    • upload/includes/xml/videohoster-YouTubeHD.xml
  • TEMPLATE EDITS SINCE 1.1.9: (make sure you revert these templates!)
    • VIDEO_SHELL
    • video_details
Reply With Quote
  #245  
Old 14 Jan 2009, 17:52
chikkoo chikkoo is offline
 
Join Date: Mar 2005
Originally Posted by Jaxel View Post
3) Reported Videos to have a flag or different background color or some distinctive mark, so that admin can easily locate that video.
3 - doesn't the report link have a direct link to the video?

Also is that BB Code produced is working for every1? For me not working.
It only works if you have the BB code setup on your forums.
Hi.. Jaxel,

Thanks for considering my request and giving an update soooo quick.

The reported video have a direct link in the thread. But what happens in when as an Admin you look at the Video Directory section, that we can't make out which are the file videos listed are already reported, that needs to be corrected or deleted.

With regard to BB code, I am already using a [media] tag for youtube. Do you mind telling how to setup to make it work with your BBcode (for youtube, metacafe & dailymotion).

Thanks, once again.
Reply With Quote
  #246  
Old 14 Jan 2009, 18:05
RS25com RS25com is offline
 
Join Date: Dec 2001
I just updated from 1.6 (I think) to the latest version 1.2 on VB 3.8 and now I get this error when trying to view a video:

Fatal error: Call to undefined method vB_VideoSharingService_YouTube::fetch_showurl() in /home/pippimps/public_html/forums/video.php on line 492

And suggestions?

-----------

Nevermind, I am an idiot.

SOLUTION: After upgrading, go to Video Directory - Manager Hoster - Click "Import Video-Hoster" - browse to install folder (VidDirRx-1.2.0\upload\includes\xml) and install the XML files for each hoster and set the settings.


Last edited by RS25com; 14 Jan 2009 at 18:15.
Reply With Quote
  #247  
Old 14 Jan 2009, 18:17
RS25com RS25com is offline
 
Join Date: Dec 2001
Feature request - the ability to re-order videos in the system.

Right now I have a few videos such as Part 1, Part 2, and Part 3, but they are out of order. It would be nice to be able to re-organize them if needed.
Reply With Quote
  #248  
Old 14 Jan 2009, 18:55
Spicey LA Spicey LA is offline
 
Join Date: Jul 2008
Real name: Lisa Scerina Harris
Can someone please help me with this -

I get this error message when uploading or adding new videos:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Thanx in advance
Reply With Quote
  #249  
Old 14 Jan 2009, 18:57
bugzy bugzy is offline
 
Join Date: Jul 2004
I read through the thread with 1.4.x and 1.6.x

whats the latest version?
Reply With Quote
  #250  
Old 14 Jan 2009, 19:03
Spicey LA Spicey LA is offline
 
Join Date: Jul 2008
Real name: Lisa Scerina Harris
whenever adding a video and it is adding - I keep gettin a permission denied errror message for following file [path]/includes/videoserviceapi/class_youtube.php

Can someone please help me? thanx in advance
Reply With Quote
  #251  
Old 14 Jan 2009, 19:09
Jaxel Jaxel is offline
 
Join Date: Sep 2005
Originally Posted by Spicey LA View Post
Can someone please help me with this -

I get this error message when uploading or adding new videos:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Thanx in advance
Try removing the &eurl and on from your link
Originally Posted by Spicey LA View Post
whenever adding a video and it is adding - I keep gettin a permission denied errror message for following file [path]/includes/videoserviceapi/class_youtube.php

Can someone please help me? thanx in advance
CHMOD 777 that directory and your thumbnails directories.

Last edited by Jaxel; 14 Jan 2009 at 19:16.
Reply With Quote
  #252  
Old 14 Jan 2009, 21:42
Adam21 Adam21 is offline
 
Join Date: Apr 2005
Hi Jaxel.I mean could we have an inline mass-delete videos option?
Reply With Quote
  #253  
Old 14 Jan 2009, 22:21
SnowBot's Avatar
SnowBot SnowBot is offline
 
Join Date: Jul 2003
Real name: Snowy
OK i imported the new product fule, re saved settings (no additional hosters) and when i click a video i get a blank white page.....

Also in admincp > video directory > general settings : nothing happens.
__________________
A Disability Chat Community
Reply With Quote
  #254  
Old 14 Jan 2009, 22:32
RS25com RS25com is offline
 
Join Date: Dec 2001
Did you re-import the hoster files, like I had to a few posts back?
Reply With Quote
  #255  
Old 14 Jan 2009, 22:37
SnowBot's Avatar
SnowBot SnowBot is offline
 
Join Date: Jul 2003
Real name: Snowy
AAHH sorry missed that.

OK that fixed the watching of the videos but not the admin menu.
__________________
A Disability Chat Community
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:33.

Layout Options | Width: Wide Color: