Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Attachments as files Details »
Attachments as files
Mod Version: 1.00, by Scott MacVicar (Member) Scott MacVicar is offline
Developer Last Online: Mar 2016 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 2.2.x Rating: (2 votes - 5.00 average) Installs: 121
Released: 18 Feb 2002 Last Update: Never Downloads: 17
Not Supported  

Well after alot of time leaving it in the beta hacks forums without any problems, I'm now moving it to the Full Releases, I'm satisfied that there isn't any bugs that need to be addressed. Thanks to Jawelin he pointed out most of the mistakes through alot of his testing.
I've attached it as an installer file here, as it needs to make changes to the database. Two new rows to settings and a new column in the attachment table.

Scott

Updated some more

Note the > is missing off the bottom of the file after the ?, add it before trying to install

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Major Additions Files Upload Center - Upload Your Files To External Server beebi Modification Graveyard 328 01 May 2009 07:07

  #256  
Old 22 Nov 2002, 09:05
Areku Areku is offline
 
Join Date: Feb 2002
Rolodex, what do you need?

I still need to uninstall this mod.

Any1?
Reply With Quote
  #257  
Old 23 Nov 2002, 23:26
Exo's Avatar
Exo Exo is offline
 
Join Date: Nov 2001
super my backup does not work because its too big!
Reply With Quote
  #258  
Old 24 Nov 2002, 17:35
Bison's Avatar
Bison Bison is offline
 
Join Date: Jun 2002
Originally posted by Areku
Rolodex, what do you need?

I still need to uninstall this mod.

Any1?
I was mentioning if you get your board attachments to work after uninstalling this hack, please let me know what you did t do it! ~
Reply With Quote
  #259  
Old 30 Nov 2002, 10:03
The Ghost's Avatar
The Ghost The Ghost is offline
 
Join Date: Feb 2002
hi,

I want to Display the Attachments Size in the posts under the counter.

How could I do this?

thx, great Hack!
Reply With Quote
  #260  
Old 01 Dec 2002, 02:43
linesider linesider is offline
 
Join Date: Dec 2001
Can somebody with this hack working send me a copy of their functions.php so I can compare it to what I have going?

Thanks....
Reply With Quote
  #261  
Old 03 Dec 2002, 17:32
fury's Avatar
fury fury is offline
 
Join Date: Oct 2001
Question: how easy would it be to modify the attachments database and this hack to allow up to 3 attachments per post, and be easy to convert from a userid_dateline.extension filename format?

I want to know because I'm planning on converting a phpBB board to vBulletin, but the attachment hack I installed on the phpBB allows up to 3 attachments per post, and vBulletin by default doesn't.
__________________
Rise of Tyrants... it won't cook your breakfast, but you'll wonder how you ever lived without it
Reply With Quote
  #262  
Old 05 Dec 2002, 15:10
Prince Prince is offline
 
Join Date: Oct 2001
Question

Does this hack work with vB 2.2.9?

and can someone please briefly explain what the install does?

does it take all existing file attachments out of your vB database and make them files?
__________________
www.ironmagazineforums.com
Reply With Quote
  #263  
Old 14 Dec 2002, 21:42
Craigr's Avatar
Craigr Craigr is offline
 
Join Date: May 2002
Real name: Craig
Originally posted by Prince
Does this hack work with vB 2.2.9?

and can someone please briefly explain what the install does?

does it take all existing file attachments out of your vB database and make them files?
Well i was for installing it on 2.2.9, but i couldn't find the code in attachments.php you're supposed to replace!

Craig
Reply With Quote
  #264  
Old 15 Dec 2002, 03:37
wolffenstein's Avatar
wolffenstein wolffenstein is offline
 
Join Date: Jul 2002
installed on my testing board, running 2.2.9. ran fine.

the install file, when viewed with your browser, helps install the hack by making modifications to the database for you, and pointing out which files to modify in an "easy way." place it in your admin folder, as it requires admin access to install.

it can import (read: copy, but not delete) files from the database.

the attachments.php with proper code is in your forums' root directory. the attachments.php in the admin folder does not have the necessary coding. yes, those instructions weren't perfectly clear at first, but read all instructions before proceding, common sense should dictate. you'll notice you have to make modifications to files in the mod and admin folders, and thus, they're located in the mod/ and admin/ folders.

however, the instructions have a slight typo, though i think the reason lies within changes to vb since 2.2.3. the second instructions for the admin/functions.php file (don't mistake this for admin/adminfunctions.php like i did) have this code:
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

wheras function.php has:
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

simply, "attachmentid" and "NOT" are reversed. i wouldn't imagine this to be any problem whatsoever. i've attached the installer file with the proper change for versions 2.2.7 and above (2.2.7 change log: "Admin/functions.php; fixed a bug causing attachments used as references to be deleted when they shouldn't be").
Attached Files
File Type: php attachment_install.php (20.5 KB, 54 views)

Last edited by wolffenstein; 15 Dec 2002 at 03:45.
Reply With Quote
  #265  
Old 03 Jan 2003, 23:33
Danny Danny is offline
 
Join Date: Dec 2001
it does work fine, but I have now upgraded to vb2.2.9 and unfortunately when i try and change a user from one group to another group using the control panel i get an error in the user.php file, this error does not appear when no hacks are installed.

Database error in vBulletin Control Panel 2.2.9:

Invalid SQL: UPDATE user SET birthday='0000-00-00',options='14',usergroupid='15',username='margaret
vasey',email='email@email.com',styleid='1',parentemail='n/a',coppauser=1,homepage='http://',icq='',aim='',yahoo='',signature='',adminemail=1,showemail=0,invisible=1,usert itle='Member',customtitle=0,joindate=UNIX_TIMESTAMP('2002-09-06
15:07:30'),cookieuser=1,nosessionhash=,daysprune='-1',lastvisit=UNIX_TIMESTAMP('2002-09-06
15:07:30'),lastactivity=UNIX_TIMESTAMP('2002-09-06 15:18:27'),lastpost=UNIX_TIMESTAMP('1970-01-01
01:00:00'),posts='0',timezoneoffset='0',emailnotification=1,receivepm='0',emailo npm='1',ipaddress='-1',pmpopup=IF(pmpopup=2 AND
1=1,pmpopup,'1') WHERE userid=270
mysql error: You have an error in your SQL syntax near 'daysprune='-1',lastvisit=UNIX_TIMESTAMP('2002-09-06
15:07:30'),lastactivity=UNIX' at line 1

mysql error number: 1064

Date: Friday 03rd of January 2003 08:52:07 PM
Script: http://www.golden-springs.com/forums...admin/user.php
Referer: http://golden-springs.com/forums/adm...dit&userid=270
Reply With Quote
  #266  
Old 05 Jan 2003, 19:37
mv540 mv540 is offline
 
Join Date: Sep 2002
Hi guys, I need some quick help. I have installed this hack on a 2.2.9 board and everythijng seemed to work fine. It seems now that only mods and admins can view forums or search.
Here's the error.

Fatal error: Call to undefined function: getmodpermissions() in /home/hsphere/local/home/ital911/dss-power.com/forums/admin/functions.php on line 1758

Thanks

regular members get this error when they actually click on a forum or clich the vew newest possts, which I have set to get daily..

Last edited by mv540; 05 Jan 2003 at 19:45.
Reply With Quote
  #267  
Old 06 Jan 2003, 07:45
Danny Danny is offline
 
Join Date: Dec 2001
Originally posted by mv540
Hi guys, I need some quick help. I have installed this hack on a 2.2.9 board and everythijng seemed to work fine. It seems now that only mods and admins can view forums or search.
Here's the error.

Fatal error: Call to undefined function: getmodpermissions() in /home/hsphere/local/home/ital911/dss-power.com/forums/admin/functions.php on line 1758

Thanks

regular members get this error when they actually click on a forum or clich the vew newest possts, which I have set to get daily..
you have hacked the functions.php file incorrectly delete it and start over again, I have hacked my 2.2.9 board with this hack and everything is fine.

my above post was a bug in 2.2.9 which is fixed now.
Reply With Quote
  #268  
Old 10 Jan 2003, 12:12
Areku Areku is offline
 
Join Date: Feb 2002
Hi!

I recently uninstalled this hack off from my board, but I must have forgotten to change something in editpost.php since now, everytime i try to delete ANY post (doesnt matter if it contains an attachment or not) or try to delete any attached file, I get the following error:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The error does NOT appear if I just edit the text of the post and submit changes.


Can any1 help out??
Reply With Quote
  #269  
Old 13 Jan 2003, 10:14
Areku Areku is offline
 
Join Date: Feb 2002
Further exploring functions.php I found the responsible (I think it's the responsible for the error):


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

However, what should I do with this routine that's causing problems ONLY with editpost.php? If I delete it I'm sure a new problem will arise, right?


I might think of a database not so well written or some sort of column is superfluous, but I'm stucked, what shall I do now?

THanks!!!
Reply With Quote
  #270  
Old 26 Jan 2003, 03:00
Mustang5ohhh Mustang5ohhh is offline
 
Join Date: Dec 2002
I'm getting the same error as above when I go to delete a thread with an attachment. Any updates ?

Next ... I'm sort of new to the vB thing ... I've installed the hack and with a few minor problems that I worked out ... it "seems" to be working. The whole problem is that I'm not sure if it is working right. Using Telnet I connect to MySQL and I still see the attachment tables:

1. Am I supposed to?
2. The filedata column has nothing in it ... does that mean that it worked and the file is out in the directory?
3. Is there a querie I can run to see if that it is indeed working?

Sorry about so many questions ... I went to the MySQL site but ... I'm not that advanced yet ... I need laymans terms to get me through this.

Thanks in advance.

M
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:33.

Layout Options | Width: Wide Color: