Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 09 Feb 2011, 00:01
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
Too many connections MYSQL

Hello,
I am having anywhere from 1 to 3 a day where my server bombs out for a few minutes. My site seems slow sometimes as well. Started a couple weeks ago. I contacted my host they reset the server but didn't do any good. The file that each error references changes all the time. Though I do see more external.php RSS files for about 1 out of every 5. Any ideas on how to figure out what is going on.

mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections ......./includes/class_core.php on line 311

It also says I have alot of guests. How many is to many and would this cause it? I don't know if I really believe there are that many guests, so could it be search engines causing server load?

Thanks to anyone that can shed some light or help point me in the right direction.
Jamey

Last edited by jpietrowiak; 09 Feb 2011 at 00:40.
Reply With Quote
  #2  
Old 09 Feb 2011, 01:01
KevinL KevinL is offline
 
Join Date: Apr 2005
Either upgrade to a VPS or a better shared hosting environment.

I would say another shared environment depending on how busy your actual site is.

Can we have a link to the site?
Reply With Quote
  #3  
Old 09 Feb 2011, 01:20
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
Sorry here is the vbulletin URL for the CNC Professional Forum

I tried a VPS once when it was hosted at Dreamhost. I had to keep sliding the slider for memory and it was at $50 a month and still was not enough. I requested to go back to shared hosting since I did not have any problems there and it was alot less. I only upgraded at the time because I wanted it to be as fast as it could be. Didn't think it would cost that much. Now I am on Gatorhost. Have not had any problems until the last 3 weeks. No major upgrades either, so its kindof odd. Just wondering if it was hacked or something. Also I do not archive any old posts so would this also be a possible cause?
Reply With Quote
  #4  
Old 11 Feb 2011, 17:07
benstillman benstillman is offline
 
Join Date: Jun 2007
Real name: Ben
What is max_connections set at? Sounds like it's probably too low.
__________________
Reply With Quote
  #5  
Old 11 Feb 2011, 19:02
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
Thanks, Where would I find that? I tried looking through my control panel but can't seem to find it. I looked in the PHP.ini EZ config which is where I thought it should be.

Also I noticed a setting "Add No-Cache HTTP Headers" and I have this set to yes. Would this be an option to maybe help and if so would that cause my visitors not to see new posts made to threads if they viewed that thread previously?
Reply With Quote
  #6  
Old 12 Feb 2011, 01:52
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
I believe Hostgator has a fixed max 25 mysql connections for shared hosting. That should be okay for up to maybe 75 concurrent users depending what they're doing.

BTW, I too have been seeing "Guest attacks" recently, with 10X the normal number of them, all from different places doing different things.
Reply With Quote
  #7  
Old 12 Feb 2011, 03:18
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Hostgator won't up it from 25 on shared hosting. They blame it on vb.
Reply With Quote
  #8  
Old 14 Feb 2011, 20:07
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
I wonder what is going on with all the guest attacks, thats interesting! Still have not gotten it figured out. I tried a few different things in Vb over the past few days but nothing made a difference. I am trying to turn off the "Add No-Cache HTTP Headers" today to see what happens if anything. I am shooting in the wind right now.
Reply With Quote
  #9  
Old 14 Feb 2011, 20:15
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
I suppose we're not off topic here, because clearly an overload of guests would throw him over the 25 mysql limit.

The only odd thing I saw in my referrers was 100X the number from mikle.com (feedwind) (about 30,000 to the next one, Facebook with about 400). So, shooting in the dark as well, I've excised my feedwind blocks; we'll see how it goes.
Reply With Quote
  #10  
Old 17 Feb 2011, 03:09
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
Well after turning off the "Add No-Cache HTTP Headers" I still am getting about 3 time outs today. So I am at a loss on what else to do at this time. Anyone have any more ideas?
Reply With Quote
  #11  
Old 17 Feb 2011, 03:59
Zachariah's Avatar
Zachariah Zachariah is offline
 
Join Date: Feb 2002
Location: Canoga Park, CA
http://www.vbulletin.org/forum/showthread.php?t=204842
__________________
http://www.szone.us |

Facebook | My:Hacks @ vBulletin.org
Reply With Quote
  #12  
Old 17 Feb 2011, 04:35
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
Hi Zachariah,
Thanks for the info Zachariah. I just implemented it and the forum is now very speedy. Definitely a noticeable improvement. Hopefully this will take care of it. I will let you all know after a couple days.

Thanks
Reply With Quote
  #13  
Old 17 Feb 2011, 05:08
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Wow, talk about a clear violation. Your host isn't limiting you to 25 connections per user, but 25 connections per account. You may be able to fool them for a while, I don't know. But I do know that instead of trying to solve the problem you're just trying to implement a clever (but illegal) workaround.
Reply With Quote
  #14  
Old 17 Feb 2011, 18:15
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
Violation probably is not a good thing. I did implement it but received two errors over the night, so it really did not fix the problem though it does really seem faster.

One thing I forgot about was that I did have to increase my bandwidth setting in the reseller account last month as well. So there was definitely a spike in traffic or something.

So now not sure what to do? Is there a setting or script to slow down search index bots? I thought I remember seeing something on this. Though I do not know if thats a good idea since it could hurt SEO.
Reply With Quote
  #15  
Old 18 Feb 2011, 19:12
jpietrowiak jpietrowiak is offline
 
Join Date: Dec 2008
ok its been a whole day and a half and no errors. Its been averaging 3 a day for past couple weeks. The last thing I did was Moderated link backs and I deleted 38 pages of them whether right or wrong. The best I could find is that you should have at most 10 websites in there. Think this would really have anything to do with it or is this just coincidence?
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 11:31.

Layout Options | Width: Wide Color: