Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Multiple Account Detection & Prevention Details »
Multiple Account Detection & Prevention
Mod Version: 1.1.3, by Kiros72 (Member) Kiros72 is offline
Developer Last Online: Sep 2013 I like it Show Printable Version Email this Page

vB Version: 3.7.x Rating: (87 votes - 4.87 average) Installs: 1036
Released: 17 Dec 2008 Last Update: 01 Apr 2009 Downloads: 5765
Not Supported Uses Plugins Additional Files Translations  

It happens all of the time. Some members will make multiple accounts to back their own opinion or get an extra vote in a poll. Here's a modification that will detect and prevent multiple accounts, as well as notify the administration about multiple accounts. Inspiration for this modification came from the work of MPDev (creator of the Multiple Account Login Detector) and randominity (creator of the Multiple Account Registration Prevention). This is basically a combination of those two modifications but with new and improved functionality.

This is not an update to the "Multiple Account Login Detector (AE Detector)" nor is it an update to the "Multiple Account Registration Prevention." If you have either one of these (or both of them) installed, you should uninstall them before installing this modification.

With the initial release of Multiple Account Detection & Prevention, I believe that I have fixed previous bugs/complications as well as improved the efficiency and logic of the code. This is my first publicly released modification. I would appreciate any comments and suggestions!

Confirmed! This works perfectly on all vBulletin 3.6, 3.7, and 3.8 versions.

Unfortunately, I cannot give support right now. I may be able to help periodically, but until my schedule yields some more free time, I won't be much support. Please check back in a week or two.

Basic Details
File Edits: None
Template Edits: None
New Files: 6
Hooks/Plugins: 3
Global Phrases: 36
Install Time: 2 Minutes or Less
Install Difficulty: None, Very Easy

Features and Settings
- Login Detection
- Registration Prevention (Multiple Methods)
- Ignore Child Accounts
- Ignored Users
- Ignored Usergroups
- Ignored ISPs
- Prevention Usergroup
- IP Address Based Prevention
- Extended IP Address Prevention
- IP Address Time Inclusion
- Banned Account Check
- Primary Banned Usergroup
- Cookie Expiration Time
- Cookie Refreshing
- Cookie Name
- Cookie Reset
- Multiple Account Reporter
- Reports via PM
- PM Report Recipients
- Reports via New Thread
- Forum for Report Threads
- Verbose Mode
- BB Codes: LIST, URL, CODE

How it Works
With every newly recognized login/registration, an account-counting cookie is set (or added onto) with the member's User ID. Depending on the settings, Multiple Account Detection & Prevention will analyze the cookie during login/registration to see if there are any multiple accounts.

Login Detection offers cookie-checking and reporting. Registration Prevention offers the same thing, plus more advanced features. First of all, when it prevents an account from registering, it actually moves the registrant to the Prevention Usergroup so that the administration can review the case. This also allows for customized privileges for recognized multiple registrants. Registration Prevention also has IP address detection which finds out just as much information about users. Depending on an administrator's preference, this modification can also reban a new registrant if one of their previous accounts has been banned. In fact, if the administration wishes, multiple registrants can simply be denied registration all together.

Whenever there is a detection/prevention, the modification will report the information to the administration through private messages, a new thread, or both (depending on settings). The Multiple Account Reporter can be any valid user.

Known Issues
- vB Optimise users: Reporting via thread seems to get messed up by vB Optimise, so try reporting via PM instead.
- PhotoPost vBGallery users: The registration handling appears to not work properly when PhotoPost vBGallery is enabled.

From what I can tell, these known clashes have been caused by the other modification's coding. The author of vB Optimise will not even work with me to fix it. Until they improve their coding, I'm not sure if I can do anything about these issues. As far as I know, administrators that do not use the above modifications will not have any problems.

Installation / Upgrade
Unzip the package (madp.zip), upload the files to your forum location, and import the product file (allow overwrite if upgrading). Please read the ReadMe.txt file that is packaged with the modification for more information.

Please remember to mark this modification as installed if you use it!
If you like it, nominate it for the Mod of the Month!

Thank you!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	admincprep.png
Views:	2691
Size:	62.6 KB
ID:	91433   Click image for larger version

Name:	admincpop1.png
Views:	2104
Size:	65.8 KB
ID:	91435   Click image for larger version

Name:	admincpop2.png
Views:	1778
Size:	50.6 KB
ID:	91436   Click image for larger version

Name:	threadregverbose.png
Views:	3835
Size:	40.3 KB
ID:	91480  

Click image for larger version

Name:	threadloginverbose.png
Views:	2816
Size:	34.7 KB
ID:	91481   Click image for larger version

Name:	threadregip_disallow.png
Views:	4163
Size:	83.3 KB
ID:	91482  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Administrative and Maintenance Tools Multiple Account Registration Prevention randominity vBulletin 3.6 Add-ons 123 09 Jun 2011 16:59
Multiple Ips detection luroca vBulletin 3.5 Add-ons 8 28 Apr 2010 10:35
Multiple Account Registration Prevention randominity vBulletin 3.5 Add-ons 4 18 Oct 2006 09:18

  #151  
Old 23 Jan 2009, 23:18
digicom's Avatar
digicom digicom is offline
 
Join Date: Apr 2006
i found out what caused The threads that are being generated that inform me of a detection aren't displaying any information it was vb optimize i unistalled it and its working great again btw i running vb 3.8.0
__________________

Reply With Quote
  #152  
Old 23 Jan 2009, 23:20
azher azher is offline
 
Join Date: Oct 2001
i'm running this just fine with vbOptimise on 3.8. maybe there's something in your vbOptimise settings that's killing it?
__________________
Islamica Community
Reply With Quote
  #153  
Old 24 Jan 2009, 08:48
Kiros72 Kiros72 is offline
 
Join Date: Apr 2006
Real name: Ben Arnett
I see... If anyone with vB Optimise installed could do some investigation to figure out what settings make my modification function improperly, I'd truly appreciate it. If I can find out what is causing it, I may be able to make a workaround for those that desire certain options in vB Optimise.
Reply With Quote
  #154  
Old 24 Jan 2009, 09:09
Kiros72 Kiros72 is offline
 
Join Date: Apr 2006
Real name: Ben Arnett
Originally Posted by azher View Post
i'm running this just fine with vbOptimise on 3.8. maybe there's something in your vbOptimise settings that's killing it?
Hmm... Well, vBulletin.org shows that you have version 1.1.0 installed, not version 1.1.1. Maybe that's the real difference? Would you mind upgrading to see if that causes any issues?
Reply With Quote
  #155  
Old 24 Jan 2009, 20:17
ndahiya ndahiya is offline
 
Join Date: Aug 2004
Running vb 3.8.0 and 1.1.1 of the mod...
Both the message and the post are blank with just underscores... Have turned registration check off. Just using it to check for multiple logins. Do have vb Optimise , but not sure why that should be a trigger.
Reply With Quote
  #156  
Old 25 Jan 2009, 01:41
Kiros72 Kiros72 is offline
 
Join Date: Apr 2006
Real name: Ben Arnett
Evidently it's causing some kind of problem. See if disabling vB Optimise remedies the issue.
Reply With Quote
  #157  
Old 25 Jan 2009, 14:28
digicom's Avatar
digicom digicom is offline
 
Join Date: Apr 2006
disabling doesnt work only unistalling vb optimise allows your mod to then work perfectly

Originally Posted by Kiros72 View Post
Evidently it's causing some kind of problem. See if disabling vB Optimise remedies the issue.
__________________


Last edited by digicom; 25 Jan 2009 at 22:43.
Reply With Quote
  #158  
Old 25 Jan 2009, 15:14
ndahiya ndahiya is offline
 
Join Date: Aug 2004
Disabling vb Optimise does appear to work. VbO is quite helpful otherwise, so maybe we can figure out a way to get it to work?


While the PMs are going ok, the messages are not getting posted to the forum. Not sure why one should work and not the other?

The reporting forum is a subforum inside a parent forum that is visible only to mods/admins. the "reporting user" is a admin.


ndahiya

Last edited by ndahiya; 25 Jan 2009 at 21:23.
Reply With Quote
  #159  
Old 25 Jan 2009, 19:11
masterweb's Avatar
masterweb masterweb is offline
 
Join Date: Aug 2007
Real name: Arteaga
Downloaded and installed, thanks for sharing this hack
Reply With Quote
  #160  
Old 26 Jan 2009, 04:55
Kiros72 Kiros72 is offline
 
Join Date: Apr 2006
Real name: Ben Arnett
Okay, thanks for your input, guys. I'll talk to the author to see if there's a clear cause.
Reply With Quote
  #161  
Old 31 Jan 2009, 16:22
Kiros72 Kiros72 is offline
 
Join Date: Apr 2006
Real name: Ben Arnett
Sorry. I haven't received a response from the author of vB Optimise. I'll start looking into it myself. Until a solution is found, either keep vB Optimise disabled or disable reporting via new threads.
Reply With Quote
  #162  
Old 07 Feb 2009, 22:23
azher azher is offline
 
Join Date: Oct 2001
hey kiros,

sorry for the lag....i haven't upgraded to 1.1.1 but i'm noticing that on 1.1.0, it's sporadically posting blanks (or underscores, as the case may be). sometimes, however, it's working perfectly fine. disabling vboptimise seems to fix it but i'd honestly rather have this working partially with vbOptimise than disabling it entirely.
__________________
Islamica Community
Reply With Quote
  #163  
Old 09 Feb 2009, 18:45
Zagis Zagis is offline
 
Join Date: Jun 2006
Hi there

I have a few members moved to prevention group but I got no notification about them. I just found them in the prevention group. What are these members? Why I'm not getting a pm about these member?

Note that I'm getting notifications about multiple registrants and these users are getting moved to the prevention group without problems.
__________________

Reply With Quote
  #164  
Old 10 Feb 2009, 16:19
indocm indocm is offline
 
Join Date: Jan 2008
help me
after installing the mod it seem user can't login and appear "
Warning: require_once([path]/madp/detection.php) [function.require-once]: failed to open stream: No such file or directory in [path]/includes/functions_login.php(185) : eval()'d code on line 3

Fatal error: require_once() [function.require]: Failed opening required '/home2/lintasca/public_html/forum/madp/detection.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/lintasca/public_html/forum/includes/functions_login.php(185) : eval()'d code on line 3"
Reply With Quote
  #165  
Old 11 Feb 2009, 05:02
shooter83 shooter83 is offline
 
Join Date: Dec 2004
Originally Posted by indocm View Post
help me
after installing the mod it seem user can't login and appear "
Warning: require_once([path]/madp/detection.php) [function.require-once]: failed to open stream: No such file or directory in [path]/includes/functions_login.php(185) : eval()'d code on line 3

Fatal error: require_once() [function.require]: Failed opening required '/home2/lintasca/public_html/forum/madp/detection.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/lintasca/public_html/forum/includes/functions_login.php(185) : eval()'d code on line 3"
i had the same problem, until i realized my ftp software did not upload "detection.php"

i was having a freak out session when i could not login to the admincp!

make sure you uploaded the contents of the 'upload' folder to your forum's root.
(If your forum's location is http://www.example.com/forums/, the root is /forums/)

Last edited by shooter83; 11 Feb 2009 at 05:25.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:16.

Layout Options | Width: Wide Color: