Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 17 Nov 2014, 00:50
OUTL4W OUTL4W is offline
 
Join Date: May 2013
RSS poster bot fatal error

I keep running into this fatal error below when trying to run the rss psoter bot task.



Fatal error: Call to a member function query_first() on a non-object in /home/public_html/includes/class_bootstrap.php(103) : eval()'d code on line 3
Reply With Quote
  #2  
Old 17 Nov 2014, 05:21
kh99 kh99 is offline
 
Join Date: Aug 2009
Real name: Kevin
That line is where the hook global_bootstrap_init_start is executed, so the problem is in a plugin using that hook location. I'm not sure why it would only happen when you run the rss poster task, that seems strange.
Reply With Quote
  #3  
Old 18 Nov 2014, 11:46
OUTL4W OUTL4W is offline
 
Join Date: May 2013
Originally Posted by kh99 View Post
That line is where the hook global_bootstrap_init_start is executed, so the problem is in a plugin using that hook location. I'm not sure why it would only happen when you run the rss poster task, that seems strange.
not sure why either....when clicking "preview feed" within the feed, everything works fine but when running it manually I get the above error.
Reply With Quote
  #4  
Old 02 Feb 2015, 03:02
OUTL4W OUTL4W is offline
 
Join Date: May 2013
I finally took the plunge and upgraded to 4.2.2 pl3 ran into the time zone issue which I finally fixed...but I am still having this posterbot issue.
Reply With Quote
  #5  
Old 02 Feb 2015, 10:38
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Jul 2009
Real name: Chris
Lets do this, disable plugins via the includes/config.php file.

To do that open your includes/config.php file and below <?php add the following.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

So it looks like this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Use a editor like notepad++ to edit any files, don't use Notepad or Wordpad.

If that fixes the issue enable plugins again by adding // before the line you added, then navigate to ACP --> Plugins & Products --> Manage Products and disable one mod at a time until you find the one causing the issue.

Once you find the culprit, post in that mods thread what the issue is, and maybe someone in that thread can help.
__________________
You can get access to my 180 mods for vB 3.6 - 4.x at The Admin Zone as well as the professional support you are used to. New vBulletin Spider Definitions, vBulletin Spiders List Hits 1000 Spiders! ​ OzzModz down. Site has had a data breach, checking how the intrusion happened. Change your PW if you use the same one on my site and others.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 11:07.

Layout Options | Width: Wide Color: