Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Restrict Style to Usergroup Details »
Restrict Style to Usergroup
Mod Version: 1.0.4, by Andreas (Coder) Andreas is offline
Developer Last Online: Mar 2019 I like it Show Printable Version Email this Page

vB Version: 4.2.0 Rating: (13 votes - 4.54 average) Installs: 273
Released: 09 Sep 2005 Last Update: 29 May 2012 Downloads: 1232
Not Supported DB Changes Uses Plugins  

Restrict Style to Usergroup(s)

Description
This Hack allows you to restrict styles to certain usergroups.

Details
1 Product XML (4 Plugins, 1 Phrase).

Screenshot (from the 3.0 Version; very similar): http://www.vbulletin.org/forum/attac...chmentid=26703

History
1.0.0
Initial Version

1.0.1
Slight Bugfix regarding secondary Usergroups not working properly

1.0.2
Converted to a Product; no more file edits necessary

1.0.3
Fixed a Bug that caused this Hack to not work at all

1.0.4
Compatibility Update for vBulletin 4.1.11+

Compatibility
This Add-on is compatible with vBulletin 3.5.X, 3.6.X, 3.7.X, 3.8.X, 4.0.X, 4.1.X and 4.2.0

Attention: This Hack does not work with Show Users using Style in Style Chooser

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Restrict style to Usergroup Andreas vBulletin 3.0 Full Releases 68 06 Aug 2006 19:20

  #106  
Old 14 Sep 2009, 19:00
Keesa Keesa is offline
 
Join Date: Oct 2007
I do not understand how this is supposed to work. I have restricted one style so only certain usergroups can use it, but it still shows to unregistered users.

Hmmmmmmm.
Reply With Quote
  #107  
Old 28 Nov 2009, 09:16
Mosh's Avatar
Mosh Mosh is offline
 
Join Date: Aug 2004
Location: Melbourne, Australia
Real name: Mosh Shigdar
This hack works with vBulletin v4.0.0 Beta 3 and 4

It is bloody amazing, this hack has been working faithfully for me since v3.5.x (over 4 years ago), which is why this my favourite hack
__________________
-- The WS Spiders List is still downloadable from vBulletin.com.
-- As of Monday 1st July 2013, I will no longer be supporting my hacks as I am leaving the vBulletin community due to medical and life-style reasons.
Reply With Quote
  #108  
Old 26 Dec 2009, 21:43
Big Kahuna's Avatar
Big Kahuna Big Kahuna is offline
 
Join Date: Feb 2002
This is just what I was looking for. over the last 8 years I've developed about ten styles -- and every time I'd delete one I thought wasn't being used -- everyone screamed. I use this hack so that the non-paying members get the default style -- while the premium members get their choice of a dozen or so.
__________________
Reply With Quote
  #109  
Old 07 Apr 2010, 12:13
nefarious nefarious is offline
 
Join Date: Jan 2003
I have this installed and running so that premium members can use the mobile skin... and it appears to work on most devices, but some Blackberry users can't even see the quick chooser and when given the direct URL to change the skin they are still reverted back to the default skin.

Anyone encountered this or can think of a way for this to work with Blackberry - or is it an inherent Blackberry problem that can't be resolved?

We are currently using 3.7.4
Reply With Quote
  #110  
Old 07 Apr 2010, 12:30
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
Easy test: Disable this Add-on, if they still can't use the style afterwards it's not a problem with this Add-on
Reply With Quote
  #111  
Old 07 Apr 2010, 12:58
nefarious nefarious is offline
 
Join Date: Jan 2003
That was my first thought... I've already asked a user having problems to let me know when they are online so we can test it.
Reply With Quote
  #112  
Old 29 Aug 2010, 00:54
Snug Snug is offline
 
Join Date: Aug 2009
when ever i add it to my skin it combines two of the skins... weird
Reply With Quote
  #113  
Old 03 Mar 2011, 10:35
Alfa1's Avatar
Alfa1 Alfa1 is offline
 
Join Date: Dec 2005
This addon seems to be causing the following error:

Warning: Invalid argument supplied for foreach() in /forum/global.php(238) : eval()'d code on line 275

Fatal error: Cannot use string offset as an array in /forum/global.php(355) : eval()'d code on line 428
Its weird because I have been using this addon for years without problems. We recently updated to the latest version of php, xcache, apache, etc. So maybe that changed something.
Do you have any idea how to fix this?
Reply With Quote
  #114  
Old 16 May 2011, 03:54
baileyjojoms baileyjojoms is offline
 
Join Date: Mar 2011
Installed and using on 4.1.3
Reply With Quote
  #115  
Old 03 Aug 2011, 16:43
mrderanged mrderanged is offline
 
Join Date: Jul 2002
I'm trying to test this on a closed board right now. Are admins exempt from style permissions? I ask because I set a skin to be accessible only to a paid group and as an admin I'm still able to access it.

Regards
Reply With Quote
  #116  
Old 22 Oct 2011, 00:41
Jman423's Avatar
Jman423 Jman423 is offline
 
Join Date: Jan 2008
I just installed this on 4.1.5 PL1 and it seems to be working just fine.
Reply With Quote
  #117  
Old 01 Nov 2011, 11:15
dspalton dspalton is offline
 
Join Date: Jun 2008
Real name: David
any idea if this is supported in 4.1.7?
We have it working on most browsers other that good old IE 8 + 9

David
Reply With Quote
  #118  
Old 11 Mar 2012, 18:21
fulviods fulviods is offline
 
Join Date: Jan 2005
Originally Posted by Alfa1 View Post
This addon seems to be causing the following error:


Its weird because I have been using this addon for years without problems. We recently updated to the latest version of php, xcache, apache, etc. So maybe that changed something.
Do you have any idea how to fix this?
I have the same problem, so i had to uninstall it
Reply With Quote
  #119  
Old 02 May 2012, 09:32
THX_Ultra THX_Ultra is offline
 
Join Date: Jan 2010
This is a great an extremely useful add-on - but when I install it in 4.1.12 - i get an error message

Warnung: Invalid argument supplied for foreach() in [path]/includes/class_bootstrap.php(999) : eval()'d code (Zeile 6)
Any chance to get that running with 4.1.12?

Or are there any alternatives - because it would be extremely useful for us. We have usergroups where we'd like to restrict the usage of certain styles.

best regards Michael
Reply With Quote
  #120  
Old 29 May 2012, 11:47
THX_Ultra THX_Ultra is offline
 
Join Date: Jan 2010
Any news on that? Especially 4.2.0 has been released.

Doesn't seem to be developed anymore, or am I wrong?

Any help would be greatly appreciated
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 05:29.

Layout Options | Width: Wide Color: