Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Rename register.php by BOP5 Details »
Rename register.php by BOP5
Mod Version: 1.1.5, by BirdOPrey5 (IB Staff) BirdOPrey5 is offline
Developer Last Online: Mar 2019 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (35 votes - 4.91 average) Installs: 267
Released: 04 May 2013 Last Update: 09 May 2013 Downloads: 917
Supported Uses Plugins Code Changes  

Brought to you by BirdOPrey5 / Qapla.com

It's great when you stop spam bots during registration but this mod gives you a chance to stop them BEFORE they even attempt to register.

I have received multiple reports from people who say their "register.php" was getting hammered with spam requests- so much so it was like a denial of service attack. Even if they disabled registration they would waste so much resources their site was slow or worse- had to be taken offline.

What this mod does is allow you to rename the register.php file- my theory is many of the vBulletin spamming bots are hard coded to look for register.php. Using a unique name will throw them off, at least for a while.

To manually change the name of register.php would have meant dozens, maybe hundreds of manual edits to files and templates previously.

This mod makes it as simple as possible. At worst you will need to edit 2 phrases and 1 file, and some people don't need to edit anything at all.

Compatible with VB 3.8.x (and 3.7, and 3.6 probably too) and all VB 4.x.x versions.

Basic Instructions
1) Import XML File
2) Go to mod settings in Admin CP
3) Rename your register.php file via FTP or some other means- make it a unique value but only use basic letters, numbers, underscores, or hyphens. Something like "joeregister999.php"
4) In the mod settings, set the value of register.php to the new file name you chose.
5) If you require email verification during registration follow the next setting in the Admin CP and edit the phrases listed (activateaccount and activateaccount_chnage phrases in Email Body)
6) Finally, if you use Facebook Connect on your forum make the manual file edit of class_bootstrap.php as instructed.

Now enjoy your new filename for register.php, I hope it reduces server load and spam in general.

------------------------------------------------------

Please "Mark as Installed" if you use this.
Donations always appreciated.
Nominate MOTM if you LOVE it!

----

Note- if having problems sending activation codes or other Admin CP related activities use the solution in post #197.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	bop5_rr_settings.jpg
Views:	1292
Size:	78.2 KB
ID:	144820  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #61  
Old 09 Jun 2013, 03:33
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
What VB version are you using?

You sure you have downloaded the latest version of the mod?
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #62  
Old 09 Jun 2013, 05:27
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by BirdOPrey5 View Post
What VB version are you using?
vBulletin 4.2.1

Originally Posted by BirdOPrey5 View Post
You sure you have downloaded the latest version of the mod?
Yes. Version 1.15 installed.
Reply With Quote
  #63  
Old 09 Jun 2013, 12:16
kmplex's Avatar
kmplex kmplex is offline
 
Join Date: Dec 2012
Thank you, signed up for your forum and left a post as well.

- Brian
Reply With Quote
  #64  
Old 09 Jun 2013, 13:49
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by djbaxter View Post
vBulletin 4.2.1



Yes. Version 1.15 installed.
Weird, working ok for me. I added code to fix this issue.


Please do this- in your admin cp, right click on the users link and choose to open in a new window.

Then try sending the codes again.

Let me know the URL in your browser on the smilie page. (you can remove your domain if you want)
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #65  
Old 09 Jun 2013, 15:08
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by BirdOPrey5 View Post
Weird, working ok for me. I added code to fix this issue.


Please do this- in your admin cp, right click on the users link and choose to open in a new window.

Then try sending the codes again.

Let me know the URL in your browser on the smilie page. (you can remove your domain if you want)
I created a new dummy user (me-test) and then selected that new member profile in AdminCP.

I don't have an option to right click "send activation codes" and open in a new tab or window from the button at the top of the AdminCP page.

The button is titled "Email Activation Codes".

Using the Firefox Web Developer: Inspector feature, i can see that this fills in and submits a form. Here's the code:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Notice that it is still referencing register.php although that is no longer the correct name for the file.

1. I do use email verification and have made all the edits in the two indicated phrases.

2. I do not use Facebook Connect.

Last edited by djbaxter; 09 Jun 2013 at 15:19.
Reply With Quote
  #66  
Old 10 Jun 2013, 15:52
RFViet RFViet is offline
 
Join Date: Jan 2006
Hi POB5,
The mod looks interested to me, before installing this mod my question is will it effects vB update since it changes file name register.php ? and how do I uninstall if I won't use it in the future ?
Reply With Quote
  #67  
Old 11 Jun 2013, 09:35
JamesUK JamesUK is offline
 
Join Date: Jul 2004
installed easily and working great, thanks.
I can instantly see a big drop-off in cpu useage on our server (39% of all website traffic has been to our register.php recently!!)
I've put a dummy 'hello world' file in as register.php so the server's not serving up a load of 404s and it all seems happy
thanks again,.
James
Reply With Quote
  #68  
Old 12 Jun 2013, 01:28
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by RFViet View Post
Hi POB5,
The mod looks interested to me, before installing this mod my question is will it effects vB update since it changes file name register.php ? and how do I uninstall if I won't use it in the future ?
After an upgrade you would need to rename register.php again to whatever the custom name you chose is.

If uninstalling just undo whatever manual changes you made. If you manually changed the phrases, change them back. If you manually changed the class_core.php file, change it back. Then just rename the register.php file back to normal and disable/install the mod. It should take just as many steps to install as uninstall.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #69  
Old 12 Jun 2013, 01:33
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by djbaxter View Post
I created a new dummy user (me-test) and then selected that new member profile in AdminCP.

I don't have an option to right click "send activation codes" and open in a new tab or window from the button at the top of the AdminCP page.

The button is titled "Email Activation Codes".

Using the Firefox Web Developer: Inspector feature, i can see that this fills in and submits a form. Here's the code:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Notice that it is still referencing register.php although that is no longer the correct name for the file.

1. I do use email verification and have made all the edits in the two indicated phrases.

2. I do not use Facebook Connect.

Thanks. I can confirm this is working on 4.2.1 on my site, so I assume it must be due to some conflict on yours.

In the drop down menu there should also be an option to email activation codes, can you try there too.

I'm talking about the "Quick User Links" drop down.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #70  
Old 12 Jun 2013, 01:37
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
Originally Posted by BirdOPrey5 View Post
Thanks. I can confirm this is working on 4.2.1 on my site, so I assume it must be due to some conflict on yours.

In the drop down menu there should also be an option to email activation codes, can you try there too.

I'm talking about the "Quick User Links" drop down.
The same thing except it opens a new blank window with the url


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Again, notice it is referencing register.php, not the alternate filename.

I'm not sure what other plug-in could be interfering, or indeed what other plugin I have installed that even references register.php
Reply With Quote
  #71  
Old 12 Jun 2013, 01:45
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
It has nothing to do with register.php in terms of the plugin, in the Admin CP it's working directly on the PHP Output buffer, which I suppose if another mod is doing as well could cause issue.

Please go to the Admin CP -> Plugins & Products -> Plugin Manager

And see if any other plugins are on this hook: useradmin_edit_column2

Hint- if you have a lot of plugins press CTRL+F to open the "Find" function in your browser and paste in the plugin name to quickly search.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #72  
Old 12 Jun 2013, 13:50
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
I did have one. However, I changed that to useradmin_edit_column1 and tried again. Same result.

Is the plugin "Send Activation Code Fix Part I" supposed to be disabled? Not that it made a difference when I enabled it but it seems to be unchecked by default.
Reply With Quote
  #73  
Old 12 Jun 2013, 14:22
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
I just tried this on a different forum with a new registration. There, I get an error message:

Not Found

The requested URL /register.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Reply With Quote
  #74  
Old 12 Jun 2013, 17:32
Disco_Stu's Avatar
Disco_Stu Disco_Stu is offline
 
Join Date: Apr 2012
fyi...had to change the following phrases:

admin_required_register
you_lost_activation_code_or_username
coppa_rules_description
vb3_register
activate_deleterequest
invalidactivateid


and the following templates:

activateform
activate_requestemail

Update:
Seems to be working ok. I was able to register a new user without any issues. The various links are working as well.

Good mod! Thanks. Marking as installed.

Last edited by Disco_Stu; 12 Jun 2013 at 18:00.
Reply With Quote
  #75  
Old 12 Jun 2013, 19:09
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by djbaxter View Post
I did have one. However, I changed that to useradmin_edit_column1 and tried again. Same result.

Is the plugin "Send Activation Code Fix Part I" supposed to be disabled? Not that it made a difference when I enabled it but it seems to be unchecked by default.
I would suggest temporarily disabling the other plugin on the hook.

Yes this mod is supposed to have 1 disabled plugin.

Originally Posted by djbaxter View Post
I just tried this on a different forum with a new registration. There, I get an error message:
Maybe you got a bad copy? Try re-downloadig.
__________________
-Joe
Former vBulletin.org Staff Member

(@BirdOPrey5) Former vb.org Moderator. Fighting for a free & independent vb.org.
BirdOPrey5.com - Exclusive VB Mods! (Formerly Qapla.com) | Joe's Ultimate Off Topic
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:37.

Layout Options | Width: Wide Color: