Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Hide BBCodes/Signatures From Guests/Users Details »
Hide BBCodes/Signatures From Guests/Users
Mod Version: 1.8.1, by MarkFL (Coder) MarkFL is offline
Developer Last Online: Mar 2019 I like it Show Printable Version Email this Page

vB Version: 4.2.x Rating: (3 votes - 4.67 average) Installs: 37
Released: 29 Apr 2015 Last Update: 22 Feb 2017 Downloads: 284
Not Supported Uses Plugins Auto-Template Additional Files Translations  

Overview:

This product will allow you to decide what BBCode content you wish to hide from guests/users on your site. You can also choose to hide user signatures from guests/users too. Hidden content is replaced with a link to your registration page for guests, and a simple message for restricted usergroups. In posts, this link or message is placed inside a block element so that it stands out.

Guests will see the following:



Members of restricted usergroups/users that have not replied will see the following:



You are given the option to merge the defined list of BBCodes in the product "MarkFL: Enhanced View Forum Posts". This way, you may choose to define the list in one place and have both products hide the same BBCodes.

Updates:

Version 1.1:
  • Now allows usergroups to be restricted from seeing the defined list of BBCodes and signatures.

Version 1.2:
  • Posts containing the symbols "<" and/or ">" will now display correctly to those from whom BBCodes are being hidden.

Version 1.3:
  • Fixed bug where the $vbulletin array need to be global for some users.
  • Messages to guests/users now phrased to allow for translations.

Version 1.4:
  • Added setting to allow hiding of BBCodes/Signatures from users until they reply to a thread.

Version 1.5:
  • Added setting for "Active Forums" in which the product is active.
  • Added separate usergroup selection for usergroups whose members must reply to a thread before the hidden BBCodes/signatures are revealed.

Version 1.6:
  • Added setting to allow for internal links to be hidden.

Version 1.7:
  • Added settings to allow individual threads/posts to be ignored by product.

Version 1.8:
  • Fixed reported issue with inline attached images.

Version 1.8.1:
  • Moved function to external script to avoid redeclaration error.

To Install:

1.) Download and extract the attached .zip file.

Upload the contents of the "upload" folder to your forum's root directory.

Note: If you have already installed "MarkFL: Enhanced View Forum Posts" v1.1 or higher, then you may skip this step, since both products use the same external PHP script.

2.) In AdminCP go to Plugins & Products -> Manage Products -> Add/Import Product.

Click on "Choose File" and browse to the product xml file that was packaged in the .zip file.

Click "Import"

You MUST set your settings to enable the mod. Each setting has an explanation of its use.



Support for this product can be found here:

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	hbfgpostuser.png
Views:	1286
Size:	94.9 KB
ID:	152948   Click image for larger version

Name:	hbfgpost.png
Views:	1279
Size:	94.2 KB
ID:	152952   Click image for larger version

Name:	markfl_hbfg_acp.jpg
Views:	752
Size:	66.1 KB
ID:	155622  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Home Enhancements Hide Avatars And Signatures From Guests On A Forum Per Forum Basis borbole vBulletin 4.x Add-ons 15 06 Aug 2015 13:13
Hide Avatars & Signatures from Guests Zieen vBulletin 3.6 Template Modifications 27 27 May 2010 07:45

  #121  
Old 03 Jan 2019, 17:14
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by blade5000 View Post
it is about data attachments that are displayed
Please get the latest version here:

Hide BBCodes/Signatures From Guests/Users

And then describe exactly what the issue is. At present I don't know what you're asking.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #122  
Old 03 Jan 2019, 17:34
gnrx gnrx is offline
 
Join Date: Apr 2009
Like indicate MarkFL, I use this version on vb 4.2.5 and PHP 7.1 and work perfect.
Reply With Quote
  #123  
Old 28 Jan 2019, 20:27
gnrx gnrx is offline
 
Join Date: Apr 2009
Yesterday, a user indicate that, in some posts (only some posts) appear a error, in the first time I was think that are for other problem, because I don't view all code error that indicate this user to me.
In chrome (in my chrome) not appear, in chrome of the user, yes.
But appears always in Firefox.
This is the error code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I view this because, when disable all plugins, not appears, I enable all, and disable one at one, when disable this, then, the post/thread with error appears well.

Regards!
Reply With Quote
  #124  
Old 28 Jan 2019, 20:41
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Do you have your attachments in the database or in the file system?
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #125  
Old 28 Jan 2019, 21:31
gnrx gnrx is offline
 
Join Date: Apr 2009
Originally Posted by MarkFL View Post
Do you have your attachments in the database or in the file system?
I have set the avatars in database, attachments I don't remember that I have but after post thsi reply, I go to view.

For me its strange because, only I view this problem in one thread (but in one page of this thread) I don't know if appears in more threads.
I review all page of this thread, I don't view any strange.

Also, I view this problem: https://www.vbulletin.org/forum/showthread.php?t=327059 Just in the same page of the same thread.

A few days ago I convert the tables that I can convert in my database to innodb (I don't think this is the cause).

But with this 2 problems, if disable de plugin hide bbcodes and ibproarcade dissapears the error, but like indicate, at the moment only view in this page of this thread, others pages of the same thread any problem.
Reply With Quote
  #126  
Old 28 Jan 2019, 22:46
gnrx gnrx is offline
 
Join Date: Apr 2009
Sorry for the confusion.
I reupload all files from https://mathhelpboards.com/vbulletin...ers-22030.html and reinstall product.
Now, work fine.
Strange because, is the same version that I was have.
Only think that, a few days ago I migrate my site to another server...in the migration some corrupt file...? Is the only that I think.
Continue with the problem with ibproarcade, but this product, now, work fine.

Sorrys.
Reply With Quote
  #127  
Old 29 Jan 2019, 01:20
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Well, I'm glad reuploading the product seems to have fixed the issue. I've never had any such issue from this product.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #128  
Old 05 Feb 2019, 19:04
gnrx gnrx is offline
 
Join Date: Apr 2009
Hello (again )
Today I view some, that I think its normal, but question this for its possible change/edit or similar.
All work fine but today I view that, in archive forum (www.domain.com/archive.php) appears all hidde content.

I think that, isn't possible edit for work in archive forum, but if its possible, its good option.
At the moment, I disable archive forum.
If isn't possible work this mod in archive forum, its possible disable some forums in archive? (I know this last question aren't about this mod )

Thanks and regards!
Reply With Quote
  #129  
Old 05 Feb 2019, 19:14
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by gnrx View Post
Hello (again )
Today I view some, that I think its normal, but question this for its possible change/edit or similar.
All work fine but today I view that, in archive forum (www.domain.com/archive.php) appears all hidde content.

I think that, isn't possible edit for work in archive forum, but if its possible, its good option.
At the moment, I disable archive forum.
If isn't possible work this mod in archive forum, its possible disable some forums in archive? (I know this last question aren't about this mod )

Thanks and regards!
I've never archived any content, and so I know nothing about how that works.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #130  
Old 05 Feb 2019, 20:22
gnrx gnrx is offline
 
Join Date: Apr 2009
Originally Posted by MarkFL View Post
I've never archived any content, and so I know nothing about how that works.
Yes, at the moment, I disable archive function. For the info that I search in google, the archive its good for index of google, for example, but...I'm not sure about this...

Regards!
Reply With Quote
  #131  
Old 21 Feb 2019, 14:47
scotty's Avatar
scotty scotty is offline
 
Join Date: Oct 2001
after activating the following error:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

version 1.8.3 installed - where can I search for an error? Thanks!
Reply With Quote
  #132  
Old 21 Feb 2019, 16:27
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
What version of PHP are you running?
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #133  
Old 21 Feb 2019, 16:34
scotty's Avatar
scotty scotty is offline
 
Join Date: Oct 2001
Originally Posted by MarkFL View Post
What version of PHP are you running?
PHP Version 7.1.25
Reply With Quote
  #134  
Old 21 Feb 2019, 17:01
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Where are you storing your attachments?
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #135  
Old 21 Feb 2019, 17:28
scotty's Avatar
scotty scotty is offline
 
Join Date: Oct 2001
hm. in the filesystem. but I have only activated the "IMG" tag.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:44.

Layout Options | Width: Wide Color: