Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 20 Apr 2015, 01:29
hilaryl hilaryl is offline
 
Join Date: Jan 2006
'vBulletin' is null or not an object

Hi,

Some of our IE users have just started getting this error message. I have seen it in both IE8 and IE9 (not sure about later versions).


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

It seems to happen the first time a page loads, but if you refresh the page, it doesn't happen anymore.

There are other error messages that started happening at the same time, the only difference being the variable which is 'null or not an object'. One is 'vb_XHTML_ready' and the other is 'PHP'.

The 'PHP' variable error is the one that causes the most grief because it relates to the text editor so when people try and post, they get a message saying there aren't enough characters - but there are.

I believe what ever the cause is, is the issue for all the errors though.

I have attached a screenshot showing the message.

Nothing javascript related was altered before the error messages started appearing.

I understand IE8 is outdated, so it's not supported anymore - but we do have users who still use it, so would love to get the errors fixed up.

If anyone has any suggestions or advice, would love to hear it.

Cheers,
Taylor
Attached Images
File Type: png InternetExplorerError.png (24.5 KB, 33 views)
Reply With Quote
  #2  
Old 20 Apr 2015, 01:46
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
http://www.bubhub.com.au/community/forums/forum.php
update to 4.2.3
Reply With Quote
  #3  
Old 20 Apr 2015, 01:51
hilaryl hilaryl is offline
 
Join Date: Jan 2006
Why would we just start receiving these errors though?
Reply With Quote
  #4  
Old 20 Apr 2015, 02:15
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
Because IE is crap you should force members to upgrade there is a setting in the settings/options/Cookies and HTTP Header Options = Force Latest IE Mode = Yes
Reply With Quote
  #5  
Old 20 Apr 2015, 02:25
hilaryl hilaryl is offline
 
Join Date: Jan 2006
Although I agree that IE is crap, the reality is that people still use it and therefore it still causes issues.

We do have that option set to 'yes' about enforcing the latest IE mode.

I'm really hoping there is a fix to this - but still can't find anything anywhere.
Reply With Quote
  #6  
Old 20 Apr 2015, 03:04
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
The fix would come from IE and updating IE is the only fix I know
Reply With Quote
  #7  
Old 30 Apr 2015, 01:54
hilaryl hilaryl is offline
 
Join Date: Jan 2006
We are still having issue with this.

I understand IE8 is out-datted, but I don't understand why the issue just randomly started happening.

And also, why a simple refresh solves the issue most times.

Can anyone suggest any stupid fixes that can resolve this?

Our users are not tech savvy, and if they are using Internet Explorer it's because they don't know how to get an alternative, or can't update to the latest version.

If you want more info, please don't hesitate to ask.

Cheers
Reply With Quote
  #8  
Old 30 Apr 2015, 01:59
ForceHSS's Avatar
ForceHSS ForceHSS is offline
 
Join Date: Apr 2008
Why not make a post on your site with a download link to either the latest IE or another browser, but if you change the setting as I said above it would force their browser to open the update url for their outdated IE
Reply With Quote
  #9  
Old 01 May 2015, 02:29
hilaryl hilaryl is offline
 
Join Date: Jan 2006
Originally Posted by ForceHSS View Post
Why not make a post on your site with a download link to either the latest IE or another browser, but if you change the setting as I said above it would force their browser to open the update url for their outdated IE
We do have the option you suggested switched on, but it won't make a difference if you are running Windows XP, as you can only update to IE8 anyway.

A solution from our end to deal with IE inabilities would be ideal.
Reply With Quote
  #10  
Old 01 May 2015, 09:54
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Does it also happen on the default style of vBulletin?
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #11  
Old 05 May 2015, 04:48
hilaryl hilaryl is offline
 
Join Date: Jan 2006
Hi Dave,

No it doesn't seem to be happening in the Default Theme.

It doesn't happen in the Mobile Theme either.

I guess that means I need to investigate the difference between the two.
Reply With Quote
  #12  
Old 05 May 2015, 12:31
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Seems like a problem in the style in that case, could be because of colliding JavaScript files/scripts.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #13  
Old 05 May 2015, 23:22
hilaryl hilaryl is offline
 
Join Date: Jan 2006
Thumbs up Found It!

Originally Posted by Dave View Post
Seems like a problem in the style in that case, could be because of colliding JavaScript files/scripts.
Hi Dave,

After looking at the styles and actually going through and one by one deleting scripts that have always been on the page, I found one that fixed the issue.

It had always been there, but was updated by a third party without our knowledge, so we didn't know to look at it straight away.

Thanks for your default theme suggestion, I forgot I had the ability to easily change the style and compare the two.

The issue was still only limited to IE8, but it's good to know where it was coming from.

Thanks,
hilary
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:42.

Layout Options | Width: Wide Color: